OCamllabs icon Home|Differences with the last checks|Previous runs


Building on clete.ocamllabs.io

(from ocaml/opam:debian-unstable)
WARNING: Error loading config file: .dockercfg: $HOME is not defined
2021-10-20 23:34.41 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-2.1 /usr/bin/opam"))
2021-10-20 23:34.41 ---> using "4d29eb3e0b7cd69a97ed90837671d5ca38aa41e2fb94346298af500378eca6fa" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'git://github.com/ocaml/opam-repository.git' ~/opam-repository && git -C ~/opam-repository checkout -q 53ec9a45898dcacb426391da813c036212d8d3e6"))
2021-10-20 23:34.41 ---> using "9e3c71f07cb8650e76491f4ea4380e82b420e7db844fb7309f51d1856544743c" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2021-10-20 23:34.41 ---> using "27d1597f48f02b6b36c95df57225917e30e08bb54134379907bf74408f22b37a" from cache

/: (run (network host)
        (shell "git clone -q 'git://github.com/kit-ty-kate/multicore-opam.git' ~/'multicore' && git -C ~/'multicore' checkout -q f7d7c872ca1a40604219336dd1396c7873215005"))
2021-10-20 23:34.41 ---> using "6bddf57bc0a6e6d09869c0fa03a31ac63b5e62bd07859f843055286df02c2c0c" from cache

/: (run (shell "opam repository add --dont-select 'multicore' ~/'multicore'"))
[multicore] Initialised
2021-10-20 23:34.41 ---> using "848dc19b3061c50bbb8d2091adb8c29c6877c8906b6aeef2e1074d985eca8453" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=multicore,default 4.14.0+domains"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-variants" {= "4.14.0+domains"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> installed ocaml-option-nnp.1
-> retrieved ocaml-variants.4.14.0+domains  (git+https://github.com/ocaml-multicore/ocaml-multicore.git#5.00)
-> installed ocaml-variants.4.14.0+domains
-> installed ocaml-config.2
-> installed ocaml.4.14.0
-> installed base-domains.base
Done.
# Run eval $(opam env --switch=4.14.0+domains) to update the current shell environment
2021-10-20 23:34.41 ---> using "e2fb0b02a47bb4c88d48911a1aa263c18a49e49bba7a2b433a60b78a00357d70" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [165 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Ign:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages [8783 kB]
- Fetched 9012 kB in 4s (2080 kB/s)
- Reading package lists...
- 
2021-10-20 23:34.41 ---> using "c4a56b01fecd006f62b6f588c951b047efa8d10c90a8f7ad2401345008406bb0" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"OCanren.0.2.0\"\
               \nopam install -vy \"OCanren.0.2.0\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"OCanren.0.2.0\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \nif [ $res = 0 ]; then\
               \n    opam remove -y \"OCanren.0.2.0\"\
               \n    opam install -vty \"OCanren.0.2.0\"\
               \n    res=$?\
               \n    if [ $res = 20 ]; then\
               \n        res=0\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
Nothing to do.
[NOTE] OCanren.0.2.0 is not installed.

[ERROR] Package conflict!
  * No agreement on the version of ocaml:
    - (invariant) -> ocaml-variants = 4.14.0+domains -> ocaml >= 4.14.0
    - OCanren >= 0.2.0 -> camlp5 >= 8 -> ocaml < 4.11.1
    You can temporarily relax the switch invariant with `--update-invariant'

No solution found, exiting
'opam install -vy OCanren.0.2.0' failed.
"/bin/bash" "-c"
"
opam remove -y "OCanren.0.2.0"
opam install -vy "OCanren.0.2.0"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "OCanren.0.2.0" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi

if [ $res = 0 ]; then
    opam remove -y "OCanren.0.2.0"
    opam install -vty "OCanren.0.2.0"
    res=$?
    if [ $res = 20 ]; then
        res=0
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed