OCamllabs icon Home|Differences with the last checks|Previous runs


Building on x86-bm-6.ocamllabs.io

(from ocaml/opam:debian-unstable)
2021-10-21 03:57.08 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-2.1 /usr/bin/opam"))
2021-10-21 03:57.08 ---> using "4d29eb3e0b7cd69a97ed90837671d5ca38aa41e2fb94346298af500378eca6fa" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'git://github.com/ocaml/opam-repository.git' ~/opam-repository && git -C ~/opam-repository checkout -q 53ec9a45898dcacb426391da813c036212d8d3e6"))
2021-10-21 03:57.08 ---> using "9e3c71f07cb8650e76491f4ea4380e82b420e7db844fb7309f51d1856544743c" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2021-10-21 03:57.08 ---> using "27d1597f48f02b6b36c95df57225917e30e08bb54134379907bf74408f22b37a" from cache

/: (run (network host)
        (shell "git clone -q 'git://github.com/kit-ty-kate/multicore-opam.git' ~/'multicore' && git -C ~/'multicore' checkout -q f7d7c872ca1a40604219336dd1396c7873215005"))
2021-10-21 03:57.08 ---> using "6bddf57bc0a6e6d09869c0fa03a31ac63b5e62bd07859f843055286df02c2c0c" from cache

/: (run (shell "opam repository add --dont-select 'multicore' ~/'multicore'"))
[multicore] Initialised
2021-10-21 03:57.08 ---> using "848dc19b3061c50bbb8d2091adb8c29c6877c8906b6aeef2e1074d985eca8453" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=multicore,default 4.14.0+domains"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-variants" {= "4.14.0+domains"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> installed ocaml-option-nnp.1
-> retrieved ocaml-variants.4.14.0+domains  (git+https://github.com/ocaml-multicore/ocaml-multicore.git#5.00)
-> installed ocaml-variants.4.14.0+domains
-> installed ocaml-config.2
-> installed ocaml.4.14.0
-> installed base-domains.base
Done.
# Run eval $(opam env --switch=4.14.0+domains) to update the current shell environment
2021-10-21 03:57.08 ---> using "e2fb0b02a47bb4c88d48911a1aa263c18a49e49bba7a2b433a60b78a00357d70" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [165 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Ign:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages [8783 kB]
- Fetched 9012 kB in 5s (1646 kB/s)
- Reading package lists...
- 
2021-10-21 03:57.08 ---> using "c4a56b01fecd006f62b6f588c951b047efa8d10c90a8f7ad2401345008406bb0" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"conf-openblas.0.2.1\"\
               \nopam install -vy \"conf-openblas.0.2.1\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"conf-openblas.0.2.1\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \nif [ $res = 0 ]; then\
               \n    opam remove -y \"conf-openblas.0.2.1\"\
               \n    opam install -vty \"conf-openblas.0.2.1\"\
               \n    res=$?\
               \n    if [ $res = 20 ]; then\
               \n        res=0\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] conf-openblas.0.2.1 is not installed.

Nothing to do.
The following actions will be performed:
  - install conf-openblas 0.2.1

The following system packages will first need to be installed:
    liblapacke-dev libopenblas-dev

<><> Handling external dependencies <><><><><><><><><><><><><><><><><><><><><><>
Let opam run your package manager to install the required system packages?
(answer 'n' for other options) [Y/n] y
+ /usr/bin/sudo "apt-get" "install" "-qq" "-yy" "liblapacke-dev" "libopenblas-dev"
- debconf: delaying package configuration, since apt-utils is not installed
- (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 18039 files and directories currently installed.)
- Removing build-essential (12.9) ...
- Removing g++ (4:10.2.1-1) ...
- Removing gcc (4:10.2.1-1) ...
- Removing dpkg-dev (1.20.9) ...
- Removing g++-10 (10.2.1-6) ...
- Removing libstdc++-10-dev:amd64 (10.2.1-6) ...
- Removing gcc-10 (10.2.1-6) ...
- Removing binutils (2.37-4) ...
- Removing binutils-x86-64-linux-gnu (2.37-4) ...
- Removing libgcc-10-dev:amd64 (10.2.1-6) ...
- Removing libasan6:amd64 (11.2.0-2) ...
- Removing libcc1-0:amd64 (11.2.0-2) ...
- Removing libgomp1:amd64 (11.2.0-2) ...
- Removing liblsan0:amd64 (11.2.0-2) ...
- Removing libtsan0:amd64 (11.2.0-2) ...
- Removing libubsan1:amd64 (11.2.0-2) ...
- (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 16474 files and directories currently installed.)
- Preparing to unpack .../libquadmath0_11.2.0-9_amd64.deb ...
- Unpacking libquadmath0:amd64 (11.2.0-9) over (11.2.0-2) ...
- Preparing to unpack .../libitm1_11.2.0-9_amd64.deb ...
- Unpacking libitm1:amd64 (11.2.0-9) over (11.2.0-2) ...
- Preparing to unpack .../libatomic1_11.2.0-9_amd64.deb ...
- Unpacking libatomic1:amd64 (11.2.0-9) over (11.2.0-2) ...
- Preparing to unpack .../gcc-11-base_11.2.0-9_amd64.deb ...
- Unpacking gcc-11-base:amd64 (11.2.0-9) over (11.2.0-2) ...
- Setting up gcc-11-base:amd64 (11.2.0-9) ...
- (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 16474 files and directories currently installed.)
- Preparing to unpack .../libgcc-s1_11.2.0-9_amd64.deb ...
- Unpacking libgcc-s1:amd64 (11.2.0-9) over (10.2.1-6) ...
- Setting up libgcc-s1:amd64 (11.2.0-9) ...
- (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 16474 files and directories currently installed.)
- Preparing to unpack .../00-libctf0_2.37-7_amd64.deb ...
- Unpacking libctf0:amd64 (2.37-7) over (2.37-4) ...
- Preparing to unpack .../01-libbinutils_2.37-7_amd64.deb ...
- Unpacking libbinutils:amd64 (2.37-7) over (2.37-4) ...
- Preparing to unpack .../02-binutils-common_2.37-7_amd64.deb ...
- Unpacking binutils-common:amd64 (2.37-7) over (2.37-4) ...
- Selecting previously unselected package libgfortran5:amd64.
- Preparing to unpack .../03-libgfortran5_11.2.0-9_amd64.deb ...
- Unpacking libgfortran5:amd64 (11.2.0-9) ...
- Selecting previously unselected package libopenblas0-pthread:amd64.
- Preparing to unpack .../04-libopenblas0-pthread_0.3.18+ds-1_amd64.deb ...
- Unpacking libopenblas0-pthread:amd64 (0.3.18+ds-1) ...
- Selecting previously unselected package libtmglib3:amd64.
- Preparing to unpack .../05-libtmglib3_3.10.0-1_amd64.deb ...
- Unpacking libtmglib3:amd64 (3.10.0-1) ...
- Selecting previously unselected package liblapacke:amd64.
- Preparing to unpack .../06-liblapacke_3.10.0-1_amd64.deb ...
- Unpacking liblapacke:amd64 (3.10.0-1) ...
- Selecting previously unselected package libopenblas-pthread-dev:amd64.
- Preparing to unpack .../07-libopenblas-pthread-dev_0.3.18+ds-1_amd64.deb ...
- Unpacking libopenblas-pthread-dev:amd64 (0.3.18+ds-1) ...
- Selecting previously unselected package libtmglib-dev:amd64.
- Preparing to unpack .../08-libtmglib-dev_3.10.0-1_amd64.deb ...
- Unpacking libtmglib-dev:amd64 (3.10.0-1) ...
- Selecting previously unselected package liblapacke-dev:amd64.
- Preparing to unpack .../09-liblapacke-dev_3.10.0-1_amd64.deb ...
- Unpacking liblapacke-dev:amd64 (3.10.0-1) ...
- Selecting previously unselected package libopenblas0:amd64.
- Preparing to unpack .../10-libopenblas0_0.3.18+ds-1_amd64.deb ...
- Unpacking libopenblas0:amd64 (0.3.18+ds-1) ...
- Selecting previously unselected package libopenblas-dev:amd64.
- Preparing to unpack .../11-libopenblas-dev_0.3.18+ds-1_amd64.deb ...
- Unpacking libopenblas-dev:amd64 (0.3.18+ds-1) ...
- Setting up binutils-common:amd64 (2.37-7) ...
- Setting up libquadmath0:amd64 (11.2.0-9) ...
- Setting up libatomic1:amd64 (11.2.0-9) ...
- Setting up libgfortran5:amd64 (11.2.0-9) ...
- Setting up libbinutils:amd64 (2.37-7) ...
- Setting up libitm1:amd64 (11.2.0-9) ...
- Setting up libctf0:amd64 (2.37-7) ...
- Setting up libopenblas0-pthread:amd64 (0.3.18+ds-1) ...
- update-alternatives: using /usr/lib/x86_64-linux-gnu/openblas-pthread/libblas.so.3 to provide /usr/lib/x86_64-linux-gnu/libblas.so.3 (libblas.so.3-x86_64-linux-gnu) in auto mode
- update-alternatives: using /usr/lib/x86_64-linux-gnu/openblas-pthread/liblapack.so.3 to provide /usr/lib/x86_64-linux-gnu/liblapack.so.3 (liblapack.so.3-x86_64-linux-gnu) in auto mode
- update-alternatives: using /usr/lib/x86_64-linux-gnu/openblas-pthread/libopenblas.so.0 to provide /usr/lib/x86_64-linux-gnu/libopenblas.so.0 (libopenblas.so.0-x86_64-linux-gnu) in auto mode
- Setting up libtmglib3:amd64 (3.10.0-1) ...
- Setting up libopenblas0:amd64 (0.3.18+ds-1) ...
- Setting up liblapacke:amd64 (3.10.0-1) ...
- Setting up libopenblas-pthread-dev:amd64 (0.3.18+ds-1) ...
- update-alternatives: using /usr/lib/x86_64-linux-gnu/openblas-pthread/libblas.so to provide /usr/lib/x86_64-linux-gnu/libblas.so (libblas.so-x86_64-linux-gnu) in auto mode
- update-alternatives: using /usr/lib/x86_64-linux-gnu/openblas-pthread/liblapack.so to provide /usr/lib/x86_64-linux-gnu/liblapack.so (liblapack.so-x86_64-linux-gnu) in auto mode
- update-alternatives: using /usr/lib/x86_64-linux-gnu/openblas-pthread/libopenblas.so to provide /usr/lib/x86_64-linux-gnu/libopenblas.so (libopenblas.so-x86_64-linux-gnu) in auto mode
- Setting up libopenblas-dev:amd64 (0.3.18+ds-1) ...
- Setting up libtmglib-dev:amd64 (3.10.0-1) ...
- Setting up liblapacke-dev:amd64 (3.10.0-1) ...
- Processing triggers for libc-bin (2.31-15) ...

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Processing  2/3: [conf-openblas: sh cc $CFLAGS test.c -lopenblas]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "sh" "-exc" "cc $CFLAGS test.c -lopenblas" (CWD=/home/opam/.opam/4.14.0+domains/.opam-switch/build/conf-openblas.0.2.1)
- + cc test.c -lopenblas
- sh: 1: cc: not found
[ERROR] The compilation of conf-openblas.0.2.1 failed at "sh -exc cc $CFLAGS test.c -lopenblas".

#=== ERROR while compiling conf-openblas.0.2.1 ================================#
# context              2.1.0 | linux/x86_64 | ocaml-variants.4.14.0+domains | file:///home/opam/opam-repository
# path                 ~/.opam/4.14.0+domains/.opam-switch/build/conf-openblas.0.2.1
# command              ~/.opam/opam-init/hooks/sandbox.sh build sh -exc cc $CFLAGS test.c -lopenblas
# exit-code            127
# env-file             ~/.opam/log/conf-openblas-19-714e27.env
# output-file          ~/.opam/log/conf-openblas-19-714e27.out
### output ###
# + cc test.c -lopenblas
# sh: 1: cc: not found



<><> Error report <><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><>
+- The following actions failed
| - build conf-openblas 0.2.1
+- 
- No changes have been performed
# Run eval $(opam env) to update the current shell environment
'opam install -vy conf-openblas.0.2.1' failed.
"/bin/bash" "-c"
"
opam remove -y "conf-openblas.0.2.1"
opam install -vy "conf-openblas.0.2.1"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "conf-openblas.0.2.1" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi

if [ $res = 0 ]; then
    opam remove -y "conf-openblas.0.2.1"
    opam install -vty "conf-openblas.0.2.1"
    res=$?
    if [ $res = 20 ]; then
        res=0
    fi
fi


exit $res
" failed with exit status 31
Failed: Build failed