OCamllabs icon Home|Differences with the last checks|Previous runs


Building on c2-1.ocamllabs.io

(from ocaml/opam:debian-unstable@sha256:ca0a0544477c6a9a763f100587b518646c93ce73d78874d823b27e8f935bb951)
Unable to find image 'ocaml/opam:debian-unstable@sha256:ca0a0544477c6a9a763f100587b518646c93ce73d78874d823b27e8f935bb951' locally
docker.io/ocaml/opam@sha256:ca0a0544477c6a9a763f100587b518646c93ce73d78874d823b27e8f935bb951: Pulling from ocaml/opam
4ab10c654db5: Pulling fs layer
4ab10c654db5: Verifying Checksum
4ab10c654db5: Download complete
4ab10c654db5: Pull complete
Digest: sha256:ca0a0544477c6a9a763f100587b518646c93ce73d78874d823b27e8f935bb951
Status: Downloaded newer image for ocaml/opam@sha256:ca0a0544477c6a9a763f100587b518646c93ce73d78874d823b27e8f935bb951
2023-01-16 12:15.24 ---> using "94874f478e26ede84037b9b3ffc4aac7c83b2542bbac8788a2cc7da937a47054" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2023-01-16 12:15.24 ---> using "e2ed8ca10c7e97a3eeacb1721604176c2efe0af3ca6e435d47ef0dd2f6bd15ce" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q e0171a799fbb4458db77a10f76a6279727aac521"))
2023-01-16 12:15.24 ---> using "3864620b78a5bfd4a34825831d954f85d91d614ee4f51a2a653199fcbdb63f63" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2023-01-16 12:15.24 ---> using "4e975791caadc63ea7aadc58806396bb379155c55894dc8ed37de19ce13ba00b" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.04' '4.04.2'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.04.2"} | "ocaml-system" {= "4.04.2"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-base-compiler.4.04.2  (https://github.com/ocaml/ocaml/archive/4.04.2.tar.gz)
-> installed ocaml-base-compiler.4.04.2
-> installed ocaml-config.1
-> installed ocaml.4.04.2
Done.
# Run eval $(opam env --switch=4.04) to update the current shell environment
2023-01-16 12:15.24 ---> using "95b4af2fffa6d6e5a43b2e1d41e136221f41ee86f0483287382e4df04e328377" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [161 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2023-01-14-0804.37-F-2023-01-13-2043.11.pdiff [63.8 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2023-01-14-0804.37-F-2023-01-13-2043.11.pdiff [63.8 kB]
- Fetched 289 kB in 2s (132 kB/s)
- Reading package lists...
- 
2023-01-16 12:15.24 ---> using "23ba4f87a536828d71856324121cfb6d15de8ac68d7a9966b9884feea63bf2c2" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam install -y ocaml-secondary-compiler"))
The following actions will be performed:
=== install 1 package
  - install ocaml-secondary-compiler 4.08.1-1

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved ocaml-secondary-compiler.4.08.1-1  (cached)
-> installed ocaml-secondary-compiler.4.08.1-1
Done.
# Run eval $(opam env) to update the current shell environment
2023-01-16 12:15.24 ---> using "a86b23e9e28dc0e00585a7acef8b6edcdff895ad2c97ad0e5debc7bebc3c5f17" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"OCanren-ppx.0.3.0\"\
               \nopam install -vy \"OCanren-ppx.0.3.0\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"OCanren-ppx.0.3.0\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] OCanren-ppx.0.3.0 is not installed.

Nothing to do.
[ERROR] Package conflict!
No solution found, exiting
  * No agreement on the version of ocaml:
    - (invariant) -> ocaml-base-compiler = 4.04.2 -> ocaml = 4.04.2
    - OCanren-ppx >= 0.3.0 -> ocaml >= 4.10
    You can temporarily relax the switch invariant with `--update-invariant'
  * No agreement on the version of ocaml-base-compiler:
    - (invariant) -> ocaml-base-compiler = 4.04.2
    - OCanren-ppx >= 0.3.0 -> ocaml >= 4.10 -> ocaml-base-compiler >= 4.12.0~
  * Missing dependency:
    - OCanren-ppx >= 0.3.0 -> ocaml >= 4.10 -> ocaml-variants < 4.10.4~ -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'
  * Missing dependency:
    - OCanren-ppx >= 0.3.0 -> ocaml >= 4.10 -> ocaml-variants >= 4.10.0 -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'

'opam install -vy OCanren-ppx.0.3.0' failed.
"/bin/bash" "-c"
"
opam remove -y "OCanren-ppx.0.3.0"
opam install -vy "OCanren-ppx.0.3.0"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "OCanren-ppx.0.3.0" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed