OCamllabs icon Home|Differences with the last checks|Previous runs


Building on x86-bm-3.ocamllabs.io

(from ocaml/opam:debian-unstable@sha256:5d9d58dd88e8e3a7a3c180578c753118efcfd5a451781452c6731c99fc9e27dd)
2022-11-15 08:18.13 ---> using "32efe2878d8713cc073fbcba05b477fab5020dac81ac1f841ea37ae67b4d70a6" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2022-11-15 08:18.13 ---> using "c06b21e9e23147ff65065b0caeb2932b761f6e4408d2fb429e6eafaede540fdc" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q 88d0c6b952c255f868635fbb4c8bc650f1fa4fd8"))
2022-11-15 08:18.13 ---> using "f5ff03689bfa4493e0d56b41d99787e727484001ba6ca3d348cc9bb14b0a105c" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2022-11-15 08:18.13 ---> using "c8ce34507d61810fd57bc948c6ee6daad97dafa9d9e05febabf80edf14a81a6c" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '5.0' '5.0.0+trunk'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-variants" {= "5.0.0+trunk"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-variants.5.0.0+trunk  (https://github.com/ocaml/ocaml/archive/5.0.tar.gz)
-> installed ocaml-variants.5.0.0+trunk
-> installed ocaml-config.3
-> installed ocaml.5.0.0
-> installed base-domains.base
-> installed base-nnp.base
Done.
# Run eval $(opam env --switch=5.0) to update the current shell environment
2022-11-15 08:18.13 ---> using "c6c73e13f5e19c64be4f400c93a23756e111ae920a94d606e70d16576e463f96" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [161 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2022-11-15-0207.35-F-2022-11-08-2013.29.pdiff [530 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2022-11-15-0207.35-F-2022-11-08-2013.29.pdiff [530 kB]
- Fetched 755 kB in 2s (429 kB/s)
- Reading package lists...
- 
2022-11-15 08:18.13 ---> using "73b52a8b4ccd1f833918ef98fc69a3f7899a8b7db82533dede98ecefb9787056" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"anycache.0.7.4\"\
               \nopam install -vy \"anycache.0.7.4\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"anycache.0.7.4\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] anycache.0.7.4 is not installed.

Nothing to do.
[ERROR] Package conflict!
  * No agreement on the version of ocaml:
    - (invariant) -> ocaml-variants = 5.0.0+trunk -> ocaml = 5.0.0
    - anycache >= 0.7.4 -> lru = 0.2.0 -> ocaml < 5.0
    You can temporarily relax the switch invariant with `--update-invariant'
  * No agreement on the version of ocaml-variants:
    - (invariant) -> ocaml-variants = 5.0.0+trunk
    - anycache >= 0.7.4 -> lru = 0.2.0 -> ocaml < 5.0 -> ocaml-variants < 4.00.1~
  * Missing dependency:
    - anycache >= 0.7.4 -> lru = 0.2.0 -> ocaml < 5.0 -> ocaml-variants < 4.08.1~ -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'
  * Missing dependency:
    - anycache >= 0.7.4 -> lru = 0.2.0 -> ocaml < 5.0 -> ocaml-variants < 4.08.3~ -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'
  * Missing dependency:
    - anycache >= 0.7.4 -> lru = 0.2.0 -> ocaml < 5.0 -> ocaml-variants < 4.09.2~ -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'
  * Missing dependency:
    - anycache >= 0.7.4 -> lru = 0.2.0 -> ocaml < 5.0 -> ocaml-variants < 4.10.4~ -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'
  * Missing dependency:
    - anycache >= 0.7.4 -> lru = 0.2.0 -> ocaml < 5.0 -> ocaml-variants < 4.11.4~ -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'

No solution found, exiting
'opam install -vy anycache.0.7.4' failed.
"/bin/bash" "-c"
"
opam remove -y "anycache.0.7.4"
opam install -vy "anycache.0.7.4"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "anycache.0.7.4" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed