OCamllabs icon Home|Differences with the last checks|Previous runs


Building on x86-bm-10.ocamllabs.io

(from ocaml/opam:debian-unstable@sha256:5d9d58dd88e8e3a7a3c180578c753118efcfd5a451781452c6731c99fc9e27dd)
2022-11-15 07:44.44 ---> using "32efe2878d8713cc073fbcba05b477fab5020dac81ac1f841ea37ae67b4d70a6" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2022-11-15 07:44.44 ---> using "c06b21e9e23147ff65065b0caeb2932b761f6e4408d2fb429e6eafaede540fdc" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q 88d0c6b952c255f868635fbb4c8bc650f1fa4fd8"))
2022-11-15 07:44.44 ---> using "f5ff03689bfa4493e0d56b41d99787e727484001ba6ca3d348cc9bb14b0a105c" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2022-11-15 07:44.44 ---> using "c8ce34507d61810fd57bc948c6ee6daad97dafa9d9e05febabf80edf14a81a6c" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.11' '4.11.2'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.11.2"} | "ocaml-system" {= "4.11.2"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-base-compiler.4.11.2  (cached)
-> installed ocaml-base-compiler.4.11.2
-> installed ocaml-config.1
-> installed ocaml.4.11.2
Done.
# Run eval $(opam env --switch=4.11) to update the current shell environment
2022-11-15 07:45.48 ---> saved as "825b81de5431bca8b6cd0a2e6400b4b6e8b59938299df02c1f6586b107913a7a"

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [161 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2022-11-15-0207.35-F-2022-11-08-2013.29.pdiff [530 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2022-11-15-0207.35-F-2022-11-08-2013.29.pdiff [530 kB]
- Fetched 755 kB in 2s (356 kB/s)
- Reading package lists...
- 
2022-11-15 07:45.52 ---> saved as "7f3abeb11755f9da014e771c854cf29136674b8be9199d4c89d77ecde46bc8a6"

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"GuaCaml.0.05\"\
               \nopam install -vy \"GuaCaml.0.05\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"GuaCaml.0.05\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] GuaCaml.0.05 is not installed.

Nothing to do.
[ERROR] Package conflict!
  * No agreement on the version of ocaml:
    - (invariant) -> ocaml-base-compiler = 4.11.2 -> ocaml = 4.11.2
    - GuaCaml >= 0.05 -> ocaml >= 4.13
    You can temporarily relax the switch invariant with `--update-invariant'
  * Incompatible packages:
    - (invariant) -> ocaml-base-compiler = 4.11.2
    - GuaCaml >= 0.05 -> ocaml >= 4.13 -> ocaml-variants < 5.1.1~
  * Missing dependency:
    - GuaCaml >= 0.05 -> ocaml >= 4.13 -> ocaml-variants < 5.1.1~ -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'

'opam install -vy GuaCaml.0.05' failed.
No solution found, exiting
"/bin/bash" "-c"
"
opam remove -y "GuaCaml.0.05"
opam install -vy "GuaCaml.0.05"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "GuaCaml.0.05" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed