OCamllabs icon Home|Differences with the last checks|Previous runs


Building on x86-bm-12.ocamllabs.io

(from ocaml/opam:debian-unstable@sha256:a20618cee40a09b4c7604919411db28c4ae473b9780730085f91824e8dd5f205)
2022-09-02 11:41.46 ---> using "00583e82ec888c922d57db664b8acb62b642829c5a4a94b17a44e5693b1db2de" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2022-09-02 11:41.46 ---> using "f816199fc982412d3ea70ae1ae1bab135eea82bc7670ac5d731bc57d0733e3c4" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q 418227c38ed4e28a0827786e5e9e50b9547c0b27"))
2022-09-02 11:41.46 ---> using "4cabcce7a0cb6de31986471b51abc9f1f3fec6a75be6e83e549da867c7605e5a" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2022-09-02 11:41.46 ---> using "d451da695ab21573c7bdead4176eec083b0218f568c4ccf5f5b38b162d64d4d7" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '5.0' '5.0.0+trunk'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-variants" {= "5.0.0+trunk"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-variants.5.0.0+trunk  (https://github.com/ocaml/ocaml/archive/5.0.tar.gz)
-> installed ocaml-variants.5.0.0+trunk
-> installed ocaml-config.3
-> installed ocaml.5.0.0
-> installed base-domains.base
-> installed base-nnp.base
Done.
# Run eval $(opam env --switch=5.0) to update the current shell environment
2022-09-02 11:41.46 ---> using "5bc990c8a0647da2e23ec22566486efbe51ed48c10d9c0bbf84182f89092b273" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [192 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2022-09-02-0804.09-F-2022-08-29-1405.22.pdiff [252 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2022-09-02-0804.09-F-2022-08-29-1405.22.pdiff [252 kB]
- Fetched 508 kB in 2s (242 kB/s)
- Reading package lists...
2022-09-02 11:41.46 ---> using "507cd89f6f8cc3b24b7682bb3eef7cab87c7b66eeeb6cc63a0d217140b118223" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"alt-ergo-parsers-free.2.3.3.dune3\"\
               \nopam install -vy \"alt-ergo-parsers-free.2.3.3.dune3\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"alt-ergo-parsers-free.2.3.3.dune3\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] alt-ergo-parsers-free.2.3.3.dune3 is not installed.

Nothing to do.
[ERROR] Package conflict!
  * No agreement on the version of ocaml:
    - (invariant) -> ocaml-variants = 5.0.0+trunk -> ocaml = 5.0.0
    - alt-ergo-parsers-free >= 2.3.3.dune3 -> ocaml < 4.07.0
    You can temporarily relax the switch invariant with `--update-invariant'
  * No agreement on the version of ocaml-variants:
    - (invariant) -> ocaml-variants = 5.0.0+trunk
    - alt-ergo-parsers-free >= 2.3.3.dune3 -> ocaml < 4.07.0 -> ocaml-variants < 4.01.1~

No solution found, exiting
'opam install -vy alt-ergo-parsers-free.2.3.3.dune3' failed.
"/bin/bash" "-c"
"
opam remove -y "alt-ergo-parsers-free.2.3.3.dune3"
opam install -vy "alt-ergo-parsers-free.2.3.3.dune3"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "alt-ergo-parsers-free.2.3.3.dune3" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed