OCamllabs icon Home|Differences with the last checks|Previous runs


Building on x86-bm-5.ocamllabs.io

(from ocaml/opam:debian-unstable@sha256:a20618cee40a09b4c7604919411db28c4ae473b9780730085f91824e8dd5f205)
Unable to find image 'ocaml/opam:debian-unstable@sha256:a20618cee40a09b4c7604919411db28c4ae473b9780730085f91824e8dd5f205' locally
docker.io/ocaml/opam@sha256:a20618cee40a09b4c7604919411db28c4ae473b9780730085f91824e8dd5f205: Pulling from ocaml/opam
f8f85475deda: Pulling fs layer
f8f85475deda: Download complete
f8f85475deda: Pull complete
Digest: sha256:a20618cee40a09b4c7604919411db28c4ae473b9780730085f91824e8dd5f205
Status: Downloaded newer image for ocaml/opam@sha256:a20618cee40a09b4c7604919411db28c4ae473b9780730085f91824e8dd5f205
2022-09-02 11:26.28 ---> using "00583e82ec888c922d57db664b8acb62b642829c5a4a94b17a44e5693b1db2de" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2022-09-02 11:26.28 ---> using "f816199fc982412d3ea70ae1ae1bab135eea82bc7670ac5d731bc57d0733e3c4" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q 418227c38ed4e28a0827786e5e9e50b9547c0b27"))
2022-09-02 11:26.28 ---> using "4cabcce7a0cb6de31986471b51abc9f1f3fec6a75be6e83e549da867c7605e5a" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2022-09-02 11:26.28 ---> using "d451da695ab21573c7bdead4176eec083b0218f568c4ccf5f5b38b162d64d4d7" from cache

/: (run (network host)
        (shell "git clone -q 'https://github.com/kit-ty-kate/opam-alpha-repository' ~/'alpha' && git -C ~/'alpha' checkout -q 6c5c682bd9208419bc24faaa163e42e74cb4e9a5"))
2022-09-02 11:26.28 ---> using "6df2c126a9b1ccede02c2b3fd26d0561e2107be8c6304477ccb8de0a479f33c1" from cache

/: (run (shell "opam repository add --dont-select 'alpha' ~/'alpha'"))
[alpha] Initialised
2022-09-02 11:26.28 ---> using "36c2866864e62ed4ca7db324088339d0b6f8bfe49e44038af6b20b9d54e88efd" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=alpha,default '5.0+alpha-repo' '5.0.0+trunk'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-variants" {= "5.0.0+trunk"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-variants.5.0.0+trunk  (https://github.com/ocaml/ocaml/archive/5.0.tar.gz)
-> installed ocaml-variants.5.0.0+trunk
-> installed ocaml-config.3
-> installed ocaml.5.0.0
-> installed base-domains.base
-> installed base-nnp.base
Done.
# Run eval $(opam env --switch=5.0+alpha-repo) to update the current shell environment
2022-09-02 11:26.28 ---> using "d0af8b0acc9dfb423091d8298ed9937c524ea943b8afa3166209172a10c7c646" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [192 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2022-09-02-0804.09-F-2022-08-29-1405.22.pdiff [252 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2022-09-02-0804.09-F-2022-08-29-1405.22.pdiff [252 kB]
- Fetched 508 kB in 2s (259 kB/s)
- Reading package lists...
2022-09-02 11:26.28 ---> using "26b19488803a26f98ff4a26939ab35d3570fd165e979664e48d2aced1a5c2b5a" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"accessor_async.v0.15.0\"\
               \nopam install -vy \"accessor_async.v0.15.0\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"accessor_async.v0.15.0\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
Nothing to do.
[NOTE] accessor_async.v0.15.0 is not installed.

The following actions will be performed:
=== install 66 packages
  - install accessor                    v0.15.0              [required by accessor_base]
  - install accessor_async              v0.15.0
  - install accessor_base               v0.15.0              [required by accessor_core]
  - install accessor_core               v0.15.0              [required by accessor_async]
  - install async_kernel                v0.15.0              [required by accessor_async]
  - install base                        v0.15.1~5.0preview   [required by core, accessor_base, core_kernel]
  - install base_bigstring              v0.15.0              [required by core]
  - install base_quickcheck             v0.15.0              [required by core]
  - install bin_prot                    v0.15.0              [required by core]
  - install core                        v0.15.0.1~alpha-repo [required by accessor_async]
  - install core_kernel                 v0.15.0              [required by async_kernel]
  - install csexp                       1.5.1                [required by dune-configurator]
  - install dune                        3.4.1                [required by accessor_async]
  - install dune-configurator           3.4.1                [required by base]
  - install fieldslib                   v0.15.0              [required by core]
  - install higher_kinded               v0.15.0              [required by accessor_base]
  - install int_repr                    v0.15.0              [required by core_kernel]
  - install jane-street-headers         v0.15.0              [required by core]
  - install jst-config                  v0.15.1              [required by core]
  - install num                         1.4                  [required by sexplib]
  - install ocaml-compiler-libs         v0.12.4              [required by ppxlib]
  - install ocamlfind                   1.9.5                [required by num]
  - install parsexp                     v0.15.0              [required by sexplib]
  - install ppx_accessor                v0.15.0              [required by accessor_async]
  - install ppx_assert                  v0.15.0              [required by core]
  - install ppx_base                    v0.15.0              [required by core]
  - install ppx_bench                   v0.15.0              [required by ppx_jane]
  - install ppx_bin_prot                v0.15.0              [required by ppx_jane]
  - install ppx_cold                    v0.15.0              [required by ppx_base]
  - install ppx_compare                 v0.15.0              [required by ppx_base, bin_prot]
  - install ppx_custom_printf           v0.15.0              [required by ppx_jane]
  - install ppx_derivers                1.2.1                [required by ppxlib]
  - install ppx_disable_unused_warnings v0.15.0              [required by ppx_jane]
  - install ppx_enumerate               v0.15.0              [required by ppx_base]
  - install ppx_expect                  v0.15.0.1~alpha-repo [required by ppx_jane]
  - install ppx_fields_conv             v0.15.0              [required by ppx_jane]
  - install ppx_fixed_literal           v0.15.0              [required by ppx_jane]
  - install ppx_hash                    v0.15.0              [required by core]
  - install ppx_here                    v0.15.0              [required by ppx_jane]
  - install ppx_ignore_instrumentation  v0.15.0              [required by ppx_jane]
  - install ppx_inline_test             v0.15.0              [required by core]
  - install ppx_jane                    v0.15.0              [required by accessor_async]
  - install ppx_let                     v0.15.0              [required by ppx_jane]
  - install ppx_log                     v0.15.0              [required by ppx_jane]
  - install ppx_module_timer            v0.15.0              [required by ppx_jane]
  - install ppx_optcomp                 v0.15.0              [required by ppx_jane]
  - install ppx_optional                v0.15.0              [required by ppx_jane]
  - install ppx_pipebang                v0.15.0              [required by ppx_jane]
  - install ppx_sexp_conv               v0.15.1              [required by core]
  - install ppx_sexp_message            v0.15.0              [required by core]
  - install ppx_sexp_value              v0.15.0              [required by ppx_jane]
  - install ppx_stable                  v0.15.0              [required by ppx_jane]
  - install ppx_string                  v0.15.0              [required by ppx_jane]
  - install ppx_typerep_conv            v0.15.0              [required by ppx_jane]
  - install ppx_variants_conv           v0.15.0              [required by ppx_jane]
  - install ppxlib                      0.27.0               [required by ppx_accessor]
  - install re                          1.10.4               [required by ppx_expect]
  - install seq                         base                 [required by re]
  - install sexplib                     v0.15.1              [required by core]
  - install sexplib0                    v0.15.1              [required by base]
  - install splittable_random           v0.15.0              [required by core]
  - install stdio                       v0.15.0              [required by core]
  - install stdlib-shims                0.3.0                [required by ppxlib]
  - install time_now                    v0.15.0              [required by core]
  - install typerep                     v0.15.0              [required by core]
  - install variantslib                 v0.15.0              [required by core]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Processing  1/197: [accessor.v0.15.0: http]
Processing  2/197: [accessor.v0.15.0: http] [accessor_async.v0.15.0: http]
Processing  3/197: [accessor.v0.15.0: http] [accessor_async.v0.15.0: http] [accessor_base.v0.15.0: http]
Processing  3/197: [accessor.v0.15.0: http] [accessor_base.v0.15.0: http]
-> retrieved accessor_async.v0.15.0  (https://ocaml.janestreet.com/ocaml-core/v0.15/files/accessor_async-v0.15.0.tar.gz)
Processing  4/197: [accessor.v0.15.0: http] [accessor_base.v0.15.0: http] [accessor_core.v0.15.0: http]
Processing  4/197: [accessor.v0.15.0: http] [accessor_core.v0.15.0: http]
-> retrieved accessor_base.v0.15.0  (https://ocaml.janestreet.com/ocaml-core/v0.15/files/accessor_base-v0.15.0.tar.gz)
Processing  5/197: [accessor.v0.15.0: http] [accessor_core.v0.15.0: http]
Processing  5/197: [accessor_core.v0.15.0: http]
-> retrieved async_kernel.v0.15.0  (cached)
Processing  6/197: [accessor_core.v0.15.0: http] [base.v0.15.1~5.0preview: git]
-> retrieved accessor.v0.15.0  (https://ocaml.janestreet.com/ocaml-core/v0.15/files/accessor-v0.15.0.tar.gz)
Processing  7/197: [accessor_core.v0.15.0: http] [base.v0.15.1~5.0preview: git]
Processing  7/197: [base.v0.15.1~5.0preview: git]
-> retrieved base_bigstring.v0.15.0  (cached)
Processing  8/197: [base.v0.15.1~5.0preview: git]
-> retrieved accessor_core.v0.15.0  (https://ocaml.janestreet.com/ocaml-core/v0.15/files/accessor_core-v0.15.0.tar.gz)
Processing  9/197: [base.v0.15.1~5.0preview: git]
-> retrieved base_quickcheck.v0.15.0  (cached)
Processing 10/197: [base.v0.15.1~5.0preview: git] [core.v0.15.0.1~alpha-repo: http]
-> retrieved bin_prot.v0.15.0  (cached)
Processing 11/197: [base.v0.15.1~5.0preview: git] [core.v0.15.0.1~alpha-repo: http]
-> retrieved core_kernel.v0.15.0  (cached)
Processing 12/197: [base.v0.15.1~5.0preview: git] [core.v0.15.0.1~alpha-repo: http]
-> retrieved csexp.1.5.1  (cached)
Processing 13/197: [base.v0.15.1~5.0preview: git] [core.v0.15.0.1~alpha-repo: http]
Processing 13/197: [base.v0.15.1~5.0preview: git]
-> retrieved core.v0.15.0.1~alpha-repo  (https://github.com/kit-ty-kate/core/archive/500.tar.gz)
Processing 14/197: [base.v0.15.1~5.0preview: git]
-> retrieved fieldslib.v0.15.0  (cached)
Processing 15/197: [base.v0.15.1~5.0preview: git]
-> retrieved higher_kinded.v0.15.0  (cached)
Processing 16/197: [base.v0.15.1~5.0preview: git]
-> retrieved int_repr.v0.15.0  (cached)
Processing 17/197: [base.v0.15.1~5.0preview: git]
-> retrieved jane-street-headers.v0.15.0  (cached)
Processing 18/197: [base.v0.15.1~5.0preview: git]
-> retrieved jst-config.v0.15.1  (cached)
Processing 19/197: [base.v0.15.1~5.0preview: git]
-> retrieved num.1.4  (cached)
Processing 20/197: [base.v0.15.1~5.0preview: git]
-> retrieved ocaml-compiler-libs.v0.12.4  (cached)
Processing 21/197: [base.v0.15.1~5.0preview: git]
-> retrieved ocamlfind.1.9.5  (cached)
Processing 22/197: [base.v0.15.1~5.0preview: git]
[ocamlfind: patch] applying 0001-Fix-bug-when-installing-with-a-system-compiler.patch
Processing 23/197: [base.v0.15.1~5.0preview: git] [ocamlfind: patch]
-> retrieved parsexp.v0.15.0  (cached)
Processing 24/197: [base.v0.15.1~5.0preview: git] [ocamlfind: patch]
-> retrieved dune.3.4.1, dune-configurator.3.4.1  (cached)
Processing 25/197: [base.v0.15.1~5.0preview: git] [ocamlfind: patch]
Processing 26/197: [base.v0.15.1~5.0preview: git] [dune: ocaml bootstrap.ml] [ocamlfind: patch]
Processing 26/197: [base.v0.15.1~5.0preview: git] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_accessor.v0.15.0  (cached)
Processing 27/197: [base.v0.15.1~5.0preview: git] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_assert.v0.15.0  (cached)
Processing 28/197: [base.v0.15.1~5.0preview: git] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_base.v0.15.0  (cached)
Processing 29/197: [base.v0.15.1~5.0preview: git] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_bench.v0.15.0  (cached)
Processing 30/197: [base.v0.15.1~5.0preview: git] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_bin_prot.v0.15.0  (cached)
Processing 31/197: [base.v0.15.1~5.0preview: git] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_cold.v0.15.0  (cached)
Processing 32/197: [base.v0.15.1~5.0preview: git] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_compare.v0.15.0  (cached)
Processing 33/197: [base.v0.15.1~5.0preview: git] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_custom_printf.v0.15.0  (cached)
Processing 34/197: [base.v0.15.1~5.0preview: git] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_derivers.1.2.1  (cached)
Processing 35/197: [base.v0.15.1~5.0preview: git] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_disable_unused_warnings.v0.15.0  (cached)
Processing 36/197: [base.v0.15.1~5.0preview: git] [ppx_expect.v0.15.0.1~alpha-repo: http] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_enumerate.v0.15.0  (cached)
Processing 37/197: [base.v0.15.1~5.0preview: git] [ppx_expect.v0.15.0.1~alpha-repo: http] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_fields_conv.v0.15.0  (cached)
Processing 38/197: [base.v0.15.1~5.0preview: git] [ppx_expect.v0.15.0.1~alpha-repo: http] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_fixed_literal.v0.15.0  (cached)
Processing 39/197: [base.v0.15.1~5.0preview: git] [ppx_expect.v0.15.0.1~alpha-repo: http] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_hash.v0.15.0  (cached)
Processing 40/197: [base.v0.15.1~5.0preview: git] [ppx_expect.v0.15.0.1~alpha-repo: http] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_here.v0.15.0  (cached)
Processing 41/197: [base.v0.15.1~5.0preview: git] [ppx_expect.v0.15.0.1~alpha-repo: http] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_ignore_instrumentation.v0.15.0  (cached)
Processing 42/197: [base.v0.15.1~5.0preview: git] [ppx_expect.v0.15.0.1~alpha-repo: http] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_inline_test.v0.15.0  (cached)
Processing 43/197: [base.v0.15.1~5.0preview: git] [ppx_expect.v0.15.0.1~alpha-repo: http] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_jane.v0.15.0  (cached)
Processing 44/197: [base.v0.15.1~5.0preview: git] [ppx_expect.v0.15.0.1~alpha-repo: http] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_let.v0.15.0  (cached)
Processing 45/197: [base.v0.15.1~5.0preview: git] [ppx_expect.v0.15.0.1~alpha-repo: http] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_log.v0.15.0  (cached)
Processing 46/197: [base.v0.15.1~5.0preview: git] [ppx_expect.v0.15.0.1~alpha-repo: http] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
Processing 46/197: [base.v0.15.1~5.0preview: git] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_module_timer.v0.15.0  (cached)
Processing 47/197: [base.v0.15.1~5.0preview: git] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_expect.v0.15.0.1~alpha-repo  (https://github.com/kit-ty-kate/ppx_expect/archive/500-015.tar.gz)
Processing 48/197: [base.v0.15.1~5.0preview: git] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_optcomp.v0.15.0  (cached)
Processing 49/197: [base.v0.15.1~5.0preview: git] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
-> retrieved ppx_optional.v0.15.0  (cached)
Processing 50/197: [base.v0.15.1~5.0preview: git] [dune: ocaml bootstrap.ml] [ocamlfind: ./configure]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "./configure" "-bindir" "/home/opam/.opam/5.0+alpha-repo/bin" "-sitelib" "/home/opam/.opam/5.0+alpha-repo/lib" "-mandir" "/home/opam/.opam/5.0+alpha-repo/man" "-config" "/home/opam/.opam/5.0+alpha-repo/lib/findlib.conf" "-no-custom" "-no-camlp4" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ocamlfind.1.9.5)
- Welcome to findlib version 1.9.5
- Configuring core...
- Checking for #remove_directory...
- Testing threading model...
- systhread_supported: true
- Testing DLLs...
- Testing whether ppxopt can be supported...
- Checking for ocamlc -opaque...
- Querying installation: META list not found
- make install will double-check installed META files
- Configuring libraries...
- unix: found (in +unix)
- dynlink: found (in +dynlink)
- bigarray: not present (possible since 4.08)
- compiler-libs: found
- dbm: not present (normal since 4.00)
- graphics: not present (normal since 4.09)
- num: not present (normal since 4.06)
- ocamlbuild: not present (normal since 4.03)
- ocamldoc: found (in +ocamldoc)
- raw_spacetime: not present (normal since 4.12)
- threads: found (in +threads)
- runtime_events: found (in +runtime_events)
- str: found (in +str)
- labltk: not present (normal since 4.02)
- native dynlink: found
- camlp4: disabled
- bytes: found, installing fake library
- Configuration for stdlib written to site-lib-src/stdlib/META
- Configuration for unix written to site-lib-src/unix/META
- Configuration for dynlink written to site-lib-src/dynlink/META
- Configuration for compiler-libs written to site-lib-src/compiler-libs/META
- Configuration for ocamldoc written to site-lib-src/ocamldoc/META
- Configuration for threads written to site-lib-src/threads/META
- Configuration for runtime_events written to site-lib-src/runtime_events/META
- Configuration for str written to site-lib-src/str/META
- Configuration for bytes written to site-lib-src/bytes/META
- Detecting compiler arguments: (extractor built) ok
- 
- About the OCAML core installation:
-     Standard library:      /home/opam/.opam/5.0+alpha-repo/lib/ocaml
-     Binaries:              /home/opam/.opam/5.0+alpha-repo/bin
-     Manual pages:          /home/opam/.opam/5.0+alpha-repo/man
-     Multi-threading type:  posix
- The directory of site-specific packages will be
-     site-lib:              /home/opam/.opam/5.0+alpha-repo/lib
- The configuration file is written to:
-     findlib config file:   /home/opam/.opam/5.0+alpha-repo/lib/findlib.conf
- Software will be installed:
-     Libraries:             in <site-lib>/findlib
-     Binaries:              /home/opam/.opam/5.0+alpha-repo/bin
-     Manual pages:          /home/opam/.opam/5.0+alpha-repo/man
-     topfind script:        /home/opam/.opam/5.0+alpha-repo/lib/ocaml
- Topfind ppxopt support:    yes
- Toolbox:                   no
- Link custom runtime:       no
- Need bytes compatibility:  no
- 
- Configuration has been written to Makefile.config
- 
- You can now do 'make all', and optionally 'make opt', to build ocamlfind.
Processing 50/197: [base.v0.15.1~5.0preview: git] [dune: ocaml bootstrap.ml] [ocamlfind: make all]
-> retrieved ppx_pipebang.v0.15.0  (cached)
Processing 51/197: [base.v0.15.1~5.0preview: git] [dune: ocaml bootstrap.ml] [ocamlfind: make all]
-> retrieved ppx_sexp_conv.v0.15.1  (cached)
Processing 52/197: [base.v0.15.1~5.0preview: git] [dune: ocaml bootstrap.ml] [ocamlfind: make all]
-> retrieved ppx_sexp_message.v0.15.0  (cached)
Processing 53/197: [base.v0.15.1~5.0preview: git] [dune: ocaml bootstrap.ml] [ocamlfind: make all]
-> retrieved ppx_sexp_value.v0.15.0  (cached)
Processing 54/197: [base.v0.15.1~5.0preview: git] [dune: ocaml bootstrap.ml] [ocamlfind: make all]
-> retrieved base.v0.15.1~5.0preview  (git+https://github.com/kit-ty-kate/base#500-015)
Processing 54/197: [dune: ocaml bootstrap.ml] [ocamlfind: make all]
Processing 55/197: [dune: ocaml bootstrap.ml] [ocamlfind: make all]
-> retrieved ppx_stable.v0.15.0  (cached)
Processing 56/197: [dune: ocaml bootstrap.ml] [ocamlfind: make all]
-> retrieved ppx_string.v0.15.0  (cached)
Processing 57/197: [dune: ocaml bootstrap.ml] [ocamlfind: make all]
-> retrieved ppx_typerep_conv.v0.15.0  (cached)
Processing 58/197: [dune: ocaml bootstrap.ml] [ocamlfind: make all]
-> retrieved ppx_variants_conv.v0.15.0  (cached)
Processing 59/197: [dune: ocaml bootstrap.ml] [ocamlfind: make all]
Processing 60/197: [dune: ocaml bootstrap.ml] [ocamlfind: make all]
Processing 61/197: [dune: ocaml bootstrap.ml] [ocamlfind: make all]
-> installed seq.base
Processing 62/197: [dune: ocaml bootstrap.ml] [ocamlfind: make all]
-> retrieved sexplib.v0.15.1  (cached)
Processing 63/197: [dune: ocaml bootstrap.ml] [ocamlfind: make all]
-> retrieved re.1.10.4  (cached)
Processing 64/197: [dune: ocaml bootstrap.ml] [ocamlfind: make all]
-> retrieved sexplib0.v0.15.1  (cached)
Processing 65/197: [dune: ocaml bootstrap.ml] [ocamlfind: make all]
-> retrieved splittable_random.v0.15.0  (cached)
Processing 66/197: [dune: ocaml bootstrap.ml] [ocamlfind: make all]
-> retrieved stdio.v0.15.0  (cached)
Processing 67/197: [dune: ocaml bootstrap.ml] [ocamlfind: make all]
-> retrieved stdlib-shims.0.3.0  (cached)
Processing 68/197: [dune: ocaml bootstrap.ml] [ocamlfind: make all]
-> retrieved ppxlib.0.27.0  (cached)
Processing 69/197: [dune: ocaml bootstrap.ml] [ocamlfind: make all]
-> retrieved time_now.v0.15.0  (cached)
-> retrieved typerep.v0.15.0  (cached)
-> retrieved variantslib.v0.15.0  (cached)
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "make" "all" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ocamlfind.1.9.5)
- for p in findlib; do ( cd src/$p; make all ) || exit; done
- make[1]: Entering directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ocamlfind.1.9.5/src/findlib'
- ocamllex fl_meta.mll
- 22 states, 392 transitions, table size 1700 bytes
- USE_CYGPATH="0"; \
- export USE_CYGPATH; \
- cat findlib_config.mlp | \
-          ../../tools/patch '@CONFIGFILE@' '/home/opam/.opam/5.0+alpha-repo/lib/findlib.conf' | \
-          ../../tools/patch '@STDLIB@' '/home/opam/.opam/5.0+alpha-repo/lib/ocaml' | \
- 	sed -e 's;@AUTOLINK@;true;g' \
- 	    -e 's;@SYSTEM@;linux;g' \
- 	     >findlib_config.ml
- if [ "true" = "true" ]; then                 \
- 	cp topfind.ml.in topfind.ml;                             \
- else                                                             \
- 	sed -e '/PPXOPT_BEGIN/,/PPXOPT_END/ d' topfind.ml.in     \
- 		> topfind.ml ;                                   \
- fi
- ocamldep *.ml *.mli >depend
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c findlib_config.ml
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c fl_split.ml
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c fl_metatoken.ml
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c fl_meta.ml
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -c fl_metascanner.mli
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c fl_metascanner.ml
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -c fl_topo.mli
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c fl_topo.ml
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -c fl_package_base.mli
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c fl_package_base.ml
- File "fl_package_base.ml", line 304, characters 22-40:
- 304 | 	 let pkg_ancestors = query_requirements predlist pkg in
-       	                     ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 350, characters 18-36:
- 350 |   let ancestors = query_requirements predlist package_name in
-                         ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 375, characters 23-41:
- 375 | 	  let pkg_ancestors = query_requirements predlist pkg in
-       	                      ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 510, characters 16-35:
- 510 | 	     ( let c = package_definitions search_path pkg.package_name in
-       	               ^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label search_path was omitted in the application of this function.
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -c findlib.mli
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c findlib.ml
- File "findlib.ml", line 390, characters 2-26:
- 390 |   Fl_package_base.requires predlist pkg
-         ^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "findlib.ml", line 396, characters 2-33:
- 396 |   Fl_package_base.requires_deeply predlist pkglist
-         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c fl_args.ml
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c fl_lint.ml
- ocamlc -I +compiler-libs -a -o findlib.cma findlib_config.cmo fl_split.cmo fl_metatoken.cmo fl_meta.cmo fl_metascanner.cmo fl_topo.cmo fl_package_base.cmo findlib.cmo fl_args.cmo fl_lint.cmo
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c ocaml_args.ml
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c frontend.ml
- File "frontend.ml", line 859, characters 10-39:
- 859 |           Fl_package_base.package_users predicates1 packages1
-                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- ocamlc -I +compiler-libs  -o ocamlfind -g findlib.cma unix.cma \
-            -I +unix -I +dynlink ocaml_args.cmo frontend.cmo
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -c topfind.mli
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c topfind.ml
- File "topfind.ml", line 126, characters 40-63:
- 126 |                      match Hashtbl.find Toploop.directive_table "ppx" with
-                                               ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 256, characters 4-27:
- 256 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 266, characters 4-27:
- 266 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 278, characters 4-27:
- 278 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 291, characters 4-27:
- 291 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 305, characters 4-27:
- 305 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 317, characters 4-27:
- 317 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- ocamlc -I +compiler-libs -a -o findlib_top.cma topfind.cmo
- USE_CYGPATH="0"; \
- export USE_CYGPATH; \
- cat topfind_rd1.p | \
-          ../../tools/patch '@SITELIB@' '/home/opam/.opam/5.0+alpha-repo/lib' \
-     	    >topfind
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -c fl_dynload.mli
- ocamlc -I +compiler-libs -opaque   -I +unix -I +dynlink -g -c fl_dynload.ml
- ocamlc -I +compiler-libs -a -o findlib_dynload.cma fl_dynload.cmo
- make[1]: Leaving directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ocamlfind.1.9.5/src/findlib'
- make all-config
- make[1]: Entering directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ocamlfind.1.9.5'
- USE_CYGPATH="0"; \
- export USE_CYGPATH; \
- cat findlib.conf.in | \
-      tools/patch '@SITELIB@' '/home/opam/.opam/5.0+alpha-repo/lib' >findlib.conf
- if ./tools/cmd_from_same_dir ocamlc; then \
- 	echo 'ocamlc="ocamlc.opt"' >>findlib.conf; \
- fi
- if ./tools/cmd_from_same_dir ocamlopt; then \
- 	echo 'ocamlopt="ocamlopt.opt"' >>findlib.conf; \
- fi
- if ./tools/cmd_from_same_dir ocamldep; then \
- 	echo 'ocamldep="ocamldep.opt"' >>findlib.conf; \
- fi
- if ./tools/cmd_from_same_dir ocamldoc; then \
- 	echo 'ocamldoc="ocamldoc.opt"' >>findlib.conf; \
- fi
- make[1]: Leaving directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ocamlfind.1.9.5'
Processing 69/197: [dune: ocaml bootstrap.ml] [ocamlfind: make opt]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "make" "opt" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ocamlfind.1.9.5)
- for p in findlib; do ( cd src/$p; make opt ) || exit; done
- make[1]: Entering directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ocamlfind.1.9.5/src/findlib'
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c findlib_config.ml
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c fl_split.ml
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c fl_metatoken.ml
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c fl_meta.ml
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c fl_metascanner.ml
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c fl_topo.ml
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c fl_package_base.ml
- File "fl_package_base.ml", line 304, characters 22-40:
- 304 | 	 let pkg_ancestors = query_requirements predlist pkg in
-       	                     ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 350, characters 18-36:
- 350 |   let ancestors = query_requirements predlist package_name in
-                         ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 375, characters 23-41:
- 375 | 	  let pkg_ancestors = query_requirements predlist pkg in
-       	                      ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 510, characters 16-35:
- 510 | 	     ( let c = package_definitions search_path pkg.package_name in
-       	               ^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label search_path was omitted in the application of this function.
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c findlib.ml
- File "findlib.ml", line 390, characters 2-26:
- 390 |   Fl_package_base.requires predlist pkg
-         ^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "findlib.ml", line 396, characters 2-33:
- 396 |   Fl_package_base.requires_deeply predlist pkglist
-         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c fl_args.ml
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c fl_lint.ml
- ocamlopt -I +compiler-libs -g -a -o findlib.cmxa findlib_config.cmx fl_split.cmx fl_metatoken.cmx fl_meta.cmx fl_metascanner.cmx fl_topo.cmx fl_package_base.cmx findlib.cmx fl_args.cmx fl_lint.cmx
- if [ 1 -gt 0 ]; then \
-     ocamlopt -I +compiler-libs -g -shared -o findlib.cmxs findlib_config.cmx fl_split.cmx fl_metatoken.cmx fl_meta.cmx fl_metascanner.cmx fl_topo.cmx fl_package_base.cmx findlib.cmx fl_args.cmx fl_lint.cmx; \
- fi
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c ocaml_args.ml
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c frontend.ml
- File "frontend.ml", line 859, characters 10-39:
- 859 |           Fl_package_base.package_users predicates1 packages1
-                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- ocamlopt -I +compiler-libs -g -o ocamlfind_opt findlib.cmxa unix.cmxa \
- 	   -I +unix -I +dynlink ocaml_args.cmx frontend.cmx
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c topfind.ml
- File "topfind.ml", line 126, characters 40-63:
- 126 |                      match Hashtbl.find Toploop.directive_table "ppx" with
-                                               ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 256, characters 4-27:
- 256 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 266, characters 4-27:
- 266 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 278, characters 4-27:
- 278 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 291, characters 4-27:
- 291 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 305, characters 4-27:
- 305 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 317, characters 4-27:
- 317 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- ocamlopt -I +compiler-libs -g -a -o findlib_top.cmxa topfind.cmx
- if [ 1 -gt 0 ]; then \
-     ocamlopt -I +compiler-libs -g -shared -o findlib_top.cmxs topfind.cmx; \
- fi
- ocamlopt -I +compiler-libs -g -opaque  -I +unix -I +dynlink -c fl_dynload.ml
- ocamlopt -I +compiler-libs -g -a -o findlib_dynload.cmxa fl_dynload.cmx
- if [ 1 -gt 0 ]; then \
-     ocamlopt -I +compiler-libs -g -shared -o findlib_dynload.cmxs fl_dynload.cmx; \
- fi
- make[1]: Leaving directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ocamlfind.1.9.5/src/findlib'
-> compiled  ocamlfind.1.9.5
Processing 69/197: [dune: ocaml bootstrap.ml]
Processing 70/197: [dune: ocaml bootstrap.ml] [ocamlfind: make install]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "install" "make" "install" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ocamlfind.1.9.5)
- if [ "1" -eq 1 ]; then \
-     for x in camlp4 dbm graphics labltk num ocamlbuild; do \
-       if [ -f "/home/opam/.opam/5.0+alpha-repo/lib/$x/META" ]; then \
-         if ! grep -Fq '[distributed with Ocaml]' "//home/opam/.opam/5.0+alpha-repo/lib/$x/META"; then \
-           rm -f site-lib-src/$x/META; \
-         fi; \
-       fi; \
-     done; \
-     test -f "site-lib-src/num/META" || rm -f "site-lib-src/num-top/META"; \
-   fi
- echo 'SITELIB_META =' > Makefile.packages.in
- for x in `ls site-lib-src`; do test ! -f "site-lib-src/$x/META" || echo $x >> Makefile.packages.in; done
- tr '\n' ' ' < Makefile.packages.in > Makefile.packages
- rm Makefile.packages.in
- install -d "/home/opam/.opam/5.0+alpha-repo/bin"
- install -d "/home/opam/.opam/5.0+alpha-repo/man"
- make install-config
- make[1]: Entering directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ocamlfind.1.9.5'
- install -d "`dirname \"/home/opam/.opam/5.0+alpha-repo/lib/findlib.conf\"`"
- test -f "/home/opam/.opam/5.0+alpha-repo/lib/findlib.conf" || install -c findlib.conf "/home/opam/.opam/5.0+alpha-repo/lib/findlib.conf"
- make[1]: Leaving directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ocamlfind.1.9.5'
- for p in findlib; do ( cd src/$p; make install ); done
- make[1]: Entering directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ocamlfind.1.9.5/src/findlib'
- install -d "/home/opam/.opam/5.0+alpha-repo/lib/findlib"
- install -d "/home/opam/.opam/5.0+alpha-repo/bin"
- test 1 -eq 0 || install -d "/home/opam/.opam/5.0+alpha-repo/lib/ocaml"
- test 1 -eq 0 || install -c topfind "/home/opam/.opam/5.0+alpha-repo/lib/ocaml/"
- files=` ../../tools/collect_files ../../Makefile.config \
- findlib.cmi findlib.mli findlib.cma findlib.cmxa findlib.a findlib.cmxs \
- findlib_config.cmi findlib_config.ml topfind.cmi topfind.mli \
- fl_args.cmi fl_lint.cmi fl_meta.cmi fl_split.cmi fl_topo.cmi ocaml_args.cmi \
- fl_package_base.mli fl_package_base.cmi fl_metascanner.mli fl_metascanner.cmi \
- fl_metatoken.cmi findlib_top.cma findlib_top.cmxa findlib_top.a findlib_top.cmxs \
- findlib_dynload.cma findlib_dynload.cmxa findlib_dynload.a findlib_dynload.cmxs fl_dynload.mli fl_dynload.cmi \
- META` && \
- install -c $files "/home/opam/.opam/5.0+alpha-repo/lib/findlib/"
- f="ocamlfind"; { test -f ocamlfind_opt && f="ocamlfind_opt"; }; \
- install -c $f "/home/opam/.opam/5.0+alpha-repo/bin/ocamlfind"
- # the following "if" block is only needed for 4.00beta2
- if [ 1 -eq 0 -a -f "/home/opam/.opam/5.0+alpha-repo/lib/ocaml/compiler-libs/topdirs.cmi" ]; then \
-     cd "/home/opam/.opam/5.0+alpha-repo/lib/ocaml/compiler-libs/"; \
-     install -c topdirs.cmi toploop.cmi "/home/opam/.opam/5.0+alpha-repo/lib/findlib/"; \
- fi
- make[1]: Leaving directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ocamlfind.1.9.5/src/findlib'
- make install-meta
- make[1]: Entering directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ocamlfind.1.9.5'
- for x in bytes compiler-libs dynlink ocamldoc runtime_events stdlib str threads unix ; do install -d "/home/opam/.opam/5.0+alpha-repo/lib/$x"; install -c site-lib-src/$x/META "/home/opam/.opam/5.0+alpha-repo/lib/$x/META.tmp" && mv "/home/opam/.opam/5.0+alpha-repo/lib/$x/META.tmp" "/home/opam/.opam/5.0+alpha-repo/lib/$x/META"; done
- install -d "/home/opam/.opam/5.0+alpha-repo/lib/findlib"; install -c Makefile.packages "/home/opam/.opam/5.0+alpha-repo/lib/findlib/Makefile.packages"
- make[1]: Leaving directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ocamlfind.1.9.5'
- test ! -f 'site-lib-src/num-top/META' || { cd src/findlib; make install-num-top; }
- test ! -f 'site-lib-src/camlp4/META' ||	install -c tools/safe_camlp4 "/home/opam/.opam/5.0+alpha-repo/bin"
- make install-doc
- make[1]: Entering directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ocamlfind.1.9.5'
- install -d "/home/opam/.opam/5.0+alpha-repo/man/man1" "/home/opam/.opam/5.0+alpha-repo/man/man3" "/home/opam/.opam/5.0+alpha-repo/man/man5"
- install -c doc/ref-man/ocamlfind.1 "/home/opam/.opam/5.0+alpha-repo/man/man1"
- install -c doc/ref-man/META.5 doc/ref-man/site-lib.5 doc/ref-man/findlib.conf.5 "/home/opam/.opam/5.0+alpha-repo/man/man5"
- make[1]: Leaving directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ocamlfind.1.9.5'
-> installed ocamlfind.1.9.5
Processing 70/197: [dune: ocaml bootstrap.ml]
Processing 71/197: [dune: ocaml bootstrap.ml] [num: make]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "make" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/num.1.4)
- make -C src all
- make[1]: Entering directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/num.1.4/src'
- ocamlc -ccopt -DBNG_ARCH_amd64 -c bng.c
- ocamlc -ccopt -DBNG_ARCH_amd64 -c nat_stubs.c
- ocamlmklib -oc nums bng.o nat_stubs.o
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c int_misc.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c int_misc.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c nat.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c nat.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c big_int.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c big_int.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_flags.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_flags.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c ratio.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c ratio.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c num.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c num.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_status.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_status.ml
- ocamlmklib -o nums -oc nums -linkall int_misc.cmo nat.cmo big_int.cmo arith_flags.cmo ratio.cmo num.cmo arith_status.cmo
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c int_misc.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c nat.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c big_int.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_flags.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c ratio.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c num.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_status.ml
- ocamlmklib -o nums -oc nums -linkall int_misc.cmx nat.cmx big_int.cmx arith_flags.cmx ratio.cmx num.cmx arith_status.cmx
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -I . -shared -o nums.cmxs nums.cmxa
- make[1]: Leaving directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/num.1.4/src'
- make -C toplevel all
- make[1]: Entering directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/num.1.4/toplevel'
- ocamlc -I ../src -I +compiler-libs -w +a-4-9-41-42-44-45-48 -warn-error A -safe-string -strict-sequence -strict-formats -c num_top_printers.mli
- ocamlc -I ../src -I +compiler-libs -w +a-4-9-41-42-44-45-48 -warn-error A -safe-string -strict-sequence -strict-formats -c num_top_printers.ml
- ocamlc -I ../src -I +compiler-libs -w +a-4-9-41-42-44-45-48 -warn-error A -safe-string -strict-sequence -strict-formats -c num_top.mli
- ocamlc -I ../src -I +compiler-libs -w +a-4-9-41-42-44-45-48 -warn-error A -safe-string -strict-sequence -strict-formats -c num_top.ml
- ocamlc -I ../src -I +compiler-libs -w +a-4-9-41-42-44-45-48 -warn-error A -safe-string -strict-sequence -strict-formats -a -o num_top.cma num_top_printers.cmo num_top.cmo
- make[1]: Leaving directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/num.1.4/toplevel'
-> compiled  num.1.4
Processing 71/197: [dune: ocaml bootstrap.ml]
Processing 72/197: [dune: ocaml bootstrap.ml] [num: ocamlfind remove]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "install" "ocamlfind" "remove" "num" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/num.1.4)
- ocamlfind: [WARNING] No such file: /home/opam/.opam/5.0+alpha-repo/lib/num/META
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "install" "ocamlfind" "remove" "num-top" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/num.1.4)
- ocamlfind: [WARNING] No such file: /home/opam/.opam/5.0+alpha-repo/lib/num-top/META
Processing 72/197: [dune: ocaml bootstrap.ml] [num: make install]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "install" "make" "install" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/num.1.4)
- make -C src install
- make[1]: Entering directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/num.1.4/src'
- install -d /home/opam/.opam/5.0+alpha-repo/lib/ocaml
- sed -e 's/%%VERSION%%/1.4/g' META.in > META
- ocamlfind install num META
- Installed /home/opam/.opam/5.0+alpha-repo/lib/num/META
- rm -f META
- install -m 644 nums.cma libnums.a big_int.cmi nat.cmi num.cmi ratio.cmi arith_status.cmi big_int.mli nat.mli num.mli ratio.mli arith_status.mli big_int.cmti nat.cmti num.cmti ratio.cmti arith_status.cmti nums.cmxa nums.a int_misc.cmx nat.cmx big_int.cmx arith_flags.cmx ratio.cmx num.cmx arith_status.cmx nums.cmxs /home/opam/.opam/5.0+alpha-repo/lib/ocaml
- install -d /home/opam/.opam/5.0+alpha-repo/lib/ocaml/stublibs
- install dllnums.so /home/opam/.opam/5.0+alpha-repo/lib/ocaml/stublibs
- make[1]: Leaving directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/num.1.4/src'
- make -C toplevel install
- make[1]: Entering directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/num.1.4/toplevel'
- sed -e 's/%%VERSION%%/1.4/g' META.in > META
- ocamlfind install num-top META num_top.cma num_top.cmi num_top_printers.cmi
- Installed /home/opam/.opam/5.0+alpha-repo/lib/num-top/num_top_printers.cmi
- Installed /home/opam/.opam/5.0+alpha-repo/lib/num-top/num_top.cmi
- Installed /home/opam/.opam/5.0+alpha-repo/lib/num-top/num_top.cma
- Installed /home/opam/.opam/5.0+alpha-repo/lib/num-top/META
- rm -f META
- make[1]: Leaving directory '/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/num.1.4/toplevel'
-> installed num.1.4
Processing 72/197: [dune: ocaml bootstrap.ml]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "ocaml" "bootstrap.ml" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/dune.3.4.1)
- ocamlc -output-complete-exe -w -24 -g -o .duneboot.exe -I boot -I +unix unix.cma boot/libs.ml boot/duneboot.ml
- ./.duneboot.exe -j 31
- cd _boot && /home/opam/.opam/5.0+alpha-repo/bin/ocamlopt.opt -c -g -no-alias-deps -w -49-6 -alert -unstable -I +unix -I +threads build_path_prefix_map.ml
- File "vendor/build_path_prefix_map/src/build_path_prefix_map.ml", line 5, characters 17-31:
- Alert deprecated: Stdlib.Printf.kprintf
- Use Printf.ksprintf instead.
- cd _boot && /home/opam/.opam/5.0+alpha-repo/bin/ocamlopt.opt -c -g -no-alias-deps -w -49-6 -alert -unstable -I +unix -I +threads opamLexer.ml
- File "vendor/opam-file-format/src/opamLexer.mll", line 21, characters 2-16:
- Alert deprecated: Stdlib.Printf.kprintf
- Use Printf.ksprintf instead.
- 

Processing 72/197: [dune: ./dune.exe build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "./dune.exe" "build" "dune.install" "--release" "--profile" "dune-bootstrap" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/dune.3.4.1)
-> compiled  dune.3.4.1
-> installed dune.3.4.1
Processing 74/197: [csexp: dune build]
Processing 75/197: [csexp: dune build] [jane-street-headers: dune build]
Processing 76/197: [csexp: dune build] [jane-street-headers: dune build] [ocaml-compiler-libs: dune build]
Processing 77/197: [csexp: dune build] [jane-street-headers: dune build] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build]
Processing 78/197: [csexp: dune build] [jane-street-headers: dune build] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [re: dune build]
Processing 79/197: [csexp: dune build] [jane-street-headers: dune build] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [re: dune build] [sexplib0: dune build]
Processing 80/197: [csexp: dune build] [jane-street-headers: dune build] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [re: dune build] [sexplib0: dune build] [stdlib-shims: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "jane-street-headers" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/jane-street-headers.v0.15.0)
-> compiled  jane-street-headers.v0.15.0
Processing 80/197: [csexp: dune build] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [re: dune build] [sexplib0: dune build] [stdlib-shims: dune build]
-> installed jane-street-headers.v0.15.0
Processing 81/197: [csexp: dune build] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [re: dune build] [sexplib0: dune build] [stdlib-shims: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "stdlib-shims" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/stdlib-shims.0.3.0)
-> compiled  stdlib-shims.0.3.0
Processing 81/197: [csexp: dune build] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [re: dune build] [sexplib0: dune build]
-> installed stdlib-shims.0.3.0
Processing 82/197: [csexp: dune build] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [re: dune build] [sexplib0: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_derivers" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_derivers.1.2.1)
-> compiled  ppx_derivers.1.2.1
Processing 82/197: [csexp: dune build] [ocaml-compiler-libs: dune build] [re: dune build] [sexplib0: dune build]
-> installed ppx_derivers.1.2.1
Processing 83/197: [csexp: dune build] [ocaml-compiler-libs: dune build] [re: dune build] [sexplib0: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "csexp" "-j" "31" "@install" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/csexp.1.5.1)
-> compiled  csexp.1.5.1
Processing 83/197: [ocaml-compiler-libs: dune build] [re: dune build] [sexplib0: dune build]
-> installed csexp.1.5.1
Processing 84/197: [ocaml-compiler-libs: dune build] [re: dune build] [sexplib0: dune build]
Processing 85/197: [dune-configurator: rm] [ocaml-compiler-libs: dune build] [re: dune build] [sexplib0: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "rm" "-rf" "vendor/csexp" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/dune-configurator.3.4.1)
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "rm" "-rf" "vendor/pp" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/dune-configurator.3.4.1)
Processing 85/197: [dune-configurator: dune build] [ocaml-compiler-libs: dune build] [re: dune build] [sexplib0: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "sexplib0" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/sexplib0.v0.15.1)
-> compiled  sexplib0.v0.15.1
Processing 85/197: [dune-configurator: dune build] [ocaml-compiler-libs: dune build] [re: dune build]
-> installed sexplib0.v0.15.1
Processing 86/197: [dune-configurator: dune build] [ocaml-compiler-libs: dune build] [re: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "re" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/re.1.10.4)
-> compiled  re.1.10.4
Processing 86/197: [dune-configurator: dune build] [ocaml-compiler-libs: dune build]
-> installed re.1.10.4
Processing 87/197: [dune-configurator: dune build] [ocaml-compiler-libs: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ocaml-compiler-libs" "-j" "31" "@install" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ocaml-compiler-libs.v0.12.4)
-> compiled  ocaml-compiler-libs.v0.12.4
Processing 87/197: [dune-configurator: dune build]
-> installed ocaml-compiler-libs.v0.12.4
Processing 88/197: [dune-configurator: dune build]
Processing 89/197: [dune-configurator: dune build] [ppxlib: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "dune-configurator" "-j" "31" "@install" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/dune-configurator.3.4.1)
-> compiled  dune-configurator.3.4.1
Processing 89/197: [ppxlib: dune build]
-> installed dune-configurator.3.4.1
Processing 90/197: [ppxlib: dune build]
Processing 91/197: [base: dune build] [ppxlib: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "base" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/base.v0.15.1~5.0preview)
- (cd _build/default && /home/opam/.opam/5.0+alpha-repo/bin/ocamlopt.opt -w -40 -g -I src/.base.objs/byte -I src/.base.objs/native -I /home/opam/.opam/5.0+alpha-repo/lib/sexplib0 -I compiler-stdlib/src/.caml.objs/byte -I compiler-stdlib/src/.caml.objs/native -I hash_types/src/.base_internalhash_types.objs/byte -I hash_types/src/.base_internalhash_types.objs/native -I shadow-stdlib/src/.shadow_stdlib.objs/byte -I shadow-stdlib/src/.shadow_stdlib.objs/native -intf-suffix .ml -no-alias-deps -open Base__ -o src/.base.objs/native/base__Float.cmx -c -impl src/float.ml)
- File "src/float.ml", line 490, characters 10-52:
- 490 |   let t = (round_nearest [@ocaml.inlined always]) t0 in
-                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 55 [inlining-impossible]: Cannot inline: Function information unavailable
-> compiled  base.v0.15.1~5.0preview
Processing 91/197: [ppxlib: dune build]
-> installed base.v0.15.1~5.0preview
Processing 92/197: [ppxlib: dune build]
Processing 93/197: [fieldslib: dune build] [ppxlib: dune build]
Processing 94/197: [fieldslib: dune build] [parsexp: dune build] [ppxlib: dune build]
Processing 95/197: [fieldslib: dune build] [parsexp: dune build] [ppxlib: dune build] [stdio: dune build]
Processing 96/197: [fieldslib: dune build] [parsexp: dune build] [ppxlib: dune build] [stdio: dune build] [typerep: dune build]
Processing 97/197: [fieldslib: dune build] [parsexp: dune build] [ppxlib: dune build] [stdio: dune build] [typerep: dune build] [variantslib: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "fieldslib" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/fieldslib.v0.15.0)
-> compiled  fieldslib.v0.15.0
Processing 97/197: [parsexp: dune build] [ppxlib: dune build] [stdio: dune build] [typerep: dune build] [variantslib: dune build]
-> installed fieldslib.v0.15.0
Processing 98/197: [parsexp: dune build] [ppxlib: dune build] [stdio: dune build] [typerep: dune build] [variantslib: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "variantslib" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/variantslib.v0.15.0)
-> compiled  variantslib.v0.15.0
Processing 98/197: [parsexp: dune build] [ppxlib: dune build] [stdio: dune build] [typerep: dune build]
-> installed variantslib.v0.15.0
Processing 99/197: [parsexp: dune build] [ppxlib: dune build] [stdio: dune build] [typerep: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "stdio" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/stdio.v0.15.0)
-> compiled  stdio.v0.15.0
Processing 99/197: [parsexp: dune build] [ppxlib: dune build] [typerep: dune build]
-> installed stdio.v0.15.0
Processing 100/197: [parsexp: dune build] [ppxlib: dune build] [typerep: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "typerep" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/typerep.v0.15.0)
-> compiled  typerep.v0.15.0
Processing 100/197: [parsexp: dune build] [ppxlib: dune build]
-> installed typerep.v0.15.0
Processing 101/197: [parsexp: dune build] [ppxlib: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "parsexp" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/parsexp.v0.15.0)
-> compiled  parsexp.v0.15.0
Processing 101/197: [ppxlib: dune build]
-> installed parsexp.v0.15.0
Processing 102/197: [ppxlib: dune build]
Processing 103/197: [ppxlib: dune build] [sexplib: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "sexplib" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/sexplib.v0.15.1)
-> compiled  sexplib.v0.15.1
Processing 103/197: [ppxlib: dune build]
-> installed sexplib.v0.15.1
Processing 104/197: [ppxlib: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppxlib" "-j" "31" "@install" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppxlib.0.27.0)
-> compiled  ppxlib.0.27.0
-> installed ppxlib.0.27.0
Processing 106/197: [ppx_cold: dune build]
Processing 107/197: [ppx_cold: dune build] [ppx_compare: dune build]
Processing 108/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_disable_unused_warnings: dune build]
Processing 109/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_disable_unused_warnings: dune build] [ppx_enumerate: dune build]
Processing 110/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_disable_unused_warnings: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build]
Processing 111/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_disable_unused_warnings: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build]
Processing 112/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_disable_unused_warnings: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build]
Processing 113/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_disable_unused_warnings: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_ignore_instrumentation: dune build]
Processing 114/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_disable_unused_warnings: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_ignore_instrumentation: dune build] [ppx_optcomp: dune build]
Processing 115/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_disable_unused_warnings: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_ignore_instrumentation: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build]
Processing 116/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_disable_unused_warnings: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_ignore_instrumentation: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build]
Processing 117/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_disable_unused_warnings: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_ignore_instrumentation: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build]
Processing 118/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_disable_unused_warnings: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_ignore_instrumentation: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build]
Processing 119/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_disable_unused_warnings: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_ignore_instrumentation: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build]
Processing 120/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_disable_unused_warnings: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_ignore_instrumentation: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_optcomp" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_optcomp.v0.15.0)
-> compiled  ppx_optcomp.v0.15.0
Processing 120/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_disable_unused_warnings: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_ignore_instrumentation: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_optcomp.v0.15.0
Processing 121/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_disable_unused_warnings: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_ignore_instrumentation: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_fields_conv" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_fields_conv.v0.15.0)
-> compiled  ppx_fields_conv.v0.15.0
Processing 121/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_disable_unused_warnings: dune build] [ppx_enumerate: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_ignore_instrumentation: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_fields_conv.v0.15.0
Processing 122/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_disable_unused_warnings: dune build] [ppx_enumerate: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_ignore_instrumentation: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_disable_unused_warnings" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_disable_unused_warnings.v0.15.0)
-> compiled  ppx_disable_unused_warnings.v0.15.0
Processing 122/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_ignore_instrumentation: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_disable_unused_warnings.v0.15.0
Processing 123/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_ignore_instrumentation: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_here" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_here.v0.15.0)
-> compiled  ppx_here.v0.15.0
Processing 123/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fixed_literal: dune build] [ppx_ignore_instrumentation: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_here.v0.15.0
Processing 124/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fixed_literal: dune build] [ppx_ignore_instrumentation: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
Processing 125/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fixed_literal: dune build] [ppx_ignore_instrumentation: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_variants_conv" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_variants_conv.v0.15.0)
-> compiled  ppx_variants_conv.v0.15.0
Processing 125/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fixed_literal: dune build] [ppx_ignore_instrumentation: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build]
-> installed ppx_variants_conv.v0.15.0
Processing 126/197: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fixed_literal: dune build] [ppx_ignore_instrumentation: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_cold" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_cold.v0.15.0)
-> compiled  ppx_cold.v0.15.0
Processing 126/197: [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fixed_literal: dune build] [ppx_ignore_instrumentation: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build]
-> installed ppx_cold.v0.15.0
Processing 127/197: [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fixed_literal: dune build] [ppx_ignore_instrumentation: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_enumerate" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_enumerate.v0.15.0)
-> compiled  ppx_enumerate.v0.15.0
Processing 127/197: [ppx_compare: dune build] [ppx_fixed_literal: dune build] [ppx_ignore_instrumentation: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build]
-> installed ppx_enumerate.v0.15.0
Processing 128/197: [ppx_compare: dune build] [ppx_fixed_literal: dune build] [ppx_ignore_instrumentation: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_typerep_conv" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_typerep_conv.v0.15.0)
-> compiled  ppx_typerep_conv.v0.15.0
Processing 128/197: [ppx_compare: dune build] [ppx_fixed_literal: dune build] [ppx_ignore_instrumentation: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build]
-> installed ppx_typerep_conv.v0.15.0
Processing 129/197: [ppx_compare: dune build] [ppx_fixed_literal: dune build] [ppx_ignore_instrumentation: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_compare" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_compare.v0.15.0)
-> compiled  ppx_compare.v0.15.0
Processing 129/197: [ppx_fixed_literal: dune build] [ppx_ignore_instrumentation: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build]
-> installed ppx_compare.v0.15.0
Processing 130/197: [ppx_fixed_literal: dune build] [ppx_ignore_instrumentation: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_stable" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_stable.v0.15.0)
-> compiled  ppx_stable.v0.15.0
Processing 130/197: [ppx_fixed_literal: dune build] [ppx_ignore_instrumentation: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build]
-> installed ppx_stable.v0.15.0
Processing 131/197: [ppx_fixed_literal: dune build] [ppx_ignore_instrumentation: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_fixed_literal" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_fixed_literal.v0.15.0)
-> compiled  ppx_fixed_literal.v0.15.0
Processing 131/197: [ppx_ignore_instrumentation: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build]
-> installed ppx_fixed_literal.v0.15.0
Processing 132/197: [ppx_ignore_instrumentation: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_ignore_instrumentation" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_ignore_instrumentation.v0.15.0)
-> compiled  ppx_ignore_instrumentation.v0.15.0
Processing 132/197: [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build]
-> installed ppx_ignore_instrumentation.v0.15.0
Processing 133/197: [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_pipebang" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_pipebang.v0.15.0)
-> compiled  ppx_pipebang.v0.15.0
Processing 133/197: [ppx_let: dune build] [ppx_optional: dune build] [ppx_sexp_conv: dune build]
-> installed ppx_pipebang.v0.15.0
Processing 134/197: [ppx_let: dune build] [ppx_optional: dune build] [ppx_sexp_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_optional" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_optional.v0.15.0)
-> compiled  ppx_optional.v0.15.0
Processing 134/197: [ppx_let: dune build] [ppx_sexp_conv: dune build]
-> installed ppx_optional.v0.15.0
Processing 135/197: [ppx_let: dune build] [ppx_sexp_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_sexp_conv" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_sexp_conv.v0.15.1)
-> compiled  ppx_sexp_conv.v0.15.1
Processing 135/197: [ppx_let: dune build]
-> installed ppx_sexp_conv.v0.15.1
Processing 136/197: [ppx_let: dune build]
Processing 137/197: [ppx_assert: dune build] [ppx_let: dune build]
Processing 138/197: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_let: dune build]
Processing 139/197: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_hash: dune build] [ppx_let: dune build]
Processing 140/197: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_hash: dune build] [ppx_let: dune build] [ppx_sexp_message: dune build]
Processing 141/197: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_hash: dune build] [ppx_let: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_let" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_let.v0.15.0)
-> compiled  ppx_let.v0.15.0
Processing 141/197: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_hash: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
-> installed ppx_let.v0.15.0
Processing 142/197: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_hash: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_hash" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_hash.v0.15.0)
-> compiled  ppx_hash.v0.15.0
Processing 142/197: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
-> installed ppx_hash.v0.15.0
Processing 143/197: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
Processing 144/197: [ppx_assert: dune build] [ppx_base: dune build] [ppx_custom_printf: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_assert" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_assert.v0.15.0)
-> compiled  ppx_assert.v0.15.0
Processing 144/197: [ppx_base: dune build] [ppx_custom_printf: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
-> installed ppx_assert.v0.15.0
Processing 145/197: [ppx_base: dune build] [ppx_custom_printf: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
Processing 146/197: [jst-config: dune build] [ppx_base: dune build] [ppx_custom_printf: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_sexp_message" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_sexp_message.v0.15.0)
-> compiled  ppx_sexp_message.v0.15.0
Processing 146/197: [jst-config: dune build] [ppx_base: dune build] [ppx_custom_printf: dune build] [ppx_sexp_value: dune build]
-> installed ppx_sexp_message.v0.15.0
Processing 147/197: [jst-config: dune build] [ppx_base: dune build] [ppx_custom_printf: dune build] [ppx_sexp_value: dune build]
Processing 148/197: [jst-config: dune build] [ppx_base: dune build] [ppx_custom_printf: dune build] [ppx_log: dune build] [ppx_sexp_value: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_custom_printf" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_custom_printf.v0.15.0)
-> compiled  ppx_custom_printf.v0.15.0
Processing 148/197: [jst-config: dune build] [ppx_base: dune build] [ppx_log: dune build] [ppx_sexp_value: dune build]
-> installed ppx_custom_printf.v0.15.0
Processing 149/197: [jst-config: dune build] [ppx_base: dune build] [ppx_log: dune build] [ppx_sexp_value: dune build]
Processing 150/197: [bin_prot: dune build] [jst-config: dune build] [ppx_base: dune build] [ppx_log: dune build] [ppx_sexp_value: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_sexp_value" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_sexp_value.v0.15.0)
-> compiled  ppx_sexp_value.v0.15.0
Processing 150/197: [bin_prot: dune build] [jst-config: dune build] [ppx_base: dune build] [ppx_log: dune build]
-> installed ppx_sexp_value.v0.15.0
Processing 151/197: [bin_prot: dune build] [jst-config: dune build] [ppx_base: dune build] [ppx_log: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_base" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_base.v0.15.0)
-> compiled  ppx_base.v0.15.0
Processing 151/197: [bin_prot: dune build] [jst-config: dune build] [ppx_log: dune build]
-> installed ppx_base.v0.15.0
Processing 152/197: [bin_prot: dune build] [jst-config: dune build] [ppx_log: dune build]
Processing 153/197: [bin_prot: dune build] [jst-config: dune build] [ppx_log: dune build] [ppx_string: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "jst-config" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/jst-config.v0.15.1)
-> compiled  jst-config.v0.15.1
Processing 153/197: [bin_prot: dune build] [ppx_log: dune build] [ppx_string: dune build]
-> installed jst-config.v0.15.1
Processing 154/197: [bin_prot: dune build] [ppx_log: dune build] [ppx_string: dune build]
Processing 155/197: [bin_prot: dune build] [ppx_log: dune build] [ppx_string: dune build] [time_now: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "bin_prot" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/bin_prot.v0.15.0)
-> compiled  bin_prot.v0.15.0
Processing 155/197: [ppx_log: dune build] [ppx_string: dune build] [time_now: dune build]
-> installed bin_prot.v0.15.0
Processing 156/197: [ppx_log: dune build] [ppx_string: dune build] [time_now: dune build]
Processing 157/197: [ppx_bin_prot: dune build] [ppx_log: dune build] [ppx_string: dune build] [time_now: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_log" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_log.v0.15.0)
-> compiled  ppx_log.v0.15.0
Processing 157/197: [ppx_bin_prot: dune build] [ppx_string: dune build] [time_now: dune build]
-> installed ppx_log.v0.15.0
Processing 158/197: [ppx_bin_prot: dune build] [ppx_string: dune build] [time_now: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_string" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_string.v0.15.0)
-> compiled  ppx_string.v0.15.0
Processing 158/197: [ppx_bin_prot: dune build] [time_now: dune build]
-> installed ppx_string.v0.15.0
Processing 159/197: [ppx_bin_prot: dune build] [time_now: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "time_now" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/time_now.v0.15.0)
-> compiled  time_now.v0.15.0
Processing 159/197: [ppx_bin_prot: dune build]
-> installed time_now.v0.15.0
Processing 160/197: [ppx_bin_prot: dune build]
Processing 161/197: [ppx_bin_prot: dune build] [ppx_inline_test: dune build]
Processing 162/197: [ppx_bin_prot: dune build] [ppx_inline_test: dune build] [ppx_module_timer: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_bin_prot" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_bin_prot.v0.15.0)
-> compiled  ppx_bin_prot.v0.15.0
Processing 162/197: [ppx_inline_test: dune build] [ppx_module_timer: dune build]
-> installed ppx_bin_prot.v0.15.0
Processing 163/197: [ppx_inline_test: dune build] [ppx_module_timer: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_module_timer" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_module_timer.v0.15.0)
-> compiled  ppx_module_timer.v0.15.0
Processing 163/197: [ppx_inline_test: dune build]
-> installed ppx_module_timer.v0.15.0
Processing 164/197: [ppx_inline_test: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_inline_test" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_inline_test.v0.15.0)
-> compiled  ppx_inline_test.v0.15.0
-> installed ppx_inline_test.v0.15.0
Processing 166/197: [ppx_bench: dune build]
Processing 167/197: [ppx_bench: dune build] [ppx_expect: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_bench" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_bench.v0.15.0)
-> compiled  ppx_bench.v0.15.0
Processing 167/197: [ppx_expect: dune build]
-> installed ppx_bench.v0.15.0
Processing 168/197: [ppx_expect: dune build]
Processing 169/197: [ppx_expect: dune build] [splittable_random: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_expect" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_expect.v0.15.0.1~alpha-repo)
-> compiled  ppx_expect.v0.15.0.1~alpha-repo
Processing 169/197: [splittable_random: dune build]
-> installed ppx_expect.v0.15.0.1~alpha-repo
Processing 170/197: [splittable_random: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "splittable_random" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/splittable_random.v0.15.0)
-> compiled  splittable_random.v0.15.0
-> installed splittable_random.v0.15.0
Processing 172/197: [base_quickcheck: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "base_quickcheck" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/base_quickcheck.v0.15.0)
-> compiled  base_quickcheck.v0.15.0
-> installed base_quickcheck.v0.15.0
Processing 174/197: [ppx_jane: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_jane" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_jane.v0.15.0)
-> compiled  ppx_jane.v0.15.0
-> installed ppx_jane.v0.15.0
Processing 176/197: [higher_kinded: dune build]
Processing 177/197: [higher_kinded: dune build] [int_repr: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "higher_kinded" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/higher_kinded.v0.15.0)
-> compiled  higher_kinded.v0.15.0
Processing 177/197: [int_repr: dune build]
-> installed higher_kinded.v0.15.0
Processing 178/197: [int_repr: dune build]
Processing 179/197: [accessor: dune build] [int_repr: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "int_repr" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/int_repr.v0.15.0)
-> compiled  int_repr.v0.15.0
Processing 179/197: [accessor: dune build]
-> installed int_repr.v0.15.0
Processing 180/197: [accessor: dune build]
Processing 181/197: [accessor: dune build] [base_bigstring: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "base_bigstring" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/base_bigstring.v0.15.0)
-> compiled  base_bigstring.v0.15.0
Processing 181/197: [accessor: dune build]
-> installed base_bigstring.v0.15.0
Processing 182/197: [accessor: dune build]
Processing 183/197: [accessor: dune build] [core: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "accessor" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/accessor.v0.15.0)
-> compiled  accessor.v0.15.0
Processing 183/197: [core: dune build]
-> installed accessor.v0.15.0
Processing 184/197: [core: dune build]
Processing 185/197: [core: dune build] [ppx_accessor: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_accessor" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/ppx_accessor.v0.15.0)
-> compiled  ppx_accessor.v0.15.0
Processing 185/197: [core: dune build]
-> installed ppx_accessor.v0.15.0
Processing 186/197: [core: dune build]
Processing 187/197: [accessor_base: dune build] [core: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "accessor_base" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/accessor_base.v0.15.0)
-> compiled  accessor_base.v0.15.0
Processing 187/197: [core: dune build]
-> installed accessor_base.v0.15.0
Processing 188/197: [core: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "core" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/core.v0.15.0.1~alpha-repo)
- (cd _build/default/core/src && /usr/bin/gcc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC -D_FILE_OFFSET_BITS=64 -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC -D_LARGEFILE64_SOURCE -g -I /home/opam/.opam/5.0+alpha-repo/lib/ocaml -I /home/opam/.opam/5.0+alpha-repo/lib/base -I /home/opam/.opam/5.0+alpha-repo/lib/base/base_internalhash_types -I /home/opam/.opam/5.0+alpha-repo/lib/base/caml -I /home/opam/.opam/5.0+alpha-repo/lib/base/md5 -I /home/opam/.opam/5.0+alpha-repo/lib/base/shadow_stdlib -I /home/opam/.opam/5.0+alpha-repo/lib/base_bigstring -I /home/opam/.opam/5.0+alpha-repo/lib/base_quickcheck -I /home/opam/.opam/5.0+alpha-repo/lib/base_quickcheck/ppx_quickcheck/runtime -I /home/opam/.opam/5.0+alpha-repo/lib/bin_prot -I /home/opam/.opam/5.0+alpha-repo/lib/bin_prot/shape -I /home/opam/.opam/5.0+alpha-repo/lib/fieldslib -I /home/opam/.opam/5.0+alpha-repo/lib/int_repr -I /home/opam/.opam/5.0+alpha-repo/lib/jane-street-headers -I /home/opam/.opam/5.0+alpha-repo/lib/parsexp -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_assert/runtime-lib -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_bench/runtime-lib -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_compare/runtime-lib -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_enumerate/runtime-lib -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_expect/collector -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_expect/common -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_expect/config -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_expect/config_types -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_hash/runtime-lib -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_here/runtime-lib -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_inline_test/config -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_inline_test/runtime-lib -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_log/types -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_module_timer/runtime -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_sexp_conv/runtime-lib -I /home/opam/.opam/5.0+alpha-repo/lib/sexplib -I /home/opam/.opam/5.0+alpha-repo/lib/sexplib0 -I /home/opam/.opam/5.0+alpha-repo/lib/splittable_random -I /home/opam/.opam/5.0+alpha-repo/lib/stdio -I /home/opam/.opam/5.0+alpha-repo/lib/time_now -I /home/opam/.opam/5.0+alpha-repo/lib/typerep -I /home/opam/.opam/5.0+alpha-repo/lib/variantslib -I ../../base_for_tests/src -I ../../validate/src -o bigstring_stubs.o -c bigstring_stubs.c)
- In file included from bigstring_stubs.c:54:
- bigstring_stubs.c: In function 'core_bigstring_destroy':
- /home/opam/.opam/5.0+alpha-repo/lib/ocaml/caml/custom.h:48:27: warning: initialization discards 'const' qualifier from pointer target type [-Wdiscarded-qualifiers]
-    48 | #define Custom_ops_val(v) (*((const struct custom_operations **) (v)))
-       |                           ^
- bigstring_stubs.c:116:35: note: in expansion of macro 'Custom_ops_val'
-   116 |   struct custom_operations* ops = Custom_ops_val(v);
-       |                                   ^~~~~~~~~~~~~~
- (cd _build/default/core/src && /usr/bin/gcc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC -D_FILE_OFFSET_BITS=64 -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC -D_LARGEFILE64_SOURCE -g -I /home/opam/.opam/5.0+alpha-repo/lib/ocaml -I /home/opam/.opam/5.0+alpha-repo/lib/base -I /home/opam/.opam/5.0+alpha-repo/lib/base/base_internalhash_types -I /home/opam/.opam/5.0+alpha-repo/lib/base/caml -I /home/opam/.opam/5.0+alpha-repo/lib/base/md5 -I /home/opam/.opam/5.0+alpha-repo/lib/base/shadow_stdlib -I /home/opam/.opam/5.0+alpha-repo/lib/base_bigstring -I /home/opam/.opam/5.0+alpha-repo/lib/base_quickcheck -I /home/opam/.opam/5.0+alpha-repo/lib/base_quickcheck/ppx_quickcheck/runtime -I /home/opam/.opam/5.0+alpha-repo/lib/bin_prot -I /home/opam/.opam/5.0+alpha-repo/lib/bin_prot/shape -I /home/opam/.opam/5.0+alpha-repo/lib/fieldslib -I /home/opam/.opam/5.0+alpha-repo/lib/int_repr -I /home/opam/.opam/5.0+alpha-repo/lib/jane-street-headers -I /home/opam/.opam/5.0+alpha-repo/lib/parsexp -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_assert/runtime-lib -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_bench/runtime-lib -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_compare/runtime-lib -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_enumerate/runtime-lib -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_expect/collector -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_expect/common -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_expect/config -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_expect/config_types -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_hash/runtime-lib -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_here/runtime-lib -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_inline_test/config -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_inline_test/runtime-lib -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_log/types -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_module_timer/runtime -I /home/opam/.opam/5.0+alpha-repo/lib/ppx_sexp_conv/runtime-lib -I /home/opam/.opam/5.0+alpha-repo/lib/sexplib -I /home/opam/.opam/5.0+alpha-repo/lib/sexplib0 -I /home/opam/.opam/5.0+alpha-repo/lib/splittable_random -I /home/opam/.opam/5.0+alpha-repo/lib/stdio -I /home/opam/.opam/5.0+alpha-repo/lib/time_now -I /home/opam/.opam/5.0+alpha-repo/lib/typerep -I /home/opam/.opam/5.0+alpha-repo/lib/variantslib -I ../../base_for_tests/src -I ../../validate/src -o array_stubs.o -c array_stubs.c)
- array_stubs.c: In function 'core_array_unsafe_int_blit':
- array_stubs.c:14:11: warning: passing argument 1 of 'memmove' discards 'volatile' qualifier from pointer target type [-Wdiscarded-qualifiers]
-    14 |   memmove(&Field(dst, Long_val(dst_pos)),
- In file included from array_stubs.c:2:
- /usr/include/string.h:47:29: note: expected 'void *' but argument is of type 'volatile value *' {aka 'volatile long int *'}
-    47 | extern void *memmove (void *__dest, const void *__src, size_t __n)
-       |                       ~~~~~~^~~~~~
- array_stubs.c:15:11: warning: passing argument 2 of 'memmove' discards 'volatile' qualifier from pointer target type [-Wdiscarded-qualifiers]
-    15 |           &Field(src, Long_val(src_pos)),
- /usr/include/string.h:47:49: note: expected 'const void *' but argument is of type 'volatile value *' {aka 'volatile long int *'}
-    47 | extern void *memmove (void *__dest, const void *__src, size_t __n)
-       |                                     ~~~~~~~~~~~~^~~~~
-> compiled  core.v0.15.0.1~alpha-repo
-> installed core.v0.15.0.1~alpha-repo
Processing 190/197: [accessor_core: dune build]
Processing 191/197: [accessor_core: dune build] [core_kernel: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "accessor_core" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/accessor_core.v0.15.0)
-> compiled  accessor_core.v0.15.0
Processing 191/197: [core_kernel: dune build]
-> installed accessor_core.v0.15.0
Processing 192/197: [core_kernel: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "core_kernel" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/core_kernel.v0.15.0)
-> compiled  core_kernel.v0.15.0
-> installed core_kernel.v0.15.0
Processing 194/197: [async_kernel: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "async_kernel" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/async_kernel.v0.15.0)
-> compiled  async_kernel.v0.15.0
-> installed async_kernel.v0.15.0
Processing 196/197: [accessor_async: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "accessor_async" "-j" "31" (CWD=/home/opam/.opam/5.0+alpha-repo/.opam-switch/build/accessor_async.v0.15.0)
-> compiled  accessor_async.v0.15.0
-> installed accessor_async.v0.15.0
Done.
# Run eval $(opam env) to update the current shell environment
2022-09-02 11:33.55 ---> saved as "0077d68e124a18708e2225b216586b4d9c51ebfa2e3390f91259f9e5f3157d3d"
Job succeeded