OCamllabs icon Home|Differences with the last checks|Previous runs


Building on x86-bm-5.ocamllabs.io

(from ocaml/opam:debian-unstable@sha256:a20618cee40a09b4c7604919411db28c4ae473b9780730085f91824e8dd5f205)
Unable to find image 'ocaml/opam:debian-unstable@sha256:a20618cee40a09b4c7604919411db28c4ae473b9780730085f91824e8dd5f205' locally
docker.io/ocaml/opam@sha256:a20618cee40a09b4c7604919411db28c4ae473b9780730085f91824e8dd5f205: Pulling from ocaml/opam
f8f85475deda: Pulling fs layer
f8f85475deda: Download complete
f8f85475deda: Pull complete
Digest: sha256:a20618cee40a09b4c7604919411db28c4ae473b9780730085f91824e8dd5f205
Status: Downloaded newer image for ocaml/opam@sha256:a20618cee40a09b4c7604919411db28c4ae473b9780730085f91824e8dd5f205
2022-09-02 11:22.49 ---> using "00583e82ec888c922d57db664b8acb62b642829c5a4a94b17a44e5693b1db2de" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2022-09-02 11:22.49 ---> using "f816199fc982412d3ea70ae1ae1bab135eea82bc7670ac5d731bc57d0733e3c4" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q 418227c38ed4e28a0827786e5e9e50b9547c0b27"))
2022-09-02 11:22.49 ---> using "4cabcce7a0cb6de31986471b51abc9f1f3fec6a75be6e83e549da867c7605e5a" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2022-09-02 11:22.49 ---> using "d451da695ab21573c7bdead4176eec083b0218f568c4ccf5f5b38b162d64d4d7" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.07' '4.07.1'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.07.1"} | "ocaml-system" {= "4.07.1"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-base-compiler.4.07.1  (cached)
-> installed ocaml-base-compiler.4.07.1
-> installed ocaml-config.1
-> installed ocaml.4.07.1
Done.
# Run eval $(opam env --switch=4.07) to update the current shell environment
2022-09-02 11:22.49 ---> using "13a94c1348b779b7be3095c488c5bbd88141845f0b7666c6b8d92d2784077d63" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [192 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2022-09-02-0804.09-F-2022-08-29-1405.22.pdiff [252 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2022-09-02-0804.09-F-2022-08-29-1405.22.pdiff [252 kB]
- Fetched 508 kB in 3s (190 kB/s)
- Reading package lists...
- 
2022-09-02 11:22.49 ---> using "866b5b06d31d31351632b3dc9b939a539f9082f43d5437e14c580724adcf344e" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam install -y ocaml-secondary-compiler"))
The following actions will be performed:
=== install 1 package
  - install ocaml-secondary-compiler 4.08.1-1

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved ocaml-secondary-compiler.4.08.1-1  (cached)
-> installed ocaml-secondary-compiler.4.08.1-1
Done.
# Run eval $(opam env) to update the current shell environment
2022-09-02 11:22.49 ---> using "183c78b445e61c76952b1cfecb47a30e03880808b168386a4e55a75bff72f975" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"OCanren.0.3.0\"\
               \nopam install -vy \"OCanren.0.3.0\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"OCanren.0.3.0\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] OCanren.0.3.0 is not installed.

Nothing to do.
[ERROR] Package conflict!
  * No agreement on the version of ocaml-base-compiler:
    - (invariant) -> ocaml-base-compiler = 4.07.1
    - OCanren >= 0.3.0 -> ocaml >= 4.10 -> ocaml-base-compiler = 4.11.0
    You can temporarily relax the switch invariant with `--update-invariant'
  * Missing dependency:
    - OCanren >= 0.3.0 -> ocaml >= 4.10 -> ocaml-variants < 5.1.1~ -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'
  * Missing dependency:
    - OCanren >= 0.3.0 -> ocaml >= 4.10 -> ocaml-variants >= 4.10.0 -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'

No solution found, exiting
'opam install -vy OCanren.0.3.0' failed.
"/bin/bash" "-c"
"
opam remove -y "OCanren.0.3.0"
opam install -vy "OCanren.0.3.0"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "OCanren.0.3.0" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed