OCamllabs icon Home|Differences with the last checks|Previous runs


Building on m1-c.ocamllabs.io

(from ocaml/opam:debian-unstable@sha256:bb407f0ab6e2dc82dbe92df3e70b2bc766e3316a3deb0f8e1261a83d1ee9a8a6)
2022-07-31 17:48.56 ---> using "84ad74e48090150870a3f897d2aa4017a0b12d09be276f0731e715c5e6838ba3" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2022-07-31 17:48.56 ---> using "be6b4213b45a1b0ea178fb960e08c1a7ad35265b4a2569afe9e489d3c680a210" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q 3d455d59622e1fc4afaca747d0bb60440015528e"))
2022-07-31 17:48.56 ---> using "2fdc6004e5295913c5d70a730bac27055552229c20459beccd5addb9580ddb86" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

  ~/.profile is already up-to-date.
2022-07-31 17:48.56 ---> using "50ae04b82dccf8c14fad8a3f76afed55b097c55450975acbd7a4e66eac776465" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.08' '4.08.1'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.08.1"} | "ocaml-system" {= "4.08.1"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-base-compiler.4.08.1  (cached)
-> installed ocaml-base-compiler.4.08.1
-> installed ocaml-config.1
-> installed ocaml.4.08.1
Done.
# Run eval $(opam env --switch=4.08) to update the current shell environment
2022-07-31 17:48.56 ---> using "7236e921690c8c3f05afc60627e2530f57bcf04646235ab594b44da2cfe8b6b2" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [192 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2022-07-31-1403.39-F-2022-07-19-1412.00.pdiff [899 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2022-07-31-1403.39-F-2022-07-19-1412.00.pdiff [899 kB]
- Fetched 1155 kB in 4s (324 kB/s)
- Reading package lists...
- 
2022-07-31 17:48.56 ---> using "2afbffbe93550782602432e550f109d4eba78eb5aa136ae976e959dd9e9ccb9e" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"accessor_core.v0.15.0\"\
               \nopam install -vy \"accessor_core.v0.15.0\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"accessor_core.v0.15.0\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
Nothing to do.
[NOTE] accessor_core.v0.15.0 is not installed.

[ERROR] Package conflict!
  * No agreement on the version of ocaml-base-compiler:
    - (invariant) -> ocaml-base-compiler = 4.08.1
    - accessor_core >= v0.15.0 -> ocaml >= 4.09.0 -> ocaml-base-compiler = 4.09.1
    You can temporarily relax the switch invariant with `--update-invariant'
  * Missing dependency:
    - accessor_core >= v0.15.0 -> ocaml >= 4.09.0 -> ocaml-variants < 4.09.3~ -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'
  * Missing dependency:
    - accessor_core >= v0.15.0 -> ocaml >= 4.09.0 -> ocaml-variants >= 4.09.0 -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'

No solution found, exiting
'opam install -vy accessor_core.v0.15.0' failed.
"/bin/bash" "-c"
"
opam remove -y "accessor_core.v0.15.0"
opam install -vy "accessor_core.v0.15.0"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "accessor_core.v0.15.0" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed