OCamllabs icon Home|Differences with the last checks|Previous runs


Building on asteria.ocamllabs.io

(from ocaml/opam:debian-unstable@sha256:ecfeea51a8151a94850ab8f8a5cf42d89238a992d746070684aa038540bf4d02)
Unable to find image 'ocaml/opam:debian-unstable@sha256:ecfeea51a8151a94850ab8f8a5cf42d89238a992d746070684aa038540bf4d02' locally
docker.io/ocaml/opam@sha256:ecfeea51a8151a94850ab8f8a5cf42d89238a992d746070684aa038540bf4d02: Pulling from ocaml/opam
74eb7a1f108d: Already exists
ca9aea9b2c0b: Pulling fs layer
bab996ef39fb: Pulling fs layer
bab996ef39fb: Verifying Checksum
bab996ef39fb: Download complete
ca9aea9b2c0b: Verifying Checksum
ca9aea9b2c0b: Download complete
ca9aea9b2c0b: Pull complete
bab996ef39fb: Pull complete
Digest: sha256:ecfeea51a8151a94850ab8f8a5cf42d89238a992d746070684aa038540bf4d02
Status: Downloaded newer image for ocaml/opam@sha256:ecfeea51a8151a94850ab8f8a5cf42d89238a992d746070684aa038540bf4d02
2022-05-30 01:38.00 ---> using "470a4ec6191ce5b29ab8f829e9f65e060138b47911c121ad15640bf03792289e" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2022-05-30 01:38.00 ---> using "7d33f374c52f29410050d81cf1074485a1754fb678c631be587a50657e84327a" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q 40f3586d6235b95c53ec3719ec6e95627b267598"))
2022-05-30 01:38.00 ---> using "e33a044ce2eb47afe61fb7dd84a6bfe3fa79161accda7ec0865264012c47760c" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2022-05-30 01:38.00 ---> using "c26bb5627e7479eb41d89d97377d7acba4247f55847871ee2cea94e108e928c3" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.04' '4.04.2'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.04.2"} | "ocaml-system" {= "4.04.2"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-base-compiler.4.04.2  (cached)
-> installed ocaml-base-compiler.4.04.2
-> installed ocaml-config.1
-> installed ocaml.4.04.2
Done.
# Run eval $(opam env --switch=4.04) to update the current shell environment
2022-05-30 01:38.00 ---> using "9355058972eba8f254fba6bf49779c45a247b0332aafa5f56ee85c2c706fa0cb" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [165 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2022-05-27-2017.43-F-2022-05-17-0803.30.pdiff [534 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2022-05-27-2017.43-F-2022-05-17-0803.30.pdiff [534 kB]
- Fetched 763 kB in 1s (573 kB/s)
- Reading package lists...
2022-05-30 01:38.00 ---> using "c6b271370369079ce96a5a14119d32a2992ca377d556a7afaf55550d2b8718cb" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam install -y ocaml-secondary-compiler"))
The following actions will be performed:
=== install 1 package
  - install ocaml-secondary-compiler 4.08.1-1

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved ocaml-secondary-compiler.4.08.1-1  (cached)
-> installed ocaml-secondary-compiler.4.08.1-1
Done.
# Run eval $(opam env) to update the current shell environment
2022-05-30 01:38.00 ---> using "88b7b416ea7c9059b0d0e8c4dc90c9750ce09f522efa630ef74911f82f83a2b7" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"calculon-web.0.7\"\
               \nopam install -vy \"calculon-web.0.7\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"calculon-web.0.7\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
Nothing to do.
[NOTE] calculon-web.0.7 is not installed.

[ERROR] Package conflict!
No solution found, exiting
  * No agreement on the version of ocaml:
    - (invariant) -> ocaml-base-compiler = 4.04.2 -> ocaml = 4.04.2
    - calculon-web >= 0.7 -> calculon >= 0.7 -> ocaml >= 4.08.0
    You can temporarily relax the switch invariant with `--update-invariant'

'opam install -vy calculon-web.0.7' failed.
"/bin/bash" "-c"
"
opam remove -y "calculon-web.0.7"
opam install -vy "calculon-web.0.7"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "calculon-web.0.7" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed