OCamllabs icon Home|Differences with the last checks|Previous runs


Building on m1-c.ocamllabs.io

(from ocaml/opam:debian-unstable@sha256:ab7f0b8ac566a6726439e621a0807bcd9fc12180ea873955fd963cfd263c279c)
Unable to find image 'ocaml/opam:debian-unstable@sha256:ab7f0b8ac566a6726439e621a0807bcd9fc12180ea873955fd963cfd263c279c' locally
docker.io/ocaml/opam@sha256:ab7f0b8ac566a6726439e621a0807bcd9fc12180ea873955fd963cfd263c279c: Pulling from ocaml/opam
7c26de214b34: Already exists
686e2e0ed2af: Pulling fs layer
6f56e1824cd6: Pulling fs layer
6f56e1824cd6: Download complete
686e2e0ed2af: Verifying Checksum
686e2e0ed2af: Download complete
686e2e0ed2af: Pull complete
6f56e1824cd6: Pull complete
Digest: sha256:ab7f0b8ac566a6726439e621a0807bcd9fc12180ea873955fd963cfd263c279c
Status: Downloaded newer image for ocaml/opam@sha256:ab7f0b8ac566a6726439e621a0807bcd9fc12180ea873955fd963cfd263c279c
2022-05-11 21:46.48 ---> using "31be97220bde553e6e760a64d33a5a13bf22f7bc7b939c6db9f7e6618bb986a9" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2022-05-11 21:46.48 ---> using "179f53753baadbe2063c82b23383d48191f66b8e16101240f7dfbf1ced2cc270" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q 7ebba7f05b4ae6507db523882e2a6df3fcb82fb3"))
2022-05-11 21:46.48 ---> using "e03d0e1409ca900b4238dc5a99fda90533ac437f633561f6a23a7ce554600652" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2022-05-11 21:46.48 ---> using "f2b762bd14fc0fe661511410f052bca3d3a6d98c0572418fb3219e7975323dc4" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.14' '4.14.0'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.14.0"} | "ocaml-system" {= "4.14.0"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> installed ocaml-options-vanilla.1
-> retrieved ocaml-base-compiler.4.14.0  (cached)
-> installed ocaml-base-compiler.4.14.0
-> installed ocaml-config.2
-> installed ocaml.4.14.0
Done.
# Run eval $(opam env --switch=4.14) to update the current shell environment
2022-05-11 21:46.48 ---> using "0bdbeab844a5c0d444466b6898d035067688706f61777272f6b865e758fee51b" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [165 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Ign:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages [9165 kB]
- Fetched 9394 kB in 3s (2931 kB/s)
- Reading package lists...
2022-05-11 21:46.48 ---> using "6091c105dd394b2e48910fc198c2a03e4a9247021e305c794ee256dde1d1dbf0" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"abt.0.0.3\"\
               \nopam install -vy \"abt.0.0.3\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"abt.0.0.3\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] abt.0.0.3 is not installed.

Nothing to do.
[ERROR] Package conflict!
  * No agreement on the version of ocaml:
    - (invariant) -> ocaml-base-compiler >= 4.14.0 -> ocaml = 4.14.0
    - abt -> core_kernel < v0.9.0 -> ocaml < 4.02.1
    You can temporarily relax the switch invariant with `--update-invariant'
  * No agreement on the version of ocaml-base-compiler:
    - (invariant) -> ocaml-base-compiler >= 4.14.0
    - abt -> core_kernel < v0.9.0 -> ocaml = 4.02.3 -> ocaml-base-compiler = 4.02.3
  * Missing dependency:
    - abt -> core_kernel < v0.9.0 -> ocaml = 4.02.3 -> ocaml-variants >= 4.02.3 -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'

No solution found, exiting
'opam install -vy abt.0.0.3' failed.
"/bin/bash" "-c"
"
opam remove -y "abt.0.0.3"
opam install -vy "abt.0.0.3"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "abt.0.0.3" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed