OCamllabs icon Home|Differences with the last checks|Previous runs


Building on pima.ocamllabs.io

(from ocaml/opam:debian-unstable@sha256:ab7f0b8ac566a6726439e621a0807bcd9fc12180ea873955fd963cfd263c279c)
Unable to find image 'ocaml/opam:debian-unstable@sha256:ab7f0b8ac566a6726439e621a0807bcd9fc12180ea873955fd963cfd263c279c' locally
docker.io/ocaml/opam@sha256:ab7f0b8ac566a6726439e621a0807bcd9fc12180ea873955fd963cfd263c279c: Pulling from ocaml/opam
7c26de214b34: Already exists
686e2e0ed2af: Pulling fs layer
6f56e1824cd6: Pulling fs layer
6f56e1824cd6: Verifying Checksum
6f56e1824cd6: Download complete
686e2e0ed2af: Verifying Checksum
686e2e0ed2af: Download complete
686e2e0ed2af: Pull complete
6f56e1824cd6: Pull complete
Digest: sha256:ab7f0b8ac566a6726439e621a0807bcd9fc12180ea873955fd963cfd263c279c
Status: Downloaded newer image for ocaml/opam@sha256:ab7f0b8ac566a6726439e621a0807bcd9fc12180ea873955fd963cfd263c279c
2022-05-11 22:37.15 ---> using "31be97220bde553e6e760a64d33a5a13bf22f7bc7b939c6db9f7e6618bb986a9" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2022-05-11 22:37.15 ---> using "179f53753baadbe2063c82b23383d48191f66b8e16101240f7dfbf1ced2cc270" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q 7ebba7f05b4ae6507db523882e2a6df3fcb82fb3"))
2022-05-11 22:37.15 ---> using "e03d0e1409ca900b4238dc5a99fda90533ac437f633561f6a23a7ce554600652" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2022-05-11 22:37.15 ---> using "f2b762bd14fc0fe661511410f052bca3d3a6d98c0572418fb3219e7975323dc4" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.10' '4.10.2'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.10.2"} | "ocaml-system" {= "4.10.2"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-base-compiler.4.10.2  (cached)
-> installed ocaml-base-compiler.4.10.2
-> installed ocaml-config.1
-> installed ocaml.4.10.2
Done.
# Run eval $(opam env --switch=4.10) to update the current shell environment
2022-05-11 22:37.15 ---> using "93b69ac5b68338276c94674ff0d58bf90bf31aaebf22712a622bd2ee7e013588" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [165 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Ign:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages [9165 kB]
- Fetched 9394 kB in 2s (4987 kB/s)
- Reading package lists...
- 
2022-05-11 22:37.15 ---> using "916c1783ae7c945b78e6a757d49b1b452a451e1ef5c4c74810b343f2cddacdff" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"async-mvar.0.1.0\"\
               \nopam install -vy \"async-mvar.0.1.0\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"async-mvar.0.1.0\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] async-mvar.0.1.0 is not installed.

Nothing to do.
[ERROR] Package conflict!
No solution found, exiting
  * No agreement on the version of ocaml:
    - (invariant) -> ocaml-base-compiler = 4.10.2 -> ocaml = 4.10.2
    - async-mvar -> core_kernel < 113.24.00 -> ocaml < 4.02.1
    You can temporarily relax the switch invariant with `--update-invariant'

'opam install -vy async-mvar.0.1.0' failed.
"/bin/bash" "-c"
"
opam remove -y "async-mvar.0.1.0"
opam install -vy "async-mvar.0.1.0"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "async-mvar.0.1.0" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed