OCamllabs icon Home|Differences with the last checks|Previous runs


Building on marpe.ocamllabs.io

(from ocaml/opam:debian-unstable@sha256:62ae74868419940a0a8d446d6b24fb54d1e206ed0d6bd202c9f46c230f7df1cf)
Unable to find image 'ocaml/opam:debian-unstable@sha256:62ae74868419940a0a8d446d6b24fb54d1e206ed0d6bd202c9f46c230f7df1cf' locally
docker.io/ocaml/opam@sha256:62ae74868419940a0a8d446d6b24fb54d1e206ed0d6bd202c9f46c230f7df1cf: Pulling from ocaml/opam
007cfbb78823: Already exists
edf3681963a0: Pulling fs layer
181467391df8: Pulling fs layer
181467391df8: Verifying Checksum
181467391df8: Download complete
edf3681963a0: Verifying Checksum
edf3681963a0: Download complete
edf3681963a0: Pull complete
181467391df8: Pull complete
Digest: sha256:62ae74868419940a0a8d446d6b24fb54d1e206ed0d6bd202c9f46c230f7df1cf
Status: Downloaded newer image for ocaml/opam@sha256:62ae74868419940a0a8d446d6b24fb54d1e206ed0d6bd202c9f46c230f7df1cf
2022-04-21 13:37.21 ---> using "762188f9398aba124469f63b90ef28f78843303841337e68ccd45493eb15dc5f" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2022-04-21 13:37.21 ---> using "a15a00d0ccbc261934a81c26be68bf36d968f2bc911a45b736c8af7735348ff8" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q c5e50e60ba0d358270d3d6dc037f7d055dc61d08"))
2022-04-21 13:37.21 ---> using "0c46a3114082274bf9eac9b20e57b4acb2102543813d8cf462fc3081839e0628" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2022-04-21 13:37.21 ---> using "75ef25fbdf0fae6666c31c2f8960b63b4568c4d552ffaeddca7b23a16bb6dbc5" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.13' '4.13.1'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.13.1"} | "ocaml-system" {= "4.13.1"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> installed ocaml-options-vanilla.1
-> retrieved ocaml-base-compiler.4.13.1  (cached)
-> installed ocaml-base-compiler.4.13.1
-> installed ocaml-config.2
-> installed ocaml.4.13.1
Done.
# Run eval $(opam env --switch=4.13) to update the current shell environment
2022-04-21 13:37.21 ---> using "4ec830ed2304b48fa836ab00d53bdda4000fdf78f33a9fe761530536b7a08cd3" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [165 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Ign:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages [9149 kB]
- Fetched 9378 kB in 1s (7161 kB/s)
- Reading package lists...
2022-04-21 13:37.21 ---> using "16e8fe13eebdd50b5d951da21e683bc879b2183b471980e6fd3ccb6cab6d25a2" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"camelot.1.7.1\"\
               \nopam install -vy \"camelot.1.7.1\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"camelot.1.7.1\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] camelot.1.7.1 is not installed.

Nothing to do.
[ERROR] Package conflict!
No solution found, exiting
  * No agreement on the version of ocaml:
    - (invariant) -> ocaml-base-compiler = 4.13.1 -> ocaml = 4.13.1
    - camelot >= 1.7.1 -> ocaml < 4.13
    You can temporarily relax the switch invariant with `--update-invariant'

'opam install -vy camelot.1.7.1' failed.
"/bin/bash" "-c"
"
opam remove -y "camelot.1.7.1"
opam install -vy "camelot.1.7.1"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "camelot.1.7.1" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed