OCamllabs icon Home|Differences with the last checks|Previous runs


Building on x86-bm-1.ocamllabs.io

(from ocaml/opam:debian-unstable@sha256:62ae74868419940a0a8d446d6b24fb54d1e206ed0d6bd202c9f46c230f7df1cf)
Unable to find image 'ocaml/opam:debian-unstable@sha256:62ae74868419940a0a8d446d6b24fb54d1e206ed0d6bd202c9f46c230f7df1cf' locally
docker.io/ocaml/opam@sha256:62ae74868419940a0a8d446d6b24fb54d1e206ed0d6bd202c9f46c230f7df1cf: Pulling from ocaml/opam
007cfbb78823: Already exists
edf3681963a0: Pulling fs layer
181467391df8: Pulling fs layer
181467391df8: Verifying Checksum
181467391df8: Download complete
edf3681963a0: Download complete
edf3681963a0: Pull complete
181467391df8: Pull complete
Digest: sha256:62ae74868419940a0a8d446d6b24fb54d1e206ed0d6bd202c9f46c230f7df1cf
Status: Downloaded newer image for ocaml/opam@sha256:62ae74868419940a0a8d446d6b24fb54d1e206ed0d6bd202c9f46c230f7df1cf
2022-04-21 08:07.24 ---> using "762188f9398aba124469f63b90ef28f78843303841337e68ccd45493eb15dc5f" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2022-04-21 08:07.24 ---> using "a15a00d0ccbc261934a81c26be68bf36d968f2bc911a45b736c8af7735348ff8" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q c5e50e60ba0d358270d3d6dc037f7d055dc61d08"))
2022-04-21 08:07.24 ---> using "0c46a3114082274bf9eac9b20e57b4acb2102543813d8cf462fc3081839e0628" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2022-04-21 08:07.24 ---> using "75ef25fbdf0fae6666c31c2f8960b63b4568c4d552ffaeddca7b23a16bb6dbc5" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.03' '4.03.0'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.03.0"} | "ocaml-system" {= "4.03.0"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-base-compiler.4.03.0  (https://github.com/ocaml/ocaml/archive/4.03.0.tar.gz)
-> installed ocaml-base-compiler.4.03.0
-> installed ocaml-config.1
-> installed ocaml.4.03.0
Done.
# Run eval $(opam env --switch=4.03) to update the current shell environment
2022-04-21 08:07.24 ---> using "84206ec5a5ad79f94d8fa097dacb899cec34e4681b8fcd388a50dbc2d7560064" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [165 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Ign:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages [9149 kB]
- Fetched 9378 kB in 2s (5690 kB/s)
- Reading package lists...
- 
2022-04-21 08:07.24 ---> using "b4a0e185420ce72e02b23a0528b194baef49c26a27e93b1fa1174bee58397b1c" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam install -y ocaml-secondary-compiler"))
The following actions will be performed:
=== install 1 package
  - install ocaml-secondary-compiler 4.08.1-1

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved ocaml-secondary-compiler.4.08.1-1  (cached)
-> installed ocaml-secondary-compiler.4.08.1-1
Done.
# Run eval $(opam env) to update the current shell environment
2022-04-21 08:07.24 ---> using "8caf3a415931897cf430b46984bc2e4e2ddd3c70b0e0378c91ec676230e9d8e1" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"ask.0.2.0\"\
               \nopam install -vy \"ask.0.2.0\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"ask.0.2.0\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] ask.0.2.0 is not installed.

Nothing to do.
[ERROR] Package conflict!
No solution found, exiting
  * No agreement on the version of ocaml-base-compiler:
    - (invariant) -> ocaml-base-compiler = 4.03.0
    - ask -> ocaml >= 4.11 -> ocaml-base-compiler = 4.11.0
    You can temporarily relax the switch invariant with `--update-invariant'
  * Missing dependency:
    - ask -> ocaml >= 4.11 -> ocaml-variants < 4.11.4~ -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'
  * Missing dependency:
    - ask -> ocaml >= 4.11 -> ocaml-variants >= 4.11.0 -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'

'opam install -vy ask.0.2.0' failed.
"/bin/bash" "-c"
"
opam remove -y "ask.0.2.0"
opam install -vy "ask.0.2.0"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "ask.0.2.0" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed