OCamllabs icon Home|Differences with the last checks|Previous runs


Building on phoebe.ocamllabs.io

(from ocaml/opam:debian-unstable@sha256:a13c01aab19715953d47831effb2beb0ac90dc98c13b216893db2550799e3b9f)
2022-01-11 04:13.36 ---> using "25f41b9b491d02c7254b970e99985d870c42757893c20fc18444d6909849d261" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2022-01-11 04:13.36 ---> using "c24d6e6ed3acb535aaba9c88e96e6ada0fbaa14bd43ffd1def50fa468542e261" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'https://github.com/ocaml/opam-repository' ~/opam-repository && git -C ~/opam-repository checkout -q c14aaaa298d8e4577d7c56422e0de69a4d0818fa"))
2022-01-11 04:13.36 ---> using "e68d9b9f57f0f96efeb7bc081692c1dd1590494e494678b74fd3395445d2e470" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2022-01-11 04:13.36 ---> using "deb88c8fbe443db08484583d4adebeb2493ed1e6134d873c3bbfb72f14b8d5bc" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=default '4.10' '4.10.2'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.10.2"} | "ocaml-system" {= "4.10.2"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-base-compiler.4.10.2  (cached)
-> installed ocaml-base-compiler.4.10.2
-> installed ocaml-config.1
-> installed ocaml.4.10.2
Done.
# Run eval $(opam env --switch=4.10) to update the current shell environment
2022-01-11 04:13.36 ---> using "7dc9b733243a81dfecdf6a07cfb7044a608eda74c41e45e47602f235bedca928" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [165 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2022-01-11-0202.29-F-2022-01-05-2001.28.pdiff [246 kB]
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages T-2022-01-11-0202.29-F-2022-01-05-2001.28.pdiff [246 kB]
- Fetched 475 kB in 3s (169 kB/s)
- Reading package lists...
- 
2022-01-11 04:13.36 ---> using "2a118edb0ef33e3a5e656626a81a889eff6d8f469e24cd892c30a93fcf54cb3e" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"OCanren-ppx.0.2.0\"\
               \nopam install -vy \"OCanren-ppx.0.2.0\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"OCanren-ppx.0.2.0\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] OCanren-ppx.0.2.0 is not installed.

Nothing to do.
The following actions will be performed:
  - install dune                2.9.1   [required by OCanren-ppx]
  - install stdlib-shims        0.3.0   [required by ppxlib]
  - install sexplib0            v0.14.0 [required by base, ppxlib]
  - install result              1.5     [required by dune-configurator]
  - install ppx_derivers        1.2.1   [required by ppxlib]
  - install ocaml-compiler-libs v0.12.4 [required by ppxlib]
  - install csexp               1.5.1   [required by dune-configurator]
  - install ppxlib              0.24.0  [required by OCanren-ppx]
  - install dune-configurator   2.9.1   [required by OCanren-ppx]
  - install base                v0.14.2 [required by OCanren-ppx]
  - install OCanren-ppx         0.2.0
===== 11 to install =====

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Processing  1/33:
Processing  2/33:
Processing  3/33:
-> retrieved csexp.1.5.1  (cached)
Processing  4/33:
-> retrieved base.v0.14.2  (cached)
Processing  5/33: [OCanren-ppx.0.2.0: http]
-> retrieved dune.2.9.1  (cached)
Processing  6/33: [OCanren-ppx.0.2.0: http]
Processing  7/33: [OCanren-ppx.0.2.0: http] [dune: ocaml bootstrap.ml]
-> retrieved dune-configurator.2.9.1  (cached)
Processing  8/33: [OCanren-ppx.0.2.0: http] [dune: ocaml bootstrap.ml]
Processing  8/33: [dune: ocaml bootstrap.ml]
-> retrieved ocaml-compiler-libs.v0.12.4  (cached)
Processing  9/33: [dune: ocaml bootstrap.ml]
-> retrieved ppx_derivers.1.2.1  (cached)
Processing 10/33: [dune: ocaml bootstrap.ml]
-> retrieved result.1.5  (cached)
Processing 11/33: [dune: ocaml bootstrap.ml]
-> retrieved sexplib0.v0.14.0  (cached)
Processing 12/33: [dune: ocaml bootstrap.ml]
-> retrieved stdlib-shims.0.3.0  (cached)
-> retrieved ppxlib.0.24.0  (cached)
-> retrieved OCanren-ppx.0.2.0  (https://github.com/JetBrains-Research/OCanren/releases/download/0.2.0/OCanren-ppx-0.2.0.tbz)
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "ocaml" "bootstrap.ml" "-j" "71" (CWD=/home/opam/.opam/4.10/.opam-switch/build/dune.2.9.1)
- ocamlc -output-complete-exe -w -24 -g -o .duneboot.exe -I boot unix.cma boot/libs.ml boot/duneboot.ml
- ./.duneboot.exe -j 71
- 

Processing 12/33: [dune: ./dune.exe build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "./dune.exe" "build" "-p" "dune" "--profile" "dune-bootstrap" "-j" "71" (CWD=/home/opam/.opam/4.10/.opam-switch/build/dune.2.9.1)
-> compiled  dune.2.9.1
-> installed dune.2.9.1
Processing 14/33: [csexp: dune build]
Processing 15/33: [csexp: dune build] [ocaml-compiler-libs: dune build]
Processing 16/33: [csexp: dune build] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build]
Processing 17/33: [csexp: dune build] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [result: dune build]
Processing 18/33: [csexp: dune build] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [result: dune build] [sexplib0: dune build]
Processing 19/33: [csexp: dune build] [ocaml-compiler-libs: dune build] [ppx_derivers: dune build] [result: dune build] [sexplib0: dune build] [stdlib-shims: dune build]
-> compiled  ppx_derivers.1.2.1
Processing 19/33: [csexp: dune build] [ocaml-compiler-libs: dune build] [result: dune build] [sexplib0: dune build] [stdlib-shims: dune build]
-> installed ppx_derivers.1.2.1
Processing 20/33: [csexp: dune build] [ocaml-compiler-libs: dune build] [result: dune build] [sexplib0: dune build] [stdlib-shims: dune build]
-> compiled  csexp.1.5.1
Processing 20/33: [ocaml-compiler-libs: dune build] [result: dune build] [sexplib0: dune build] [stdlib-shims: dune build]
-> installed csexp.1.5.1
Processing 21/33: [ocaml-compiler-libs: dune build] [result: dune build] [sexplib0: dune build] [stdlib-shims: dune build]
-> compiled  result.1.5
Processing 21/33: [ocaml-compiler-libs: dune build] [sexplib0: dune build] [stdlib-shims: dune build]
-> installed result.1.5
Processing 22/33: [ocaml-compiler-libs: dune build] [sexplib0: dune build] [stdlib-shims: dune build]
Processing 23/33: [dune-configurator: dune build] [ocaml-compiler-libs: dune build] [sexplib0: dune build] [stdlib-shims: dune build]
-> compiled  stdlib-shims.0.3.0
Processing 23/33: [dune-configurator: dune build] [ocaml-compiler-libs: dune build] [sexplib0: dune build]
-> installed stdlib-shims.0.3.0
Processing 24/33: [dune-configurator: dune build] [ocaml-compiler-libs: dune build] [sexplib0: dune build]
-> compiled  sexplib0.v0.14.0
Processing 24/33: [dune-configurator: dune build] [ocaml-compiler-libs: dune build]
-> installed sexplib0.v0.14.0
Processing 25/33: [dune-configurator: dune build] [ocaml-compiler-libs: dune build]
-> compiled  ocaml-compiler-libs.v0.12.4
Processing 25/33: [dune-configurator: dune build]
-> installed ocaml-compiler-libs.v0.12.4
Processing 26/33: [dune-configurator: dune build]
Processing 27/33: [dune-configurator: dune build] [ppxlib: dune build]
-> compiled  dune-configurator.2.9.1
Processing 27/33: [ppxlib: dune build]
-> installed dune-configurator.2.9.1
Processing 28/33: [ppxlib: dune build]
Processing 29/33: [base: dune build] [ppxlib: dune build]
-> compiled  base.v0.14.2
Processing 29/33: [ppxlib: dune build]
-> installed base.v0.14.2
Processing 30/33: [ppxlib: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppxlib" "-j" "71" "@install" (CWD=/home/opam/.opam/4.10/.opam-switch/build/ppxlib.0.24.0)
-> compiled  ppxlib.0.24.0
-> installed ppxlib.0.24.0
Processing 32/33: [OCanren-ppx: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "OCanren-ppx" "-j" "71" (CWD=/home/opam/.opam/4.10/.opam-switch/build/OCanren-ppx.0.2.0)
-       ocamlc ppx/distrib/.ppx_distrib.objs/byte/ppx_distrib__Ppx_distrib_expander.{cmi,cmo,cmt}
- File "ppx/distrib/ppx_distrib_expander.ml", lines 60-61, characters 2-24:
- 60 | ..let Pcstr_tuple pcd_args = pcd_args in
- 61 |   extract_names pcd_args
- Warning 8: this pattern-matching is not exhaustive.
- Here is an example of a case that is not matched:
- Pcstr_record _
-     ocamlopt ppx/distrib/.ppx_distrib.objs/native/ppx_distrib__Ppx_distrib_expander.{cmx,o}
- File "ppx/distrib/ppx_distrib_expander.ml", lines 60-61, characters 2-24:
- 60 | ..let Pcstr_tuple pcd_args = pcd_args in
- 61 |   extract_names pcd_args
- Warning 8: this pattern-matching is not exhaustive.
- Here is an example of a case that is not matched:
- Pcstr_record _
-> compiled  OCanren-ppx.0.2.0
-> installed OCanren-ppx.0.2.0
Done.
# Run eval $(opam env) to update the current shell environment
2022-01-11 04:14.28 ---> saved as "cc354f61bd1d0b27f7f716a2c802c0eb71e9f3beffa0f44b46c8188299a96e21"
Job succeeded