OCamllabs icon Home|Differences with the last checks|Previous runs


Building on apache.ocamllabs.io

(from ocaml/opam:debian-unstable)
WARNING: Error loading config file: .dockercfg: $HOME is not defined
2021-11-20 23:47.06 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-2.1 /usr/bin/opam"))
2021-11-20 23:47.06 ---> using "4d29eb3e0b7cd69a97ed90837671d5ca38aa41e2fb94346298af500378eca6fa" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'git://github.com/ocaml/opam-repository.git' ~/opam-repository && git -C ~/opam-repository checkout -q 092c37746a8cb99ad2a9eefb7943196a9f1cedc2"))
2021-11-20 23:47.06 ---> using "b16b0ba39ac480f1735de0669bb4ac773826ab8eac33ef47d77f0f0f78464c94" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2021-11-20 23:47.06 ---> using "2afdc0690c5df357ea3e845c3eef70aee34e4ad430085bc0cf66a0cce51d1232" from cache

/: (run (network host)
        (shell "git clone -q 'git://github.com/ocaml/ocaml-beta-repository.git' ~/'beta' && git -C ~/'beta' checkout -q 79aeeadd813bdae424ab53f882f08bee0a4e0b89"))
2021-11-20 23:47.06 ---> using "55d1403124175c5424188f0334144b7f3e548012f40d8a9f57dd3407e9bf5016" from cache

/: (run (shell "opam repository add --dont-select 'beta' ~/'beta'"))
[beta] Initialised
2021-11-20 23:47.06 ---> using "c8b605c6210873a972c1f801736d60c96480eb79d742379c4645a8288d014e32" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=beta,default '4.13' '4.13.1'"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.13.1"} | "ocaml-system" {= "4.13.1"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> installed ocaml-options-vanilla.1
-> retrieved ocaml-base-compiler.4.13.1  (cached)
-> installed ocaml-base-compiler.4.13.1
-> installed ocaml-config.2
-> installed ocaml.4.13.1
Done.
# Run eval $(opam env --switch=4.13) to update the current shell environment
2021-11-20 23:47.06 ---> using "6e1e9ae3e45853472824dcfbedc78d05f2db7f0d0dc700a044d7a1c41c898d01" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [165 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Ign:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages [8853 kB]
- Fetched 9082 kB in 2s (5406 kB/s)
- Reading package lists...
- 
2021-11-20 23:47.06 ---> using "f779045ead18286950b522e80293ab660c17137e332ee0206e30f46b760840fc" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"async_inotify.v0.14.0\"\
               \nopam install -vy \"async_inotify.v0.14.0\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"async_inotify.v0.14.0\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
Nothing to do.
[NOTE] async_inotify.v0.14.0 is not installed.

The following actions will be performed:
  - install seq                     base    [required by re]
  - install ocamlbuild              0.14.0  [required by inotify]
  - install ocamlfind               1.9.1   [required by inotify]
  - install dune                    2.9.1   [required by async_inotify]
  - install num                     1.4     [required by sexplib]
  - install base-bytes              base    [required by inotify]
  - install stdlib-shims            0.3.0   [required by ppxlib]
  - install spawn                   v0.14.0 [required by core]
  - install sexplib0                v0.14.0 [required by base, sexplib]
  - install result                  1.5     [required by dune-configurator]
  - install re                      1.10.3  [required by ppx_expect]
  - install ppx_derivers            1.2.1   [required by ppxlib]
  - install octavius                1.2.2   [required by ppx_js_style]
  - install ocaml-compiler-libs     v0.12.4 [required by ppxlib]
  - install jane-street-headers     v0.14.0 [required by core_kernel]
  - install csexp                   1.5.1   [required by dune-configurator]
  - install inotify                 2.3     [required by async_inotify]
  - install ppxlib                  0.23.0  [required by ppx_jane]
  - install dune-configurator       2.9.1   [required by base]
  - install ppx_pipebang            v0.14.0 [required by ppx_jane]
  - install base                    v0.14.1 [required by core_kernel]
  - install variantslib             v0.14.0 [required by core_kernel]
  - install typerep                 v0.14.0 [required by core_kernel]
  - install stdio                   v0.14.0 [required by core_kernel]
  - install ppx_stable              v0.14.1 [required by ppx_jane]
  - install ppx_sexp_conv           v0.14.3 [required by core_kernel]
  - install ppx_optional            v0.14.0 [required by ppx_jane]
  - install ppx_let                 v0.14.0 [required by ppx_jane]
  - install ppx_js_style            v0.14.1 [required by ppx_base]
  - install ppx_here                v0.14.0 [required by ppx_jane]
  - install ppx_fixed_literal       v0.14.0 [required by ppx_jane]
  - install ppx_enumerate           v0.14.0 [required by ppx_base]
  - install ppx_compare             v0.14.0 [required by ppx_base, bin_prot]
  - install ppx_cold                v0.14.0 [required by ppx_base]
  - install parsexp                 v0.14.1 [required by sexplib]
  - install fieldslib               v0.14.0 [required by core_kernel]
  - install ppx_variants_conv       v0.14.2 [required by ppx_jane]
  - install ppx_typerep_conv        v0.14.2 [required by ppx_jane]
  - install ppx_optcomp             v0.14.3 [required by core_kernel]
  - install ppx_custom_printf       v0.14.1 [required by ppx_jane]
  - install ppx_sexp_value          v0.14.0 [required by ppx_jane]
  - install ppx_sexp_message        v0.14.1 [required by core_kernel]
  - install ppx_hash                v0.14.0 [required by core_kernel]
  - install ppx_assert              v0.14.0 [required by core_kernel]
  - install sexplib                 v0.14.0 [required by core_kernel, core]
  - install ppx_fields_conv         v0.14.2 [required by ppx_jane]
  - install ppx_base                v0.14.0 [required by core_kernel]
  - install jst-config              v0.14.1 [required by core_kernel, core]
  - install bin_prot                v0.14.0 [required by core_kernel]
  - install ppx_string              v0.14.1 [required by ppx_jane]
  - install time_now                v0.14.0 [required by core_kernel]
  - install ppx_bin_prot            v0.14.0 [required by ppx_jane]
  - install ppx_module_timer        v0.14.0 [required by ppx_jane]
  - install ppx_inline_test         v0.14.1 [required by core_kernel]
  - install ppx_expect              v0.14.1 [required by ppx_jane]
  - install ppx_bench               v0.14.1 [required by ppx_jane]
  - install splittable_random       v0.14.0 [required by core_kernel]
  - install base_quickcheck         v0.14.1 [required by core_kernel]
  - install ppx_jane                v0.14.0 [required by async_inotify]
  - install base_bigstring          v0.14.0 [required by core_kernel]
  - install core_kernel             v0.14.2 [required by async]
  - install timezone                v0.14.0 [required by core]
  - install protocol_version_header v0.14.0 [required by async_rpc_kernel]
  - install async_kernel            v0.14.0 [required by async]
  - install core                    v0.14.1 [required by async_inotify]
  - install async_rpc_kernel        v0.14.0 [required by async]
  - install textutils               v0.14.0 [required by async]
  - install async_unix              v0.14.0 [required by async]
  - install async                   v0.14.0 [required by async_inotify]
  - install async_find              v0.14.0 [required by async_inotify]
  - install async_inotify           v0.14.0
===== 71 to install =====

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Processing  1/213:
Processing  2/213:
Processing  3/213:
-> retrieved async_find.v0.14.0  (cached)
Processing  4/213:
-> retrieved async.v0.14.0  (cached)
Processing  5/213:
-> retrieved async_inotify.v0.14.0  (cached)
Processing  6/213:
-> retrieved async_kernel.v0.14.0  (cached)
Processing  7/213:
-> retrieved async_rpc_kernel.v0.14.0  (cached)
Processing  8/213:
Processing  9/213:
-> retrieved async_unix.v0.14.0  (cached)
Processing 10/213:
-> retrieved base.v0.14.1  (cached)
Processing 11/213:
-> retrieved base_bigstring.v0.14.0  (cached)
Processing 12/213:
-> retrieved base_quickcheck.v0.14.1  (cached)
Processing 13/213:
-> retrieved bin_prot.v0.14.0  (cached)
Processing 14/213:
-> retrieved core.v0.14.1  (cached)
Processing 15/213:
-> retrieved core_kernel.v0.14.2  (cached)
Processing 16/213:
-> retrieved csexp.1.5.1  (cached)
Processing 17/213:
-> retrieved fieldslib.v0.14.0  (cached)
Processing 18/213:
-> retrieved inotify.2.3  (cached)
Processing 19/213:
-> retrieved jane-street-headers.v0.14.0  (cached)
Processing 20/213:
-> retrieved jst-config.v0.14.1  (cached)
Processing 21/213:
-> retrieved num.1.4  (cached)
Processing 22/213:
-> retrieved ocaml-compiler-libs.v0.12.4  (cached)
Processing 23/213:
-> retrieved ocamlbuild.0.14.0  (cached)
Processing 24/213:
Processing 25/213: [ocamlbuild: make configure.make]
-> retrieved dune.2.9.1  (cached)
Processing 26/213: [ocamlbuild: make configure.make]
Processing 27/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make configure.make]
-> retrieved dune-configurator.2.9.1  (cached)
Processing 28/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make configure.make]
-> retrieved ocamlfind.1.9.1  (cached)
Processing 29/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make configure.make]
Processing 30/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make configure.make] [ocamlfind: ./configure]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "make" "-f" "configure.make" "all" "OCAMLBUILD_PREFIX=/home/opam/.opam/4.13" "OCAMLBUILD_BINDIR=/home/opam/.opam/4.13/bin" "OCAMLBUILD_LIBDIR=/home/opam/.opam/4.13/lib" "OCAMLBUILD_MANDIR=/home/opam/.opam/4.13/man" "OCAML_NATIVE=true" "OCAML_NATIVE_TOOLS=true" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0)
- (echo "# This file was generated from configure.make"; \
- echo ;\
- echo "OCAML_PREFIX="; \
- echo "OCAML_BINDIR=/home/opam/.opam/4.13/bin"; \
- echo "OCAML_LIBDIR=/home/opam/.opam/4.13/lib/ocaml"; \
- echo "OCAML_MANDIR=/home/opam/.opam/4.13/man"; \
- echo ;\
- echo "EXT_OBJ=.o"; \
- echo "EXT_ASM=.s"; \
- echo "EXT_LIB=.a"; \
- echo "EXT_DLL=.so"; \
- echo "EXE="; \
- echo ;\
- echo "OCAML_NATIVE=true"; \
- echo "OCAML_NATIVE_TOOLS=true"; \
- echo "NATDYNLINK=true"; \
- echo "SUPPORT_SHARED_LIBRARIES=true"; \
- echo ;\
- echo "PREFIX=/home/opam/.opam/4.13"; \
- echo "BINDIR=/home/opam/.opam/4.13/bin"; \
- echo "LIBDIR=/home/opam/.opam/4.13/lib"; \
- echo "MANDIR=/home/opam/.opam/4.13/man"; \
- ) > Makefile.config
- (echo "(* This file was generated from ../configure.make *)"; \
- echo ;\
- echo 'let bindir = "/home/opam/.opam/4.13/bin"'; \
- echo 'let libdir = "/home/opam/.opam/4.13/lib"'; \
- echo 'let ocaml_libdir = "/home/opam/.opam/4.13/lib/ocaml"'; \
- echo 'let libdir_abs = "/home/opam/.opam/4.13/lib"'; \
- echo 'let ocaml_native = true'; \
- echo 'let ocaml_native_tools = true'; \
- echo 'let supports_shared_libraries = true';\
- echo 'let a = "a"'; \
- echo 'let o = "o"'; \
- echo 'let so = "so"'; \
- echo 'let ext_dll = ".so"'; \
- echo 'let exe = ""'; \
- echo 'let version = "0.14.0"'; \
- ) > src/ocamlbuild_config.ml
- (echo "# This file was generated from configure.make"; \
- echo ;\
- echo "OCAML_PREFIX="; \
- echo "OCAML_BINDIR=/home/opam/.opam/4.13/bin"; \
- echo "OCAML_LIBDIR=/home/opam/.opam/4.13/lib/ocaml"; \
- echo "OCAML_MANDIR=/home/opam/.opam/4.13/man"; \
- echo ;\
- echo "EXT_OBJ=.o"; \
- echo "EXT_ASM=.s"; \
- echo "EXT_LIB=.a"; \
- echo "EXT_DLL=.so"; \
- echo "EXE="; \
- echo ;\
- echo "OCAML_NATIVE=true"; \
- echo "OCAML_NATIVE_TOOLS=true"; \
- echo "NATDYNLINK=true"; \
- echo "SUPPORT_SHARED_LIBRARIES=true"; \
- echo ;\
- echo "PREFIX=/home/opam/.opam/4.13"; \
- echo "BINDIR=/home/opam/.opam/4.13/bin"; \
- echo "LIBDIR=/home/opam/.opam/4.13/lib"; \
- echo "MANDIR=/home/opam/.opam/4.13/man"; \
- ) > Makefile.config
- (echo "(* This file was generated from ../configure.make *)"; \
- echo ;\
- echo 'let bindir = "/home/opam/.opam/4.13/bin"'; \
- echo 'let libdir = "/home/opam/.opam/4.13/lib"'; \
- echo 'let ocaml_libdir = "/home/opam/.opam/4.13/lib/ocaml"'; \
- echo 'let libdir_abs = "/home/opam/.opam/4.13/lib"'; \
- echo 'let ocaml_native = true'; \
- echo 'let ocaml_native_tools = true'; \
- echo 'let supports_shared_libraries = true';\
- echo 'let a = "a"'; \
- echo 'let o = "o"'; \
- echo 'let so = "so"'; \
- echo 'let ext_dll = ".so"'; \
- echo 'let exe = ""'; \
- echo 'let version = "0.14.0"'; \
- ) > src/ocamlbuild_config.ml
Processing 30/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved octavius.1.2.2  (cached)
Processing 31/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved parsexp.v0.14.1  (cached)
Processing 32/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_assert.v0.14.0  (cached)
Processing 33/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_base.v0.14.0  (cached)
Processing 34/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_bench.v0.14.1  (cached)
Processing 35/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_bin_prot.v0.14.0  (cached)
Processing 36/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_cold.v0.14.0  (cached)
Processing 37/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_compare.v0.14.0  (cached)
Processing 38/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_custom_printf.v0.14.1  (cached)
Processing 39/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_derivers.1.2.1  (cached)
Processing 40/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_enumerate.v0.14.0  (cached)
Processing 41/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_expect.v0.14.1  (cached)
Processing 42/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_fields_conv.v0.14.2  (cached)
Processing 43/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_fixed_literal.v0.14.0  (cached)
Processing 44/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_hash.v0.14.0  (cached)
Processing 45/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_here.v0.14.0  (cached)
Processing 46/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_inline_test.v0.14.1  (cached)
Processing 47/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_jane.v0.14.0  (cached)
Processing 48/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_js_style.v0.14.1  (cached)
Processing 49/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_let.v0.14.0  (cached)
Processing 50/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_module_timer.v0.14.0  (cached)
Processing 51/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_optcomp.v0.14.3  (cached)
Processing 52/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_optional.v0.14.0  (cached)
Processing 53/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_pipebang.v0.14.0  (cached)
Processing 54/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_sexp_conv.v0.14.3  (cached)
Processing 55/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_sexp_message.v0.14.1  (cached)
Processing 56/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_sexp_value.v0.14.0  (cached)
Processing 57/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_stable.v0.14.1  (cached)
Processing 58/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_string.v0.14.1  (cached)
Processing 59/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_typerep_conv.v0.14.2  (cached)
Processing 60/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved ppx_variants_conv.v0.14.2  (cached)
Processing 61/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved protocol_version_header.v0.14.0  (cached)
Processing 62/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved result.1.5  (cached)
Processing 63/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
Processing 64/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
Processing 65/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> installed seq.base
Processing 66/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
-> retrieved re.1.10.3  (cached)
Processing 67/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: ./configure]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "./configure" "-bindir" "/home/opam/.opam/4.13/bin" "-sitelib" "/home/opam/.opam/4.13/lib" "-mandir" "/home/opam/.opam/4.13/man" "-config" "/home/opam/.opam/4.13/lib/findlib.conf" "-no-custom" "-no-camlp4" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1)
- Welcome to findlib version 1.9.1
- Configuring core...
- Checking for #remove_directory...
- Testing threading model...
- systhread_supported: true
- Testing DLLs...
- Testing whether ppxopt can be supported...
- Checking for ocamlc -opaque...
- Querying installation: META list not found
- make install will double-check installed META files
- Configuring libraries...
- unix: found
- bigarray: found
- compiler-libs: found
- dbm: not present (normal since 4.00)
- graphics: not present (normal since 4.09)
- num: not present (normal since 4.06)
- ocamlbuild: not present (normal since 4.03)
- ocamldoc: found
- raw_spacetime: not present (normal since 4.12)
- threads: found
- str: found
- labltk: not present (normal since 4.02)
- native dynlink: found
- camlp4: disabled
- bytes: found, installing fake library
- Configuration for dynlink written to site-lib-src/dynlink/META
- Configuration for stdlib written to site-lib-src/stdlib/META
- Configuration for unix written to site-lib-src/unix/META
- Configuration for bigarray written to site-lib-src/bigarray/META
- Configuration for compiler-libs written to site-lib-src/compiler-libs/META
- Configuration for ocamldoc written to site-lib-src/ocamldoc/META
- Configuration for threads written to site-lib-src/threads/META
- Configuration for str written to site-lib-src/str/META
- Configuration for bytes written to site-lib-src/bytes/META
- Detecting compiler arguments: (extractor built) ok
- 
- About the OCAML core installation:
-     Standard library:      /home/opam/.opam/4.13/lib/ocaml
-     Binaries:              /home/opam/.opam/4.13/bin
-     Manual pages:          /home/opam/.opam/4.13/man
-     Multi-threading type:  posix
- The directory of site-specific packages will be
-     site-lib:              /home/opam/.opam/4.13/lib
- The configuration file is written to:
-     findlib config file:   /home/opam/.opam/4.13/lib/findlib.conf
- Software will be installed:
-     Libraries:             in <site-lib>/findlib
-     Binaries:              /home/opam/.opam/4.13/bin
-     Manual pages:          /home/opam/.opam/4.13/man
-     topfind script:        /home/opam/.opam/4.13/lib/ocaml
- Topfind ppxopt support:    yes
- Toolbox:                   no
- Link custom runtime:       no
- Need bytes compatibility:  no
- 
- Configuration has been written to Makefile.config
- 
- You can now do 'make all', and optionally 'make opt', to build ocamlfind.
- Welcome to findlib version 1.9.1
- Configuring core...
- Checking for #remove_directory...
- Testing threading model...
- systhread_supported: true
- Testing DLLs...
- Testing whether ppxopt can be supported...
- Checking for ocamlc -opaque...
- Querying installation: META list not found
- make install will double-check installed META files
- Configuring libraries...
- unix: found
- bigarray: found
- compiler-libs: found
- dbm: not present (normal since 4.00)
- graphics: not present (normal since 4.09)
- num: not present (normal since 4.06)
- ocamlbuild: not present (normal since 4.03)
- ocamldoc: found
- raw_spacetime: not present (normal since 4.12)
- threads: found
- str: found
- labltk: not present (normal since 4.02)
- native dynlink: found
- camlp4: disabled
- bytes: found, installing fake library
- Configuration for dynlink written to site-lib-src/dynlink/META
- Configuration for stdlib written to site-lib-src/stdlib/META
- Configuration for unix written to site-lib-src/unix/META
- Configuration for bigarray written to site-lib-src/bigarray/META
- Configuration for compiler-libs written to site-lib-src/compiler-libs/META
- Configuration for ocamldoc written to site-lib-src/ocamldoc/META
- Configuration for threads written to site-lib-src/threads/META
- Configuration for str written to site-lib-src/str/META
- Configuration for bytes written to site-lib-src/bytes/META
- Detecting compiler arguments: (extractor built) ok
- 
- About the OCAML core installation:
-     Standard library:      /home/opam/.opam/4.13/lib/ocaml
-     Binaries:              /home/opam/.opam/4.13/bin
-     Manual pages:          /home/opam/.opam/4.13/man
-     Multi-threading type:  posix
- The directory of site-specific packages will be
-     site-lib:              /home/opam/.opam/4.13/lib
- The configuration file is written to:
-     findlib config file:   /home/opam/.opam/4.13/lib/findlib.conf
- Software will be installed:
-     Libraries:             in <site-lib>/findlib
-     Binaries:              /home/opam/.opam/4.13/bin
-     Manual pages:          /home/opam/.opam/4.13/man
-     topfind script:        /home/opam/.opam/4.13/lib/ocaml
- Topfind ppxopt support:    yes
- Toolbox:                   no
- Link custom runtime:       no
- Need bytes compatibility:  no
- 
- Configuration has been written to Makefile.config
- 
- You can now do 'make all', and optionally 'make opt', to build ocamlfind.
Processing 67/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: make all]
-> retrieved sexplib.v0.14.0  (cached)
Processing 68/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: make all]
-> retrieved ppxlib.0.23.0  (cached)
Processing 69/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: make all]
-> retrieved sexplib0.v0.14.0  (cached)
Processing 70/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: make all]
-> retrieved spawn.v0.14.0  (cached)
Processing 71/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: make all]
-> retrieved splittable_random.v0.14.0  (cached)
Processing 72/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: make all]
-> retrieved stdio.v0.14.0  (cached)
Processing 73/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: make all]
-> retrieved stdlib-shims.0.3.0  (cached)
Processing 74/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: make all]
-> retrieved textutils.v0.14.0  (cached)
Processing 75/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: make all]
-> retrieved time_now.v0.14.0  (cached)
Processing 76/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: make all]
-> retrieved timezone.v0.14.0  (cached)
-> retrieved typerep.v0.14.0  (cached)
-> retrieved variantslib.v0.14.0  (cached)
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "make" "all" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1)
- for p in findlib; do ( cd src/$p; make all ) || exit; done
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1/src/findlib'
- ocamllex fl_meta.mll
- 22 states, 392 transitions, table size 1700 bytes
- USE_CYGPATH="0"; \
- export USE_CYGPATH; \
- cat findlib_config.mlp | \
-          ../../tools/patch '@CONFIGFILE@' '/home/opam/.opam/4.13/lib/findlib.conf' | \
-          ../../tools/patch '@STDLIB@' '/home/opam/.opam/4.13/lib/ocaml' | \
- 	sed -e 's;@AUTOLINK@;true;g' \
- 	    -e 's;@SYSTEM@;linux;g' \
- 	     >findlib_config.ml
- if [ "true" = "true" ]; then                 \
- 	cp topfind.ml.in topfind.ml;                             \
- else                                                             \
- 	sed -e '/PPXOPT_BEGIN/,/PPXOPT_END/ d' topfind.ml.in     \
- 		> topfind.ml ;                                   \
- fi
- ocamldep *.ml *.mli >depend
- ocamlc -I +compiler-libs -opaque -g -c findlib_config.ml
- ocamlc -I +compiler-libs -opaque -g -c fl_split.ml
- ocamlc -I +compiler-libs -opaque -g -c fl_metatoken.ml
- ocamlc -I +compiler-libs -opaque -g -c fl_meta.ml
- ocamlc -I +compiler-libs -opaque -c fl_metascanner.mli
- ocamlc -I +compiler-libs -opaque -g -c fl_metascanner.ml
- ocamlc -I +compiler-libs -opaque -c fl_topo.mli
- ocamlc -I +compiler-libs -opaque -g -c fl_topo.ml
- ocamlc -I +compiler-libs -opaque -c fl_package_base.mli
- ocamlc -I +compiler-libs -opaque -g -c fl_package_base.ml
- File "fl_package_base.ml", line 304, characters 22-40:
- 304 | 	 let pkg_ancestors = query_requirements predlist pkg in
-                             ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 350, characters 18-36:
- 350 |   let ancestors = query_requirements predlist package_name in
-                         ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 375, characters 23-41:
- 375 | 	  let pkg_ancestors = query_requirements predlist pkg in
-                              ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 510, characters 16-35:
- 510 | 	     ( let c = package_definitions search_path pkg.package_name in
-                       ^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label search_path was omitted in the application of this function.
- ocamlc -I +compiler-libs -opaque -c findlib.mli
- ocamlc -I +compiler-libs -opaque -g -c findlib.ml
- File "findlib.ml", line 390, characters 2-26:
- 390 |   Fl_package_base.requires predlist pkg
-         ^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "findlib.ml", line 396, characters 2-33:
- 396 |   Fl_package_base.requires_deeply predlist pkglist
-         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- ocamlc -I +compiler-libs -opaque -g -c fl_args.ml
- ocamlc -I +compiler-libs -opaque -g -c fl_lint.ml
- ocamlc -I +compiler-libs -a -o findlib.cma findlib_config.cmo fl_split.cmo fl_metatoken.cmo fl_meta.cmo fl_metascanner.cmo fl_topo.cmo fl_package_base.cmo findlib.cmo fl_args.cmo fl_lint.cmo
- ocamlc -I +compiler-libs -opaque -g -c ocaml_args.ml
- ocamlc -I +compiler-libs -opaque -g -c frontend.ml
- File "frontend.ml", line 859, characters 10-39:
- 859 |           Fl_package_base.package_users predicates1 packages1
-                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "frontend.ml", line 1826, characters 16-29:
- 1826 |       let buf = String.create buflen in   (* FIXME: Bytes.create *)
-                        ^^^^^^^^^^^^^
- Alert deprecated: Stdlib.String.create
- Use Bytes.create/BytesLabels.create instead.
- ocamlc -I +compiler-libs  -o ocamlfind -g findlib.cma unix.cma \
-            ocaml_args.cmo frontend.cmo
- ocamlc -I +compiler-libs -opaque -c topfind.mli
- ocamlc -I +compiler-libs -opaque -g -c topfind.ml
- File "topfind.ml", line 126, characters 40-63:
- 126 |                      match Hashtbl.find Toploop.directive_table "ppx" with
-                                               ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 252, characters 4-27:
- 252 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 262, characters 4-27:
- 262 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 274, characters 4-27:
- 274 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 287, characters 4-27:
- 287 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 301, characters 4-27:
- 301 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 313, characters 4-27:
- 313 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- ocamlc -I +compiler-libs -a -o findlib_top.cma topfind.cmo
- USE_CYGPATH="0"; \
- export USE_CYGPATH; \
- cat topfind_rd1.p | \
-          ../../tools/patch '@SITELIB@' '/home/opam/.opam/4.13/lib' \
-     	    >topfind
- ocamlc -I +compiler-libs -opaque -c fl_dynload.mli
- ocamlc -I +compiler-libs -opaque -g -c fl_dynload.ml
- ocamlc -I +compiler-libs -a -o findlib_dynload.cma fl_dynload.cmo
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1/src/findlib'
- make all-config
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1'
- USE_CYGPATH="0"; \
- export USE_CYGPATH; \
- cat findlib.conf.in | \
-      tools/patch '@SITELIB@' '/home/opam/.opam/4.13/lib' >findlib.conf
- if ./tools/cmd_from_same_dir ocamlc; then \
- 	echo 'ocamlc="ocamlc.opt"' >>findlib.conf; \
- fi
- if ./tools/cmd_from_same_dir ocamlopt; then \
- 	echo 'ocamlopt="ocamlopt.opt"' >>findlib.conf; \
- fi
- if ./tools/cmd_from_same_dir ocamldep; then \
- 	echo 'ocamldep="ocamldep.opt"' >>findlib.conf; \
- fi
- if ./tools/cmd_from_same_dir ocamldoc; then \
- 	echo 'ocamldoc="ocamldoc.opt"' >>findlib.conf; \
- fi
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1'
- for p in findlib; do ( cd src/$p; make all ) || exit; done
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1/src/findlib'
- ocamllex fl_meta.mll
- 22 states, 392 transitions, table size 1700 bytes
- USE_CYGPATH="0"; \
- export USE_CYGPATH; \
- cat findlib_config.mlp | \
-          ../../tools/patch '@CONFIGFILE@' '/home/opam/.opam/4.13/lib/findlib.conf' | \
-          ../../tools/patch '@STDLIB@' '/home/opam/.opam/4.13/lib/ocaml' | \
- 	sed -e 's;@AUTOLINK@;true;g' \
- 	    -e 's;@SYSTEM@;linux;g' \
- 	     >findlib_config.ml
- if [ "true" = "true" ]; then                 \
- 	cp topfind.ml.in topfind.ml;                             \
- else                                                             \
- 	sed -e '/PPXOPT_BEGIN/,/PPXOPT_END/ d' topfind.ml.in     \
- 		> topfind.ml ;                                   \
- fi
- ocamldep *.ml *.mli >depend
- ocamlc -I +compiler-libs -opaque -g -c findlib_config.ml
- ocamlc -I +compiler-libs -opaque -g -c fl_split.ml
- ocamlc -I +compiler-libs -opaque -g -c fl_metatoken.ml
- ocamlc -I +compiler-libs -opaque -g -c fl_meta.ml
- ocamlc -I +compiler-libs -opaque -c fl_metascanner.mli
- ocamlc -I +compiler-libs -opaque -g -c fl_metascanner.ml
- ocamlc -I +compiler-libs -opaque -c fl_topo.mli
- ocamlc -I +compiler-libs -opaque -g -c fl_topo.ml
- ocamlc -I +compiler-libs -opaque -c fl_package_base.mli
- ocamlc -I +compiler-libs -opaque -g -c fl_package_base.ml
- File "fl_package_base.ml", line 304, characters 22-40:
- 304 | 	 let pkg_ancestors = query_requirements predlist pkg in
-                             ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 350, characters 18-36:
- 350 |   let ancestors = query_requirements predlist package_name in
-                         ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 375, characters 23-41:
- 375 | 	  let pkg_ancestors = query_requirements predlist pkg in
-                              ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 510, characters 16-35:
- 510 | 	     ( let c = package_definitions search_path pkg.package_name in
-                       ^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label search_path was omitted in the application of this function.
- ocamlc -I +compiler-libs -opaque -c findlib.mli
- ocamlc -I +compiler-libs -opaque -g -c findlib.ml
- File "findlib.ml", line 390, characters 2-26:
- 390 |   Fl_package_base.requires predlist pkg
-         ^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "findlib.ml", line 396, characters 2-33:
- 396 |   Fl_package_base.requires_deeply predlist pkglist
-         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- ocamlc -I +compiler-libs -opaque -g -c fl_args.ml
- ocamlc -I +compiler-libs -opaque -g -c fl_lint.ml
- ocamlc -I +compiler-libs -a -o findlib.cma findlib_config.cmo fl_split.cmo fl_metatoken.cmo fl_meta.cmo fl_metascanner.cmo fl_topo.cmo fl_package_base.cmo findlib.cmo fl_args.cmo fl_lint.cmo
- ocamlc -I +compiler-libs -opaque -g -c ocaml_args.ml
- ocamlc -I +compiler-libs -opaque -g -c frontend.ml
- File "frontend.ml", line 859, characters 10-39:
- 859 |           Fl_package_base.package_users predicates1 packages1
-                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "frontend.ml", line 1826, characters 16-29:
- 1826 |       let buf = String.create buflen in   (* FIXME: Bytes.create *)
-                        ^^^^^^^^^^^^^
- Alert deprecated: Stdlib.String.create
- Use Bytes.create/BytesLabels.create instead.
- ocamlc -I +compiler-libs  -o ocamlfind -g findlib.cma unix.cma \
-            ocaml_args.cmo frontend.cmo
- ocamlc -I +compiler-libs -opaque -c topfind.mli
- ocamlc -I +compiler-libs -opaque -g -c topfind.ml
- File "topfind.ml", line 126, characters 40-63:
- 126 |                      match Hashtbl.find Toploop.directive_table "ppx" with
-                                               ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 252, characters 4-27:
- 252 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 262, characters 4-27:
- 262 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 274, characters 4-27:
- 274 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 287, characters 4-27:
- 287 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 301, characters 4-27:
- 301 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 313, characters 4-27:
- 313 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- ocamlc -I +compiler-libs -a -o findlib_top.cma topfind.cmo
- USE_CYGPATH="0"; \
- export USE_CYGPATH; \
- cat topfind_rd1.p | \
-          ../../tools/patch '@SITELIB@' '/home/opam/.opam/4.13/lib' \
-     	    >topfind
- ocamlc -I +compiler-libs -opaque -c fl_dynload.mli
- ocamlc -I +compiler-libs -opaque -g -c fl_dynload.ml
- ocamlc -I +compiler-libs -a -o findlib_dynload.cma fl_dynload.cmo
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1/src/findlib'
- make all-config
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1'
- USE_CYGPATH="0"; \
- export USE_CYGPATH; \
- cat findlib.conf.in | \
-      tools/patch '@SITELIB@' '/home/opam/.opam/4.13/lib' >findlib.conf
- if ./tools/cmd_from_same_dir ocamlc; then \
- 	echo 'ocamlc="ocamlc.opt"' >>findlib.conf; \
- fi
- if ./tools/cmd_from_same_dir ocamlopt; then \
- 	echo 'ocamlopt="ocamlopt.opt"' >>findlib.conf; \
- fi
- if ./tools/cmd_from_same_dir ocamldep; then \
- 	echo 'ocamldep="ocamldep.opt"' >>findlib.conf; \
- fi
- if ./tools/cmd_from_same_dir ocamldoc; then \
- 	echo 'ocamldoc="ocamldoc.opt"' >>findlib.conf; \
- fi
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1'
Processing 76/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: make opt]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "make" "opt" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1)
- for p in findlib; do ( cd src/$p; make opt ) || exit; done
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1/src/findlib'
- ocamlopt -I +compiler-libs -g -opaque -c findlib_config.ml
- ocamlopt -I +compiler-libs -g -opaque -c fl_split.ml
- ocamlopt -I +compiler-libs -g -opaque -c fl_metatoken.ml
- ocamlopt -I +compiler-libs -g -opaque -c fl_meta.ml
- ocamlopt -I +compiler-libs -g -opaque -c fl_metascanner.ml
- ocamlopt -I +compiler-libs -g -opaque -c fl_topo.ml
- ocamlopt -I +compiler-libs -g -opaque -c fl_package_base.ml
- File "fl_package_base.ml", line 304, characters 22-40:
- 304 | 	 let pkg_ancestors = query_requirements predlist pkg in
-                             ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 350, characters 18-36:
- 350 |   let ancestors = query_requirements predlist package_name in
-                         ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 375, characters 23-41:
- 375 | 	  let pkg_ancestors = query_requirements predlist pkg in
-                              ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 510, characters 16-35:
- 510 | 	     ( let c = package_definitions search_path pkg.package_name in
-                       ^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label search_path was omitted in the application of this function.
- ocamlopt -I +compiler-libs -g -opaque -c findlib.ml
- File "findlib.ml", line 390, characters 2-26:
- 390 |   Fl_package_base.requires predlist pkg
-         ^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "findlib.ml", line 396, characters 2-33:
- 396 |   Fl_package_base.requires_deeply predlist pkglist
-         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- ocamlopt -I +compiler-libs -g -opaque -c fl_args.ml
- ocamlopt -I +compiler-libs -g -opaque -c fl_lint.ml
- ocamlopt -I +compiler-libs -g -a -o findlib.cmxa findlib_config.cmx fl_split.cmx fl_metatoken.cmx fl_meta.cmx fl_metascanner.cmx fl_topo.cmx fl_package_base.cmx findlib.cmx fl_args.cmx fl_lint.cmx
- if [ 1 -gt 0 ]; then \
-     ocamlopt -I +compiler-libs -g -shared -o findlib.cmxs findlib_config.cmx fl_split.cmx fl_metatoken.cmx fl_meta.cmx fl_metascanner.cmx fl_topo.cmx fl_package_base.cmx findlib.cmx fl_args.cmx fl_lint.cmx; \
- fi
- ocamlopt -I +compiler-libs -g -opaque -c ocaml_args.ml
- ocamlopt -I +compiler-libs -g -opaque -c frontend.ml
- File "frontend.ml", line 859, characters 10-39:
- 859 |           Fl_package_base.package_users predicates1 packages1
-                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "frontend.ml", line 1826, characters 16-29:
- 1826 |       let buf = String.create buflen in   (* FIXME: Bytes.create *)
-                        ^^^^^^^^^^^^^
- Alert deprecated: Stdlib.String.create
- Use Bytes.create/BytesLabels.create instead.
- ocamlopt -I +compiler-libs -g -o ocamlfind_opt findlib.cmxa unix.cmxa \
- 	   ocaml_args.cmx frontend.cmx
- ocamlopt -I +compiler-libs -g -opaque -c topfind.ml
- File "topfind.ml", line 126, characters 40-63:
- 126 |                      match Hashtbl.find Toploop.directive_table "ppx" with
-                                               ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 252, characters 4-27:
- 252 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 262, characters 4-27:
- 262 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 274, characters 4-27:
- 274 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 287, characters 4-27:
- 287 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 301, characters 4-27:
- 301 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 313, characters 4-27:
- 313 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "_none_", line 1:
- Warning 58 [no-cmx-file]: no cmx file was found in path for module Topdirs, and its interface was not compiled with -opaque
- File "_none_", line 1:
- Warning 58 [no-cmx-file]: no cmx file was found in path for module Toploop, and its interface was not compiled with -opaque
- ocamlopt -I +compiler-libs -g -a -o findlib_top.cmxa topfind.cmx
- if [ 1 -gt 0 ]; then \
-     ocamlopt -I +compiler-libs -g -shared -o findlib_top.cmxs topfind.cmx; \
- fi
- ocamlopt -I +compiler-libs -g -opaque -c fl_dynload.ml
- ocamlopt -I +compiler-libs -g -a -o findlib_dynload.cmxa fl_dynload.cmx
- if [ 1 -gt 0 ]; then \
-     ocamlopt -I +compiler-libs -g -shared -o findlib_dynload.cmxs fl_dynload.cmx; \
- fi
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1/src/findlib'
- for p in findlib; do ( cd src/$p; make opt ) || exit; done
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1/src/findlib'
- ocamlopt -I +compiler-libs -g -opaque -c findlib_config.ml
- ocamlopt -I +compiler-libs -g -opaque -c fl_split.ml
- ocamlopt -I +compiler-libs -g -opaque -c fl_metatoken.ml
- ocamlopt -I +compiler-libs -g -opaque -c fl_meta.ml
- ocamlopt -I +compiler-libs -g -opaque -c fl_metascanner.ml
- ocamlopt -I +compiler-libs -g -opaque -c fl_topo.ml
- ocamlopt -I +compiler-libs -g -opaque -c fl_package_base.ml
- File "fl_package_base.ml", line 304, characters 22-40:
- 304 | 	 let pkg_ancestors = query_requirements predlist pkg in
-                             ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 350, characters 18-36:
- 350 |   let ancestors = query_requirements predlist package_name in
-                         ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 375, characters 23-41:
- 375 | 	  let pkg_ancestors = query_requirements predlist pkg in
-                              ^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "fl_package_base.ml", line 510, characters 16-35:
- 510 | 	     ( let c = package_definitions search_path pkg.package_name in
-                       ^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label search_path was omitted in the application of this function.
- ocamlopt -I +compiler-libs -g -opaque -c findlib.ml
- File "findlib.ml", line 390, characters 2-26:
- 390 |   Fl_package_base.requires predlist pkg
-         ^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "findlib.ml", line 396, characters 2-33:
- 396 |   Fl_package_base.requires_deeply predlist pkglist
-         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- ocamlopt -I +compiler-libs -g -opaque -c fl_args.ml
- ocamlopt -I +compiler-libs -g -opaque -c fl_lint.ml
- ocamlopt -I +compiler-libs -g -a -o findlib.cmxa findlib_config.cmx fl_split.cmx fl_metatoken.cmx fl_meta.cmx fl_metascanner.cmx fl_topo.cmx fl_package_base.cmx findlib.cmx fl_args.cmx fl_lint.cmx
- if [ 1 -gt 0 ]; then \
-     ocamlopt -I +compiler-libs -g -shared -o findlib.cmxs findlib_config.cmx fl_split.cmx fl_metatoken.cmx fl_meta.cmx fl_metascanner.cmx fl_topo.cmx fl_package_base.cmx findlib.cmx fl_args.cmx fl_lint.cmx; \
- fi
- ocamlopt -I +compiler-libs -g -opaque -c ocaml_args.ml
- ocamlopt -I +compiler-libs -g -opaque -c frontend.ml
- File "frontend.ml", line 859, characters 10-39:
- 859 |           Fl_package_base.package_users predicates1 packages1
-                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Warning 6 [labels-omitted]: label preds was omitted in the application of this function.
- File "frontend.ml", line 1826, characters 16-29:
- 1826 |       let buf = String.create buflen in   (* FIXME: Bytes.create *)
-                        ^^^^^^^^^^^^^
- Alert deprecated: Stdlib.String.create
- Use Bytes.create/BytesLabels.create instead.
- ocamlopt -I +compiler-libs -g -o ocamlfind_opt findlib.cmxa unix.cmxa \
- 	   ocaml_args.cmx frontend.cmx
- ocamlopt -I +compiler-libs -g -opaque -c topfind.ml
- File "topfind.ml", line 126, characters 40-63:
- 126 |                      match Hashtbl.find Toploop.directive_table "ppx" with
-                                               ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 252, characters 4-27:
- 252 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 262, characters 4-27:
- 262 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 274, characters 4-27:
- 274 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 287, characters 4-27:
- 287 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 301, characters 4-27:
- 301 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "topfind.ml", line 313, characters 4-27:
- 313 |     Toploop.directive_table
-           ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "_none_", line 1:
- Warning 58 [no-cmx-file]: no cmx file was found in path for module Topdirs, and its interface was not compiled with -opaque
- File "_none_", line 1:
- Warning 58 [no-cmx-file]: no cmx file was found in path for module Toploop, and its interface was not compiled with -opaque
- ocamlopt -I +compiler-libs -g -a -o findlib_top.cmxa topfind.cmx
- if [ 1 -gt 0 ]; then \
-     ocamlopt -I +compiler-libs -g -shared -o findlib_top.cmxs topfind.cmx; \
- fi
- ocamlopt -I +compiler-libs -g -opaque -c fl_dynload.ml
- ocamlopt -I +compiler-libs -g -a -o findlib_dynload.cmxa fl_dynload.cmx
- if [ 1 -gt 0 ]; then \
-     ocamlopt -I +compiler-libs -g -shared -o findlib_dynload.cmxs fl_dynload.cmx; \
- fi
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1/src/findlib'
-> compiled  ocamlfind.1.9.1
Processing 76/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled]
Processing 77/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [ocamlfind: make install]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "install" "make" "install" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1)
- if [ "1" -eq 1 ]; then \
-     for x in camlp4 dbm graphics labltk num ocamlbuild; do \
-       if [ -f "/home/opam/.opam/4.13/lib/$x/META" ]; then \
-         if ! grep -Fq '[distributed with Ocaml]' "//home/opam/.opam/4.13/lib/$x/META"; then \
-           rm -f site-lib-src/$x/META; \
-         fi \
-       fi \
-     done; \
-     test -f "site-lib-src/num/META" || rm -f "site-lib-src/num-top/META"; \
-   fi
- echo 'SITELIB_META =' > Makefile.packages.in
- for x in `ls site-lib-src`; do test ! -f "site-lib-src/$x/META" || echo $x >> Makefile.packages.in; done
- tr '\n' ' ' < Makefile.packages.in > Makefile.packages
- rm Makefile.packages.in
- mkdir -p "/home/opam/.opam/4.13/bin"
- mkdir -p "/home/opam/.opam/4.13/man"
- make install-config
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1'
- mkdir -p "`dirname \"/home/opam/.opam/4.13/lib/findlib.conf\"`"
- test -f "/home/opam/.opam/4.13/lib/findlib.conf" || cp findlib.conf "/home/opam/.opam/4.13/lib/findlib.conf"
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1'
- for p in findlib; do ( cd src/$p; make install ); done
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1/src/findlib'
- mkdir -p "/home/opam/.opam/4.13/lib/findlib"
- mkdir -p "/home/opam/.opam/4.13/bin"
- test 1 -eq 0 || cp topfind "/home/opam/.opam/4.13/lib/ocaml"
- files=` ../../tools/collect_files ../../Makefile.config findlib.cmi findlib.mli findlib.cma findlib.cmxa findlib.a findlib.cmxs topfind.cmi topfind.mli fl_package_base.mli fl_package_base.cmi fl_metascanner.mli fl_metascanner.cmi fl_metatoken.cmi findlib_top.cma findlib_top.cmxa findlib_top.a findlib_top.cmxs findlib_dynload.cma findlib_dynload.cmxa findlib_dynload.a findlib_dynload.cmxs fl_dynload.mli fl_dynload.cmi META` && \
- cp $files "/home/opam/.opam/4.13/lib/findlib"
- f="ocamlfind"; { test -f ocamlfind_opt && f="ocamlfind_opt"; }; \
- cp $f "/home/opam/.opam/4.13/bin/ocamlfind"
- # the following "if" block is only needed for 4.00beta2
- if [ 1 -eq 0 -a -f "/home/opam/.opam/4.13/lib/ocaml/compiler-libs/topdirs.cmi" ]; then \
-     cd "/home/opam/.opam/4.13/lib/ocaml/compiler-libs/"; \
-     cp topdirs.cmi toploop.cmi "/home/opam/.opam/4.13/lib/findlib/"; \
- fi
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1/src/findlib'
- make install-meta
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1'
- for x in bigarray bytes compiler-libs dynlink ocamldoc stdlib str threads unix ; do mkdir -p "/home/opam/.opam/4.13/lib/$x"; cp site-lib-src/$x/META "/home/opam/.opam/4.13/lib/$x"; done
- mkdir -p "/home/opam/.opam/4.13/lib/findlib"; cp Makefile.packages "/home/opam/.opam/4.13/lib/findlib/Makefile.packages"
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1'
- test ! -f 'site-lib-src/num-top/META' || { cd src/findlib; make install-num-top; }
- test ! -f 'site-lib-src/camlp4/META' ||	cp tools/safe_camlp4 "/home/opam/.opam/4.13/bin"
- make install-doc
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1'
- mkdir -p "/home/opam/.opam/4.13/man/man1" "/home/opam/.opam/4.13/man/man3" "/home/opam/.opam/4.13/man/man5"
- cp doc/ref-man/ocamlfind.1 "/home/opam/.opam/4.13/man/man1"
- cp doc/ref-man/META.5 doc/ref-man/site-lib.5 doc/ref-man/findlib.conf.5 "/home/opam/.opam/4.13/man/man5"
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1'
- if [ "1" -eq 1 ]; then \
-     for x in camlp4 dbm graphics labltk num ocamlbuild; do \
-       if [ -f "/home/opam/.opam/4.13/lib/$x/META" ]; then \
-         if ! grep -Fq '[distributed with Ocaml]' "//home/opam/.opam/4.13/lib/$x/META"; then \
-           rm -f site-lib-src/$x/META; \
-         fi \
-       fi \
-     done; \
-     test -f "site-lib-src/num/META" || rm -f "site-lib-src/num-top/META"; \
-   fi
- echo 'SITELIB_META =' > Makefile.packages.in
- for x in `ls site-lib-src`; do test ! -f "site-lib-src/$x/META" || echo $x >> Makefile.packages.in; done
- tr '\n' ' ' < Makefile.packages.in > Makefile.packages
- rm Makefile.packages.in
- mkdir -p "/home/opam/.opam/4.13/bin"
- mkdir -p "/home/opam/.opam/4.13/man"
- make install-config
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1'
- mkdir -p "`dirname \"/home/opam/.opam/4.13/lib/findlib.conf\"`"
- test -f "/home/opam/.opam/4.13/lib/findlib.conf" || cp findlib.conf "/home/opam/.opam/4.13/lib/findlib.conf"
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1'
- for p in findlib; do ( cd src/$p; make install ); done
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1/src/findlib'
- mkdir -p "/home/opam/.opam/4.13/lib/findlib"
- mkdir -p "/home/opam/.opam/4.13/bin"
- test 1 -eq 0 || cp topfind "/home/opam/.opam/4.13/lib/ocaml"
- files=` ../../tools/collect_files ../../Makefile.config findlib.cmi findlib.mli findlib.cma findlib.cmxa findlib.a findlib.cmxs topfind.cmi topfind.mli fl_package_base.mli fl_package_base.cmi fl_metascanner.mli fl_metascanner.cmi fl_metatoken.cmi findlib_top.cma findlib_top.cmxa findlib_top.a findlib_top.cmxs findlib_dynload.cma findlib_dynload.cmxa findlib_dynload.a findlib_dynload.cmxs fl_dynload.mli fl_dynload.cmi META` && \
- cp $files "/home/opam/.opam/4.13/lib/findlib"
- f="ocamlfind"; { test -f ocamlfind_opt && f="ocamlfind_opt"; }; \
- cp $f "/home/opam/.opam/4.13/bin/ocamlfind"
- # the following "if" block is only needed for 4.00beta2
- if [ 1 -eq 0 -a -f "/home/opam/.opam/4.13/lib/ocaml/compiler-libs/topdirs.cmi" ]; then \
-     cd "/home/opam/.opam/4.13/lib/ocaml/compiler-libs/"; \
-     cp topdirs.cmi toploop.cmi "/home/opam/.opam/4.13/lib/findlib/"; \
- fi
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1/src/findlib'
- make install-meta
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1'
- for x in bigarray bytes compiler-libs dynlink ocamldoc stdlib str threads unix ; do mkdir -p "/home/opam/.opam/4.13/lib/$x"; cp site-lib-src/$x/META "/home/opam/.opam/4.13/lib/$x"; done
- mkdir -p "/home/opam/.opam/4.13/lib/findlib"; cp Makefile.packages "/home/opam/.opam/4.13/lib/findlib/Makefile.packages"
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1'
- test ! -f 'site-lib-src/num-top/META' || { cd src/findlib; make install-num-top; }
- test ! -f 'site-lib-src/camlp4/META' ||	cp tools/safe_camlp4 "/home/opam/.opam/4.13/bin"
- make install-doc
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1'
- mkdir -p "/home/opam/.opam/4.13/man/man1" "/home/opam/.opam/4.13/man/man3" "/home/opam/.opam/4.13/man/man5"
- cp doc/ref-man/ocamlfind.1 "/home/opam/.opam/4.13/man/man1"
- cp doc/ref-man/META.5 doc/ref-man/site-lib.5 doc/ref-man/findlib.conf.5 "/home/opam/.opam/4.13/man/man5"
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlfind.1.9.1'
-> installed ocamlfind.1.9.1
Processing 77/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled]
Processing 78/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled]
Processing 79/213: [dune: ocaml bootstrap.ml] [num: make] [ocamlbuild: make check-if-preinstalled]
-> installed base-bytes.base
Processing 80/213: [dune: ocaml bootstrap.ml] [num: make] [ocamlbuild: make check-if-preinstalled]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "make" (CWD=/home/opam/.opam/4.13/.opam-switch/build/num.1.4)
- make -C src all
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/num.1.4/src'
- ocamlc -ccopt -DBNG_ARCH_amd64 -c bng.c
- ocamlc -ccopt -DBNG_ARCH_amd64 -c nat_stubs.c
- ocamlmklib -oc nums bng.o nat_stubs.o
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c int_misc.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c int_misc.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c nat.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c nat.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c big_int.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c big_int.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_flags.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_flags.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c ratio.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c ratio.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c num.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c num.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_status.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_status.ml
- ocamlmklib -o nums -oc nums -linkall int_misc.cmo nat.cmo big_int.cmo arith_flags.cmo ratio.cmo num.cmo arith_status.cmo
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c int_misc.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c nat.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c big_int.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_flags.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c ratio.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c num.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_status.ml
- ocamlmklib -o nums -oc nums -linkall int_misc.cmx nat.cmx big_int.cmx arith_flags.cmx ratio.cmx num.cmx arith_status.cmx
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -I . -shared -o nums.cmxs nums.cmxa
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/num.1.4/src'
- make -C toplevel all
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/num.1.4/toplevel'
- ocamlc -I ../src -I +compiler-libs -w +a-4-9-41-42-44-45-48 -warn-error A -safe-string -strict-sequence -strict-formats -c num_top_printers.mli
- ocamlc -I ../src -I +compiler-libs -w +a-4-9-41-42-44-45-48 -warn-error A -safe-string -strict-sequence -strict-formats -c num_top_printers.ml
- ocamlc -I ../src -I +compiler-libs -w +a-4-9-41-42-44-45-48 -warn-error A -safe-string -strict-sequence -strict-formats -c num_top.mli
- ocamlc -I ../src -I +compiler-libs -w +a-4-9-41-42-44-45-48 -warn-error A -safe-string -strict-sequence -strict-formats -c num_top.ml
- ocamlc -I ../src -I +compiler-libs -w +a-4-9-41-42-44-45-48 -warn-error A -safe-string -strict-sequence -strict-formats -a -o num_top.cma num_top_printers.cmo num_top.cmo
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/num.1.4/toplevel'
- make -C src all
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/num.1.4/src'
- ocamlc -ccopt -DBNG_ARCH_amd64 -c bng.c
- ocamlc -ccopt -DBNG_ARCH_amd64 -c nat_stubs.c
- ocamlmklib -oc nums bng.o nat_stubs.o
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c int_misc.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c int_misc.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c nat.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c nat.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c big_int.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c big_int.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_flags.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_flags.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c ratio.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c ratio.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c num.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c num.ml
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_status.mli
- ocamlc -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_status.ml
- ocamlmklib -o nums -oc nums -linkall int_misc.cmo nat.cmo big_int.cmo arith_flags.cmo ratio.cmo num.cmo arith_status.cmo
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c int_misc.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c nat.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c big_int.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_flags.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c ratio.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c num.ml
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -c arith_status.ml
- ocamlmklib -o nums -oc nums -linkall int_misc.cmx nat.cmx big_int.cmx arith_flags.cmx ratio.cmx num.cmx arith_status.cmx
- ocamlopt -w +a-4-9-41-42-44-45-48 -warn-error A -bin-annot -g -safe-string -strict-sequence -strict-formats -I . -shared -o nums.cmxs nums.cmxa
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/num.1.4/src'
- make -C toplevel all
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/num.1.4/toplevel'
- ocamlc -I ../src -I +compiler-libs -w +a-4-9-41-42-44-45-48 -warn-error A -safe-string -strict-sequence -strict-formats -c num_top_printers.mli
- ocamlc -I ../src -I +compiler-libs -w +a-4-9-41-42-44-45-48 -warn-error A -safe-string -strict-sequence -strict-formats -c num_top_printers.ml
- ocamlc -I ../src -I +compiler-libs -w +a-4-9-41-42-44-45-48 -warn-error A -safe-string -strict-sequence -strict-formats -c num_top.mli
- ocamlc -I ../src -I +compiler-libs -w +a-4-9-41-42-44-45-48 -warn-error A -safe-string -strict-sequence -strict-formats -c num_top.ml
- ocamlc -I ../src -I +compiler-libs -w +a-4-9-41-42-44-45-48 -warn-error A -safe-string -strict-sequence -strict-formats -a -o num_top.cma num_top_printers.cmo num_top.cmo
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/num.1.4/toplevel'
-> compiled  num.1.4
Processing 80/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled]
Processing 81/213: [dune: ocaml bootstrap.ml] [ocamlbuild: make check-if-preinstalled] [num: make install]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "make" "check-if-preinstalled" "all" "opam-install" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0)
- if test -d /home/opam/.opam/4.13/lib/ocaml/ocamlbuild; then\
-   >&2 echo "ERROR: Preinstalled ocamlbuild detected at"\
-        "/home/opam/.opam/4.13/lib/ocaml/ocamlbuild";\
-   >&2 echo "Installation aborted; if you want to bypass this"\
-         "safety check, pass CHECK_IF_PREINSTALLED=false to make";\
-   exit 2;\
- fi
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/const.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/loc.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/loc.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/discard_printf.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/discard_printf.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/signatures.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_std.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_std.ml
- File "src/my_std.ml", line 127, characters 20-38:
- 127 |       let compare = Pervasives.compare
-                           ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_unix.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_unix.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tags.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tags.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/display.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/display.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/log.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/log.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/shell.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/shell.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/bool.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/bool.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_ast.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_ast.ml
- ocamllex.opt src/glob_lexer.mll
- 55 states, 419 transitions, table size 2006 bytes
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_lexer.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_lexer.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob.ml
- ocamllex.opt src/lexers.mll
- 251 states, 1051 transitions, table size 5710 bytes
- 4334 additional bytes used for bindings
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/lexers.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/lexers.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/param_tags.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/param_tags.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/command.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/command.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_config.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_where.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_where.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/slurp.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/slurp.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/options.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/options.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/pathname.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/pathname.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/configuration.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/configuration.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/flags.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/flags.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hygiene.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hygiene.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/digest_cache.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/digest_cache.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/resource.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/resource.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/rule.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/rule.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/solver.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/solver.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/report.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/report.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tools.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tools.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/fda.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/fda.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/findlib.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/findlib.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_arch.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_arch.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_utils.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_utils.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_dependencies.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_dependencies.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_compiler.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_compiler.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_tools.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_tools.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_specific.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_specific.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/exit_codes.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/exit_codes.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/plugin.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/plugin.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hooks.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hooks.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/main.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/main.ml
- File "src/main.ml", line 289, characters 4-19:
- 289 |     Pervasives.exit rc
-           ^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "src/main.ml", line 310, characters 10-25:
- 310 |           Pervasives.exit rc_ok
-                 ^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "src/main.ml", line 313, characters 10-25:
- 313 |           Pervasives.exit rc
-                 ^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- mkdir -p tmp
- ocamlc.opt -pack src/const.cmo src/loc.cmo src/discard_printf.cmo src/signatures.cmi src/my_std.cmo src/my_unix.cmo src/tags.cmo src/display.cmo src/log.cmo src/shell.cmo src/bool.cmo src/glob_ast.cmo src/glob_lexer.cmo src/glob.cmo src/lexers.cmo src/param_tags.cmo src/command.cmo src/ocamlbuild_config.cmo src/ocamlbuild_where.cmo src/slurp.cmo src/options.cmo src/pathname.cmo src/configuration.cmo src/flags.cmo src/hygiene.cmo src/digest_cache.cmo src/resource.cmo src/rule.cmo src/solver.cmo src/report.cmo src/tools.cmo src/fda.cmo src/findlib.cmo src/ocaml_arch.cmo src/ocaml_utils.cmo src/ocaml_dependencies.cmo src/ocaml_compiler.cmo src/ocaml_tools.cmo src/ocaml_specific.cmo src/exit_codes.cmo src/plugin.cmo src/hooks.cmo src/main.cmo -o tmp/ocamlbuild_pack.cmo
- mv tmp/ocamlbuild_pack.cmi src/ocamlbuild_pack.cmi
- mv tmp/ocamlbuild_pack.cmo src/ocamlbuild_pack.cmo
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_plugin.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_plugin.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_executor.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_executor.ml
- File "src/ocamlbuild_executor.ml", line 86, characters 24-41:
- 86 |   ?(display=(fun f -> f Pervasives.stdout))
-                              ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_unix_plugin.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_unix_plugin.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild.ml
- ocamlc.opt -I +unix -I src -o ocamlbuild.byte unix.cma src/ocamlbuild_pack.cmo src/ocamlbuild_plugin.cmo src/ocamlbuild_executor.cmo src/ocamlbuild_unix_plugin.cmo src/ocamlbuild.cmo
- ocamlc.opt -a -o src/ocamlbuildlib.cma src/ocamlbuild_pack.cmo src/ocamlbuild_plugin.cmo src/ocamlbuild_executor.cmo src/ocamlbuild_unix_plugin.cmo
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/const.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/loc.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/discard_printf.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_std.ml
- File "src/my_std.ml", line 127, characters 20-38:
- 127 |       let compare = Pervasives.compare
-                           ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_unix.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tags.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/display.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/log.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/shell.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/bool.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_ast.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_lexer.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/lexers.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/param_tags.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/command.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_config.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_where.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/slurp.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/options.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/pathname.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/configuration.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/flags.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hygiene.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/digest_cache.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/resource.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/rule.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/solver.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/report.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tools.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/fda.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/findlib.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_arch.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_utils.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_dependencies.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_compiler.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_tools.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_specific.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/exit_codes.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/plugin.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hooks.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/main.ml
- File "src/main.ml", line 289, characters 4-19:
- 289 |     Pervasives.exit rc
-           ^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "src/main.ml", line 310, characters 10-25:
- 310 |           Pervasives.exit rc_ok
-                 ^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "src/main.ml", line 313, characters 10-25:
- 313 |           Pervasives.exit rc
-                 ^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- mkdir -p tmp
- ocamlopt.opt -pack src/const.cmx src/loc.cmx src/discard_printf.cmx src/signatures.cmi src/my_std.cmx src/my_unix.cmx src/tags.cmx src/display.cmx src/log.cmx src/shell.cmx src/bool.cmx src/glob_ast.cmx src/glob_lexer.cmx src/glob.cmx src/lexers.cmx src/param_tags.cmx src/command.cmx src/ocamlbuild_config.cmx src/ocamlbuild_where.cmx src/slurp.cmx src/options.cmx src/pathname.cmx src/configuration.cmx src/flags.cmx src/hygiene.cmx src/digest_cache.cmx src/resource.cmx src/rule.cmx src/solver.cmx src/report.cmx src/tools.cmx src/fda.cmx src/findlib.cmx src/ocaml_arch.cmx src/ocaml_utils.cmx src/ocaml_dependencies.cmx src/ocaml_compiler.cmx src/ocaml_tools.cmx src/ocaml_specific.cmx src/exit_codes.cmx src/plugin.cmx src/hooks.cmx src/main.cmx -o tmp/ocamlbuild_pack.cmx
- mv tmp/ocamlbuild_pack.cmx src/ocamlbuild_pack.cmx
- mv tmp/ocamlbuild_pack.o src/ocamlbuild_pack.o
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_plugin.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_executor.ml
- File "src/ocamlbuild_executor.ml", line 86, characters 24-41:
- 86 |   ?(display=(fun f -> f Pervasives.stdout))
-                              ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_unix_plugin.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild.ml
- ocamlopt.opt -I +unix -I src -o ocamlbuild.native unix.cmxa src/ocamlbuild_pack.cmx src/ocamlbuild_plugin.cmx src/ocamlbuild_executor.cmx src/ocamlbuild_unix_plugin.cmx src/ocamlbuild.cmx
- ocamlopt.opt -a -o src/ocamlbuildlib.cmxa src/ocamlbuild_pack.cmx src/ocamlbuild_plugin.cmx src/ocamlbuild_executor.cmx src/ocamlbuild_unix_plugin.cmx
- ocamlc.opt src/ocamlbuild_pack.cmo -I src man/options_man.ml -o man/options_man.byte
- ./man/options_man.byte > man/ocamlbuild.options.1
- cat man/ocamlbuild.header.1 man/ocamlbuild.options.1 man/ocamlbuild.footer.1 > man/ocamlbuild.1
- make ocamlbuild.install
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- rm -f ocamlbuild.install
- touch ocamlbuild.install
- make install-bin-opam
- make[2]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- echo 'bin: [' >> ocamlbuild.install
- echo '  "ocamlbuild.byte" {"ocamlbuild.byte"}' >> ocamlbuild.install
- echo '  "ocamlbuild.native" {"ocamlbuild.native"}' >> ocamlbuild.install
- echo '  "ocamlbuild.native" {"ocamlbuild"}' >> ocamlbuild.install
- echo ']' >> ocamlbuild.install
- echo >> ocamlbuild.install
- make[2]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- make install-lib-opam
- make[2]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- echo 'lib: [' >> ocamlbuild.install
- make install-lib-basics-opam
- make[3]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- echo '  "ocamlbuild.opam" {"opam"}' >> ocamlbuild.install
- echo '  "META"' >> ocamlbuild.install
- for lib in src/signatures.mli src/signatures.cmi src/signatures.cmti; do \
-   echo "  \"$lib\" {\"$(basename $lib)\"}" >> ocamlbuild.install; \
- done
- make[3]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- make install-lib-byte-opam
- make[3]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- for lib in src/ocamlbuildlib.cma src/ocamlbuild.cmo src/ocamlbuild_pack.cmi src/ocamlbuild_plugin.cmi src/ocamlbuild_executor.cmi src/ocamlbuild_unix_plugin.cmi; do \
-   echo "  \"$lib\" {\"$(basename $lib)\"}" >> ocamlbuild.install; \
- done
- make[3]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- make install-lib-native-opam
- make[3]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- for lib in src/ocamlbuildlib.cmxa src/ocamlbuildlib.a src/ocamlbuild.cmx src/ocamlbuild.o src/ocamlbuild_pack.cmx src/ocamlbuild_plugin.cmx src/ocamlbuild_executor.cmx src/ocamlbuild_unix_plugin.cmx src/ocamlbuild_plugin.o src/ocamlbuild_executor.o src/ocamlbuild_unix_plugin.o; do \
-   echo "  \"$lib\" {\"$(basename $lib)\"}" >> ocamlbuild.install; \
- done
- make[3]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- echo ']' >> ocamlbuild.install
- echo >> ocamlbuild.install
- make[2]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- make install-man-opam
- make[2]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- echo 'man: [' >> ocamlbuild.install
- echo '  "man/ocamlbuild.1" {"man1/ocamlbuild.1"}' >> ocamlbuild.install
- echo ']' >> ocamlbuild.install
- echo >> ocamlbuild.install
- make[2]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- make install-doc-opam
- make[2]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- echo 'doc: [' >> ocamlbuild.install
- echo '  "LICENSE"' >> ocamlbuild.install
- echo '  "Changes"' >> ocamlbuild.install
- echo '  "Readme.md"' >> ocamlbuild.install
- echo ']' >> ocamlbuild.install
- make[2]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- if test -d /home/opam/.opam/4.13/lib/ocaml/ocamlbuild; then\
-   >&2 echo "ERROR: Preinstalled ocamlbuild detected at"\
-        "/home/opam/.opam/4.13/lib/ocaml/ocamlbuild";\
-   >&2 echo "Installation aborted; if you want to bypass this"\
-         "safety check, pass CHECK_IF_PREINSTALLED=false to make";\
-   exit 2;\
- fi
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/const.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/loc.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/loc.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/discard_printf.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/discard_printf.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/signatures.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_std.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_std.ml
- File "src/my_std.ml", line 127, characters 20-38:
- 127 |       let compare = Pervasives.compare
-                           ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_unix.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_unix.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tags.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tags.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/display.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/display.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/log.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/log.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/shell.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/shell.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/bool.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/bool.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_ast.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_ast.ml
- ocamllex.opt src/glob_lexer.mll
- 55 states, 419 transitions, table size 2006 bytes
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_lexer.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_lexer.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob.ml
- ocamllex.opt src/lexers.mll
- 251 states, 1051 transitions, table size 5710 bytes
- 4334 additional bytes used for bindings
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/lexers.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/lexers.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/param_tags.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/param_tags.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/command.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/command.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_config.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_where.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_where.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/slurp.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/slurp.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/options.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/options.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/pathname.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/pathname.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/configuration.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/configuration.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/flags.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/flags.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hygiene.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hygiene.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/digest_cache.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/digest_cache.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/resource.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/resource.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/rule.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/rule.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/solver.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/solver.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/report.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/report.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tools.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tools.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/fda.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/fda.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/findlib.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/findlib.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_arch.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_arch.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_utils.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_utils.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_dependencies.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_dependencies.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_compiler.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_compiler.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_tools.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_tools.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_specific.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_specific.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/exit_codes.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/exit_codes.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/plugin.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/plugin.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hooks.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hooks.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/main.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/main.ml
- File "src/main.ml", line 289, characters 4-19:
- 289 |     Pervasives.exit rc
-           ^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "src/main.ml", line 310, characters 10-25:
- 310 |           Pervasives.exit rc_ok
-                 ^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "src/main.ml", line 313, characters 10-25:
- 313 |           Pervasives.exit rc
-                 ^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- mkdir -p tmp
- ocamlc.opt -pack src/const.cmo src/loc.cmo src/discard_printf.cmo src/signatures.cmi src/my_std.cmo src/my_unix.cmo src/tags.cmo src/display.cmo src/log.cmo src/shell.cmo src/bool.cmo src/glob_ast.cmo src/glob_lexer.cmo src/glob.cmo src/lexers.cmo src/param_tags.cmo src/command.cmo src/ocamlbuild_config.cmo src/ocamlbuild_where.cmo src/slurp.cmo src/options.cmo src/pathname.cmo src/configuration.cmo src/flags.cmo src/hygiene.cmo src/digest_cache.cmo src/resource.cmo src/rule.cmo src/solver.cmo src/report.cmo src/tools.cmo src/fda.cmo src/findlib.cmo src/ocaml_arch.cmo src/ocaml_utils.cmo src/ocaml_dependencies.cmo src/ocaml_compiler.cmo src/ocaml_tools.cmo src/ocaml_specific.cmo src/exit_codes.cmo src/plugin.cmo src/hooks.cmo src/main.cmo -o tmp/ocamlbuild_pack.cmo
- mv tmp/ocamlbuild_pack.cmi src/ocamlbuild_pack.cmi
- mv tmp/ocamlbuild_pack.cmo src/ocamlbuild_pack.cmo
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_plugin.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_plugin.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_executor.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_executor.ml
- File "src/ocamlbuild_executor.ml", line 86, characters 24-41:
- 86 |   ?(display=(fun f -> f Pervasives.stdout))
-                              ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_unix_plugin.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_unix_plugin.ml
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild.mli
- ocamlc.opt -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild.ml
- ocamlc.opt -I +unix -I src -o ocamlbuild.byte unix.cma src/ocamlbuild_pack.cmo src/ocamlbuild_plugin.cmo src/ocamlbuild_executor.cmo src/ocamlbuild_unix_plugin.cmo src/ocamlbuild.cmo
- ocamlc.opt -a -o src/ocamlbuildlib.cma src/ocamlbuild_pack.cmo src/ocamlbuild_plugin.cmo src/ocamlbuild_executor.cmo src/ocamlbuild_unix_plugin.cmo
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/const.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/loc.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/discard_printf.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_std.ml
- File "src/my_std.ml", line 127, characters 20-38:
- 127 |       let compare = Pervasives.compare
-                           ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/my_unix.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tags.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/display.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/log.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/shell.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/bool.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_ast.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob_lexer.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/glob.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/lexers.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/param_tags.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/command.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_config.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_where.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/slurp.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/options.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/pathname.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/configuration.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/flags.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hygiene.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/digest_cache.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/resource.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/rule.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/solver.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/report.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/tools.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/fda.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/findlib.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_arch.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_utils.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_dependencies.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_compiler.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_tools.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocaml_specific.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/exit_codes.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/plugin.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/hooks.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/main.ml
- File "src/main.ml", line 289, characters 4-19:
- 289 |     Pervasives.exit rc
-           ^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "src/main.ml", line 310, characters 10-25:
- 310 |           Pervasives.exit rc_ok
-                 ^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "src/main.ml", line 313, characters 10-25:
- 313 |           Pervasives.exit rc
-                 ^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- mkdir -p tmp
- ocamlopt.opt -pack src/const.cmx src/loc.cmx src/discard_printf.cmx src/signatures.cmi src/my_std.cmx src/my_unix.cmx src/tags.cmx src/display.cmx src/log.cmx src/shell.cmx src/bool.cmx src/glob_ast.cmx src/glob_lexer.cmx src/glob.cmx src/lexers.cmx src/param_tags.cmx src/command.cmx src/ocamlbuild_config.cmx src/ocamlbuild_where.cmx src/slurp.cmx src/options.cmx src/pathname.cmx src/configuration.cmx src/flags.cmx src/hygiene.cmx src/digest_cache.cmx src/resource.cmx src/rule.cmx src/solver.cmx src/report.cmx src/tools.cmx src/fda.cmx src/findlib.cmx src/ocaml_arch.cmx src/ocaml_utils.cmx src/ocaml_dependencies.cmx src/ocaml_compiler.cmx src/ocaml_tools.cmx src/ocaml_specific.cmx src/exit_codes.cmx src/plugin.cmx src/hooks.cmx src/main.cmx -o tmp/ocamlbuild_pack.cmx
- mv tmp/ocamlbuild_pack.cmx src/ocamlbuild_pack.cmx
- mv tmp/ocamlbuild_pack.o src/ocamlbuild_pack.o
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_plugin.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_executor.ml
- File "src/ocamlbuild_executor.ml", line 86, characters 24-41:
- 86 |   ?(display=(fun f -> f Pervasives.stdout))
-                              ^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild_unix_plugin.ml
- ocamlopt.opt -for-pack Ocamlbuild_pack -w L -w R -w Z -I src -I +unix -safe-string -bin-annot -strict-sequence -c src/ocamlbuild.ml
- ocamlopt.opt -I +unix -I src -o ocamlbuild.native unix.cmxa src/ocamlbuild_pack.cmx src/ocamlbuild_plugin.cmx src/ocamlbuild_executor.cmx src/ocamlbuild_unix_plugin.cmx src/ocamlbuild.cmx
- ocamlopt.opt -a -o src/ocamlbuildlib.cmxa src/ocamlbuild_pack.cmx src/ocamlbuild_plugin.cmx src/ocamlbuild_executor.cmx src/ocamlbuild_unix_plugin.cmx
- ocamlc.opt src/ocamlbuild_pack.cmo -I src man/options_man.ml -o man/options_man.byte
- ./man/options_man.byte > man/ocamlbuild.options.1
- cat man/ocamlbuild.header.1 man/ocamlbuild.options.1 man/ocamlbuild.footer.1 > man/ocamlbuild.1
- make ocamlbuild.install
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- rm -f ocamlbuild.install
- touch ocamlbuild.install
- make install-bin-opam
- make[2]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- echo 'bin: [' >> ocamlbuild.install
- echo '  "ocamlbuild.byte" {"ocamlbuild.byte"}' >> ocamlbuild.install
- echo '  "ocamlbuild.native" {"ocamlbuild.native"}' >> ocamlbuild.install
- echo '  "ocamlbuild.native" {"ocamlbuild"}' >> ocamlbuild.install
- echo ']' >> ocamlbuild.install
- echo >> ocamlbuild.install
- make[2]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- make install-lib-opam
- make[2]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- echo 'lib: [' >> ocamlbuild.install
- make install-lib-basics-opam
- make[3]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- echo '  "ocamlbuild.opam" {"opam"}' >> ocamlbuild.install
- echo '  "META"' >> ocamlbuild.install
- for lib in src/signatures.mli src/signatures.cmi src/signatures.cmti; do \
-   echo "  \"$lib\" {\"$(basename $lib)\"}" >> ocamlbuild.install; \
- done
- make[3]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- make install-lib-byte-opam
- make[3]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- for lib in src/ocamlbuildlib.cma src/ocamlbuild.cmo src/ocamlbuild_pack.cmi src/ocamlbuild_plugin.cmi src/ocamlbuild_executor.cmi src/ocamlbuild_unix_plugin.cmi; do \
-   echo "  \"$lib\" {\"$(basename $lib)\"}" >> ocamlbuild.install; \
- done
- make[3]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- make install-lib-native-opam
- make[3]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- for lib in src/ocamlbuildlib.cmxa src/ocamlbuildlib.a src/ocamlbuild.cmx src/ocamlbuild.o src/ocamlbuild_pack.cmx src/ocamlbuild_plugin.cmx src/ocamlbuild_executor.cmx src/ocamlbuild_unix_plugin.cmx src/ocamlbuild_plugin.o src/ocamlbuild_executor.o src/ocamlbuild_unix_plugin.o; do \
-   echo "  \"$lib\" {\"$(basename $lib)\"}" >> ocamlbuild.install; \
- done
- make[3]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- echo ']' >> ocamlbuild.install
- echo >> ocamlbuild.install
- make[2]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- make install-man-opam
- make[2]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- echo 'man: [' >> ocamlbuild.install
- echo '  "man/ocamlbuild.1" {"man1/ocamlbuild.1"}' >> ocamlbuild.install
- echo ']' >> ocamlbuild.install
- echo >> ocamlbuild.install
- make[2]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- make install-doc-opam
- make[2]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- echo 'doc: [' >> ocamlbuild.install
- echo '  "LICENSE"' >> ocamlbuild.install
- echo '  "Changes"' >> ocamlbuild.install
- echo '  "Readme.md"' >> ocamlbuild.install
- echo ']' >> ocamlbuild.install
- make[2]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/ocamlbuild.0.14.0'
-> compiled  ocamlbuild.0.14.0
Processing 81/213: [dune: ocaml bootstrap.ml] [num: make install]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "install" "make" "install" (CWD=/home/opam/.opam/4.13/.opam-switch/build/num.1.4)
- make -C src install
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/num.1.4/src'
- install -d /home/opam/.opam/4.13/lib/ocaml
- sed -e 's/%%VERSION%%/1.4/g' META.in > META
- ocamlfind install num META
- Installed /home/opam/.opam/4.13/lib/num/META
- rm -f META
- install -m 644 nums.cma libnums.a big_int.cmi nat.cmi num.cmi ratio.cmi arith_status.cmi big_int.mli nat.mli num.mli ratio.mli arith_status.mli big_int.cmti nat.cmti num.cmti ratio.cmti arith_status.cmti nums.cmxa nums.a int_misc.cmx nat.cmx big_int.cmx arith_flags.cmx ratio.cmx num.cmx arith_status.cmx nums.cmxs /home/opam/.opam/4.13/lib/ocaml
- install -d /home/opam/.opam/4.13/lib/ocaml/stublibs
- install dllnums.so /home/opam/.opam/4.13/lib/ocaml/stublibs
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/num.1.4/src'
- make -C toplevel install
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/num.1.4/toplevel'
- sed -e 's/%%VERSION%%/1.4/g' META.in > META
- ocamlfind install num-top META num_top.cma num_top.cmi num_top_printers.cmi
- Installed /home/opam/.opam/4.13/lib/num-top/num_top_printers.cmi
- Installed /home/opam/.opam/4.13/lib/num-top/num_top.cmi
- Installed /home/opam/.opam/4.13/lib/num-top/num_top.cma
- Installed /home/opam/.opam/4.13/lib/num-top/META
- rm -f META
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/num.1.4/toplevel'
- make -C src install
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/num.1.4/src'
- install -d /home/opam/.opam/4.13/lib/ocaml
- sed -e 's/%%VERSION%%/1.4/g' META.in > META
- ocamlfind install num META
- Installed /home/opam/.opam/4.13/lib/num/META
- rm -f META
- install -m 644 nums.cma libnums.a big_int.cmi nat.cmi num.cmi ratio.cmi arith_status.cmi big_int.mli nat.mli num.mli ratio.mli arith_status.mli big_int.cmti nat.cmti num.cmti ratio.cmti arith_status.cmti nums.cmxa nums.a int_misc.cmx nat.cmx big_int.cmx arith_flags.cmx ratio.cmx num.cmx arith_status.cmx nums.cmxs /home/opam/.opam/4.13/lib/ocaml
- install -d /home/opam/.opam/4.13/lib/ocaml/stublibs
- install dllnums.so /home/opam/.opam/4.13/lib/ocaml/stublibs
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/num.1.4/src'
- make -C toplevel install
- make[1]: Entering directory '/home/opam/.opam/4.13/.opam-switch/build/num.1.4/toplevel'
- sed -e 's/%%VERSION%%/1.4/g' META.in > META
- ocamlfind install num-top META num_top.cma num_top.cmi num_top_printers.cmi
- Installed /home/opam/.opam/4.13/lib/num-top/num_top_printers.cmi
- Installed /home/opam/.opam/4.13/lib/num-top/num_top.cmi
- Installed /home/opam/.opam/4.13/lib/num-top/num_top.cma
- Installed /home/opam/.opam/4.13/lib/num-top/META
- rm -f META
- make[1]: Leaving directory '/home/opam/.opam/4.13/.opam-switch/build/num.1.4/toplevel'
-> installed num.1.4
Processing 81/213: [dune: ocaml bootstrap.ml]
-> installed ocamlbuild.0.14.0
Processing 82/213: [dune: ocaml bootstrap.ml]
Processing 83/213: [dune: ocaml bootstrap.ml] [inotify: ocaml setup.ml]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "ocaml" "setup.ml" "-configure" "--disable-lwt" "--prefix" "/home/opam/.opam/4.13" (CWD=/home/opam/.opam/4.13/.opam-switch/build/inotify.2.3)
- File "./setup.ml", line 1404, characters 23-41:
- 1404 |          let compare = Pervasives.compare
-                               ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "setup.ml", line 3252, characters 16-34:
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "setup.ml", line 6507, characters 33-42:
- Warning 6 [labels-omitted]: label what was omitted in the application of this function.
- File "setup.ml", line 6508, characters 36-45:
- Warning 6 [labels-omitted]: label what was omitted in the application of this function.
- 
- Configuration: 
- ocamlfind: ........................................... /home/opam/.opam/4.13/bin/ocamlfind
- ocamlc: .............................................. /home/opam/.opam/4.13/bin/ocamlc.opt
- ocamlopt: ............................................ /home/opam/.opam/4.13/bin/ocamlopt.opt
- ocamlbuild: .......................................... /home/opam/.opam/4.13/bin/ocamlbuild
- Package name: ........................................ inotify
- Package version: ..................................... 2.3
- os_type: ............................................. Unix
- system: .............................................. linux
- architecture: ........................................ amd64
- ccomp_type: .......................................... cc
- ocaml_version: ....................................... 4.13.1
- standard_library_default: ............................ /home/opam/.opam/4.13/lib/ocaml
- standard_library: .................................... /home/opam/.opam/4.13/lib/ocaml
- bytecomp_c_compiler: ................................. gcc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- native_c_compiler: ................................... gcc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- model: ............................................... default
- ext_obj: ............................................. .o
- ext_asm: ............................................. .s
- ext_lib: ............................................. .a
- ext_dll: ............................................. .so
- default_executable_name: ............................. a.out
- systhread_supported: ................................. true
- Install architecture-independent files dir: .......... /home/opam/.opam/4.13
- Install architecture-dependent files in dir: ......... $prefix
- User executables: .................................... $exec_prefix/bin
- System admin executables: ............................ $exec_prefix/sbin
- Program executables: ................................. $exec_prefix/libexec
- Read-only single-machine data: ....................... $prefix/etc
- Modifiable architecture-independent data: ............ $prefix/com
- Modifiable single-machine data: ...................... $prefix/var
- Object code libraries: ............................... $exec_prefix/lib
- Read-only arch-independent data root: ................ $prefix/share
- Read-only architecture-independent data: ............. $datarootdir
- Info documentation: .................................. $datarootdir/info
- Locale-dependent data: ............................... $datarootdir/locale
- Man documentation: ................................... $datarootdir/man
- Documentation root: .................................. $datarootdir/doc/$pkg_name
- HTML documentation: .................................. $docdir
- DVI documentation: ................................... $docdir
- PDF documentation: ................................... $docdir
- PS documentation: .................................... $docdir
- findlib_version: ..................................... 1.9.1
- is_native: ........................................... true
- suffix_program: ...................................... 
- Remove a file.: ...................................... rm -f
- Remove a directory.: ................................. rm -rf
- Turn ocaml debug flag on: ............................ true
- Turn ocaml profile flag on: .......................... false
- Compiler support generation of .cmxs.: ............... true
- OCamlbuild additional flags: ......................... 
- Build the Lwt wrapper: ............................... false
- Create documentations: ............................... true
- Compile tests executable and library and run them: ... false
- pkg_unix: ............................................ /home/opam/.opam/4.13/lib/ocaml
- pkg_bytes: ........................................... /home/opam/.opam/4.13/lib/bytes
- ocamldoc: ............................................ /home/opam/.opam/4.13/bin/ocamldoc
- 
- File "./setup.ml", line 1404, characters 23-41:
- 1404 |          let compare = Pervasives.compare
-                               ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "setup.ml", line 3252, characters 16-34:
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "setup.ml", line 6507, characters 33-42:
- Warning 6 [labels-omitted]: label what was omitted in the application of this function.
- File "setup.ml", line 6508, characters 36-45:
- Warning 6 [labels-omitted]: label what was omitted in the application of this function.
- 
- Configuration: 
- ocamlfind: ........................................... /home/opam/.opam/4.13/bin/ocamlfind
- ocamlc: .............................................. /home/opam/.opam/4.13/bin/ocamlc.opt
- ocamlopt: ............................................ /home/opam/.opam/4.13/bin/ocamlopt.opt
- ocamlbuild: .......................................... /home/opam/.opam/4.13/bin/ocamlbuild
- Package name: ........................................ inotify
- Package version: ..................................... 2.3
- os_type: ............................................. Unix
- system: .............................................. linux
- architecture: ........................................ amd64
- ccomp_type: .......................................... cc
- ocaml_version: ....................................... 4.13.1
- standard_library_default: ............................ /home/opam/.opam/4.13/lib/ocaml
- standard_library: .................................... /home/opam/.opam/4.13/lib/ocaml
- bytecomp_c_compiler: ................................. gcc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- native_c_compiler: ................................... gcc -O2 -fno-strict-aliasing -fwrapv -pthread -fPIC  -D_FILE_OFFSET_BITS=64 
- model: ............................................... default
- ext_obj: ............................................. .o
- ext_asm: ............................................. .s
- ext_lib: ............................................. .a
- ext_dll: ............................................. .so
- default_executable_name: ............................. a.out
- systhread_supported: ................................. true
- Install architecture-independent files dir: .......... /home/opam/.opam/4.13
- Install architecture-dependent files in dir: ......... $prefix
- User executables: .................................... $exec_prefix/bin
- System admin executables: ............................ $exec_prefix/sbin
- Program executables: ................................. $exec_prefix/libexec
- Read-only single-machine data: ....................... $prefix/etc
- Modifiable architecture-independent data: ............ $prefix/com
- Modifiable single-machine data: ...................... $prefix/var
- Object code libraries: ............................... $exec_prefix/lib
- Read-only arch-independent data root: ................ $prefix/share
- Read-only architecture-independent data: ............. $datarootdir
- Info documentation: .................................. $datarootdir/info
- Locale-dependent data: ............................... $datarootdir/locale
- Man documentation: ................................... $datarootdir/man
- Documentation root: .................................. $datarootdir/doc/$pkg_name
- HTML documentation: .................................. $docdir
- DVI documentation: ................................... $docdir
- PDF documentation: ................................... $docdir
- PS documentation: .................................... $docdir
- findlib_version: ..................................... 1.9.1
- is_native: ........................................... true
- suffix_program: ...................................... 
- Remove a file.: ...................................... rm -f
- Remove a directory.: ................................. rm -rf
- Turn ocaml debug flag on: ............................ true
- Turn ocaml profile flag on: .......................... false
- Compiler support generation of .cmxs.: ............... true
- OCamlbuild additional flags: ......................... 
- Build the Lwt wrapper: ............................... false
- Create documentations: ............................... true
- Compile tests executable and library and run them: ... false
- pkg_unix: ............................................ /home/opam/.opam/4.13/lib/ocaml
- pkg_bytes: ........................................... /home/opam/.opam/4.13/lib/bytes
- ocamldoc: ............................................ /home/opam/.opam/4.13/bin/ocamldoc
- 
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "ocaml" "setup.ml" "-build" (CWD=/home/opam/.opam/4.13/.opam-switch/build/inotify.2.3)
- File "./setup.ml", line 1404, characters 23-41:
- 1404 |          let compare = Pervasives.compare
-                               ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "setup.ml", line 3252, characters 16-34:
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "setup.ml", line 6507, characters 33-42:
- Warning 6 [labels-omitted]: label what was omitted in the application of this function.
- File "setup.ml", line 6508, characters 36-45:
- Warning 6 [labels-omitted]: label what was omitted in the application of this function.
- /home/opam/.opam/4.13/bin/ocamlopt.opt unix.cmxa -I /home/opam/.opam/4.13/lib/ocamlbuild /home/opam/.opam/4.13/lib/ocamlbuild/ocamlbuildlib.cmxa myocamlbuild.ml /home/opam/.opam/4.13/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- File "_tags", line 25, characters 18-25:
- Warning: the tag "pkg_lwt" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 26, characters 18-30:
- Warning: the tag "pkg_lwt.unix" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 31, characters 39-52:
- Warning: the tag "pkg_fileutils" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 32, characters 39-48:
- Warning: the tag "pkg_oUnit" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 39, characters 43-56:
- Warning: the tag "pkg_fileutils" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 40, characters 43-50:
- Warning: the tag "pkg_lwt" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 41, characters 43-55:
- Warning: the tag "pkg_lwt.unix" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 42, characters 43-52:
- Warning: the tag "pkg_oUnit" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 47, characters 23-36:
- Warning: the tag "pkg_fileutils" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 48, characters 23-30:
- Warning: the tag "pkg_lwt" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 49, characters 23-35:
- Warning: the tag "pkg_lwt.unix" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 50, characters 23-32:
- Warning: the tag "pkg_oUnit" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- /home/opam/.opam/4.13/bin/ocamlfind ocamlc -g -c lib/inotify_stubs.c
- mv inotify_stubs.o lib/inotify_stubs.o
- /home/opam/.opam/4.13/bin/ocamlfind ocamlmklib -o lib/inotify_stubs -g lib/inotify_stubs.o
- /home/opam/.opam/4.13/bin/ocamlfind ocamldep -package bytes -package unix -modules lib/inotify.mli > lib/inotify.mli.depends
- /home/opam/.opam/4.13/bin/ocamlfind ocamlc -c -g -annot -bin-annot -I lib -package bytes -package unix -I lib -o lib/inotify.cmi lib/inotify.mli
- /home/opam/.opam/4.13/bin/ocamlfind ocamldep -package bytes -package unix -modules lib/inotify.ml > lib/inotify.ml.depends
- /home/opam/.opam/4.13/bin/ocamlfind ocamlc -c -g -annot -bin-annot -I lib -package bytes -package unix -I lib -o lib/inotify.cmo lib/inotify.ml
- /home/opam/.opam/4.13/bin/ocamlfind ocamlc -a -dllib -linotify_stubs -cclib -linotify_stubs -I lib lib/inotify.cmo -o lib/inotify.cma
- /home/opam/.opam/4.13/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -I lib -package bytes -package unix -I lib -o lib/inotify.cmx lib/inotify.ml
- /home/opam/.opam/4.13/bin/ocamlfind ocamlopt -a -cclib -linotify_stubs -I lib lib/inotify.cmx -o lib/inotify.cmxa
- /home/opam/.opam/4.13/bin/ocamlfind ocamlopt -shared -I lib -I lib lib/inotify.cmxa lib/inotify.cmx -o lib/inotify.cmxs
- File "./setup.ml", line 1404, characters 23-41:
- 1404 |          let compare = Pervasives.compare
-                               ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "setup.ml", line 3252, characters 16-34:
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "setup.ml", line 6507, characters 33-42:
- Warning 6 [labels-omitted]: label what was omitted in the application of this function.
- File "setup.ml", line 6508, characters 36-45:
- Warning 6 [labels-omitted]: label what was omitted in the application of this function.
- /home/opam/.opam/4.13/bin/ocamlopt.opt unix.cmxa -I /home/opam/.opam/4.13/lib/ocamlbuild /home/opam/.opam/4.13/lib/ocamlbuild/ocamlbuildlib.cmxa myocamlbuild.ml /home/opam/.opam/4.13/lib/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
- File "_tags", line 25, characters 18-25:
- Warning: the tag "pkg_lwt" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 26, characters 18-30:
- Warning: the tag "pkg_lwt.unix" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 31, characters 39-52:
- Warning: the tag "pkg_fileutils" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 32, characters 39-48:
- Warning: the tag "pkg_oUnit" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 39, characters 43-56:
- Warning: the tag "pkg_fileutils" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 40, characters 43-50:
- Warning: the tag "pkg_lwt" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 41, characters 43-55:
- Warning: the tag "pkg_lwt.unix" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 42, characters 43-52:
- Warning: the tag "pkg_oUnit" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 47, characters 23-36:
- Warning: the tag "pkg_fileutils" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 48, characters 23-30:
- Warning: the tag "pkg_lwt" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 49, characters 23-35:
- Warning: the tag "pkg_lwt.unix" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- File "_tags", line 50, characters 23-32:
- Warning: the tag "pkg_oUnit" is not used in any flag or dependency declaration, so it will have no effect; it may be a typo. Otherwise you can use `mark_tag_used` in your myocamlbuild.ml to disable this warning.
- /home/opam/.opam/4.13/bin/ocamlfind ocamlc -g -c lib/inotify_stubs.c
- mv inotify_stubs.o lib/inotify_stubs.o
- /home/opam/.opam/4.13/bin/ocamlfind ocamlmklib -o lib/inotify_stubs -g lib/inotify_stubs.o
- /home/opam/.opam/4.13/bin/ocamlfind ocamldep -package bytes -package unix -modules lib/inotify.mli > lib/inotify.mli.depends
- /home/opam/.opam/4.13/bin/ocamlfind ocamlc -c -g -annot -bin-annot -I lib -package bytes -package unix -I lib -o lib/inotify.cmi lib/inotify.mli
- /home/opam/.opam/4.13/bin/ocamlfind ocamldep -package bytes -package unix -modules lib/inotify.ml > lib/inotify.ml.depends
- /home/opam/.opam/4.13/bin/ocamlfind ocamlc -c -g -annot -bin-annot -I lib -package bytes -package unix -I lib -o lib/inotify.cmo lib/inotify.ml
- /home/opam/.opam/4.13/bin/ocamlfind ocamlc -a -dllib -linotify_stubs -cclib -linotify_stubs -I lib lib/inotify.cmo -o lib/inotify.cma
- /home/opam/.opam/4.13/bin/ocamlfind ocamlopt -c -g -annot -bin-annot -I lib -package bytes -package unix -I lib -o lib/inotify.cmx lib/inotify.ml
- /home/opam/.opam/4.13/bin/ocamlfind ocamlopt -a -cclib -linotify_stubs -I lib lib/inotify.cmx -o lib/inotify.cmxa
- /home/opam/.opam/4.13/bin/ocamlfind ocamlopt -shared -I lib -I lib lib/inotify.cmxa lib/inotify.cmx -o lib/inotify.cmxs
-> compiled  inotify.2.3
Processing 83/213: [dune: ocaml bootstrap.ml]
Processing 84/213: [dune: ocaml bootstrap.ml] [inotify: ocaml setup.ml]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "ocaml" "bootstrap.ml" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/dune.2.9.1)
- File "./bootstrap.ml", line 46, characters 17-27:
- 46 |               && String.sub fn 0 (String.length duneboot) = duneboot
-                       ^^^^^^^^^^
- Warning 6 [labels-omitted]: labels pos, len were omitted in the application of this function.
- File "./bootstrap.ml", line 103, characters 28-37:
- 103 |   let args = Array.to_list (Array.sub Sys.argv 1 (Array.length Sys.argv - 1)) in
-                                   ^^^^^^^^^
- Warning 6 [labels-omitted]: labels pos, len were omitted in the application of this function.
- ocamlc -output-complete-exe -w -24 -g -o .duneboot.exe -I boot unix.cma boot/libs.ml boot/duneboot.ml
- ./.duneboot.exe -j 127
- cd _boot && /home/opam/.opam/4.13/bin/ocamlopt.opt -c -g -no-alias-deps -w -49 -I +threads cmdliner_base.ml
- File "vendor/cmdliner/src/cmdliner_base.ml", line 158, characters 14-27:
- Warning 6 [labels-omitted]: labels kind, ambs were omitted in the application of this function.
- cd _boot && /home/opam/.opam/4.13/bin/ocamlopt.opt -c -g -no-alias-deps -w -49 -I +threads cmdliner_docgen.ml
- File "vendor/cmdliner/src/cmdliner_docgen.ml", line 278, characters 23-39:
- Warning 6 [labels-omitted]: label sec was omitted in the application of this function.
- File "vendor/cmdliner/src/cmdliner_docgen.ml", line 293, characters 22-56:
- Warning 6 [labels-omitted]: label sec was omitted in the application of this function.
- File "vendor/cmdliner/src/cmdliner_docgen.ml", line 294, characters 35-51:
- Warning 6 [labels-omitted]: label sec was omitted in the application of this function.
- File "vendor/cmdliner/src/cmdliner_docgen.ml", line 295, characters 36-52:
- Warning 6 [labels-omitted]: label sec was omitted in the application of this function.
- cd _boot && /home/opam/.opam/4.13/bin/ocamlopt.opt -c -g -no-alias-deps -w -49 -I +threads cmdliner_cline.ml
- File "vendor/cmdliner/src/cmdliner_cline.ml", line 128, characters 20-47:
- Warning 6 [labels-omitted]: labels kind, ambs were omitted in the application of this function.
- cd _boot && /home/opam/.opam/4.13/bin/ocamlopt.opt -c -g -no-alias-deps -w -49 -I +threads cmdliner_arg.ml
- File "vendor/cmdliner/src/cmdliner_arg.ml", line 193, characters 24-50:
- Warning 6 [labels-omitted]: label err was omitted in the application of this function.
- File "vendor/cmdliner/src/cmdliner_arg.ml", line 243, characters 24-50:
- Warning 6 [labels-omitted]: label err was omitted in the application of this function.
- File "vendor/cmdliner/src/cmdliner_arg.ml", line 260, characters 10-36:
- Warning 6 [labels-omitted]: label pos was omitted in the application of this function.
- cd _boot && /home/opam/.opam/4.13/bin/ocamlopt.opt -c -g -no-alias-deps -w -49 -I +threads cmdliner.ml
- File "vendor/cmdliner/src/cmdliner.ml", line 195, characters 25-47:
- Warning 6 [labels-omitted]: label errs was omitted in the application of this function.
- 

- File "./bootstrap.ml", line 46, characters 17-27:
- 46 |               && String.sub fn 0 (String.length duneboot) = duneboot
-                       ^^^^^^^^^^
- Warning 6 [labels-omitted]: labels pos, len were omitted in the application of this function.
- File "./bootstrap.ml", line 103, characters 28-37:
- 103 |   let args = Array.to_list (Array.sub Sys.argv 1 (Array.length Sys.argv - 1)) in
-                                   ^^^^^^^^^
- Warning 6 [labels-omitted]: labels pos, len were omitted in the application of this function.
- ocamlc -output-complete-exe -w -24 -g -o .duneboot.exe -I boot unix.cma boot/libs.ml boot/duneboot.ml
- ./.duneboot.exe -j 127
- cd _boot && /home/opam/.opam/4.13/bin/ocamlopt.opt -c -g -no-alias-deps -w -49 -I +threads cmdliner_base.ml
- File "vendor/cmdliner/src/cmdliner_base.ml", line 158, characters 14-27:
- Warning 6 [labels-omitted]: labels kind, ambs were omitted in the application of this function.
- cd _boot && /home/opam/.opam/4.13/bin/ocamlopt.opt -c -g -no-alias-deps -w -49 -I +threads cmdliner_docgen.ml
- File "vendor/cmdliner/src/cmdliner_docgen.ml", line 278, characters 23-39:
- Warning 6 [labels-omitted]: label sec was omitted in the application of this function.
- File "vendor/cmdliner/src/cmdliner_docgen.ml", line 293, characters 22-56:
- Warning 6 [labels-omitted]: label sec was omitted in the application of this function.
- File "vendor/cmdliner/src/cmdliner_docgen.ml", line 294, characters 35-51:
- Warning 6 [labels-omitted]: label sec was omitted in the application of this function.
- File "vendor/cmdliner/src/cmdliner_docgen.ml", line 295, characters 36-52:
- Warning 6 [labels-omitted]: label sec was omitted in the application of this function.
- cd _boot && /home/opam/.opam/4.13/bin/ocamlopt.opt -c -g -no-alias-deps -w -49 -I +threads cmdliner_cline.ml
- File "vendor/cmdliner/src/cmdliner_cline.ml", line 128, characters 20-47:
- Warning 6 [labels-omitted]: labels kind, ambs were omitted in the application of this function.
- cd _boot && /home/opam/.opam/4.13/bin/ocamlopt.opt -c -g -no-alias-deps -w -49 -I +threads cmdliner_arg.ml
- File "vendor/cmdliner/src/cmdliner_arg.ml", line 193, characters 24-50:
- Warning 6 [labels-omitted]: label err was omitted in the application of this function.
- File "vendor/cmdliner/src/cmdliner_arg.ml", line 243, characters 24-50:
- Warning 6 [labels-omitted]: label err was omitted in the application of this function.
- File "vendor/cmdliner/src/cmdliner_arg.ml", line 260, characters 10-36:
- Warning 6 [labels-omitted]: label pos was omitted in the application of this function.
- cd _boot && /home/opam/.opam/4.13/bin/ocamlopt.opt -c -g -no-alias-deps -w -49 -I +threads cmdliner.ml
- File "vendor/cmdliner/src/cmdliner.ml", line 195, characters 25-47:
- Warning 6 [labels-omitted]: label errs was omitted in the application of this function.
- 

Processing 84/213: [dune: ./dune.exe build] [inotify: ocaml setup.ml]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "./dune.exe" "build" "-p" "dune" "--profile" "dune-bootstrap" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/dune.2.9.1)
-> compiled  dune.2.9.1
Processing 84/213: [inotify: ocaml setup.ml]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "install" "ocaml" "setup.ml" "-install" (CWD=/home/opam/.opam/4.13/.opam-switch/build/inotify.2.3)
- File "./setup.ml", line 1404, characters 23-41:
- 1404 |          let compare = Pervasives.compare
-                               ^^^^^^^^^^^^^^^^^^
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "setup.ml", line 3252, characters 16-34:
- Alert deprecated: module Stdlib.Pervasives
- Use Stdlib instead.
- 
- If you need to stay compatible with OCaml < 4.07, you can use the 
- stdlib-shims library: https://github.com/ocaml/stdlib-shims
- File "setup.ml", line 6507, characters 33-42:
- Warning 6 [labels-omitted]: label what was omitted in the application of this function.
- File "setup.ml", line 6508, characters 36-45:
- Warning 6 [labels-omitted]: label what was omitted in the application of this function.
- Installed /home/opam/.opam/4.13/lib/inotify/inotify.mli
- Installed /home/opam/.opam/4.13/lib/inotify/libinotify_stubs.a
- Installed /home/opam/.opam/4.13/lib/inotify/inotify.cma
- Installed /home/opam/.opam/4.13/lib/inotify/inotify.cmxa
- Installed /home/opam/.opam/4.13/lib/inotify/inotify.a
- Installed /home/opam/.opam/4.13/lib/inotify/inotify.cmxs
- Installed /home/opam/.opam/4.13/lib/inotify/inotify.cmi
- Installed /home/opam/.opam/4.13/lib/inotify/inotify.cmti
- Installed /home/opam/.opam/4.13/lib/inotify/inotify.cmt
- Installed /home/opam/.opam/4.13/lib/inotify/inotify.annot
- Installed /home/opam/.opam/4.13/lib/inotify/inotify.cmx
- Installed /home/opam/.opam/4.13/lib/stublibs/dllinotify_stubs.so
- Installed /home/opam/.opam/4.13/lib/stublibs/dllinotify_stubs.so.owner
- ocamlfind: [WARNING] You have installed DLLs but the directory /home/opam/.opam/4.13/lib/stublibs is not mentioned in ld.conf
- Installed /home/opam/.opam/4.13/lib/inotify/META
-> installed inotify.2.3
-> installed dune.2.9.1
Processing 86/213: [csexp: dune build]
Processing 87/213: [csexp: dune build] [jane-street-headers: dune build]
Processing 88/213: [csexp: dune build] [jane-street-headers: dune build] [ocaml-compiler-libs: dune build]
Processing 89/213: [csexp: dune build] [jane-street-headers: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build]
Processing 90/213: [csexp: dune build] [jane-street-headers: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [ppx_derivers: dune build]
Processing 91/213: [csexp: dune build] [jane-street-headers: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [ppx_derivers: dune build] [re: dune build]
Processing 92/213: [csexp: dune build] [jane-street-headers: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [ppx_derivers: dune build] [re: dune build] [result: dune build]
Processing 93/213: [csexp: dune build] [jane-street-headers: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [ppx_derivers: dune build] [re: dune build] [result: dune build] [sexplib0: dune build]
Processing 94/213: [csexp: dune build] [jane-street-headers: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [ppx_derivers: dune build] [re: dune build] [result: dune build] [sexplib0: dune build] [spawn: dune build]
Processing 95/213: [csexp: dune build] [jane-street-headers: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [ppx_derivers: dune build] [re: dune build] [result: dune build] [sexplib0: dune build] [spawn: dune build] [stdlib-shims: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "jane-street-headers" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/jane-street-headers.v0.14.0)
-> compiled  jane-street-headers.v0.14.0
Processing 95/213: [csexp: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [ppx_derivers: dune build] [re: dune build] [result: dune build] [sexplib0: dune build] [spawn: dune build] [stdlib-shims: dune build]
-> installed jane-street-headers.v0.14.0
Processing 96/213: [csexp: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [ppx_derivers: dune build] [re: dune build] [result: dune build] [sexplib0: dune build] [spawn: dune build] [stdlib-shims: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_derivers" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_derivers.1.2.1)
-> compiled  ppx_derivers.1.2.1
Processing 96/213: [csexp: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [re: dune build] [result: dune build] [sexplib0: dune build] [spawn: dune build] [stdlib-shims: dune build]
-> installed ppx_derivers.1.2.1
Processing 97/213: [csexp: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [re: dune build] [result: dune build] [sexplib0: dune build] [spawn: dune build] [stdlib-shims: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "csexp" "-j" "127" "@install" (CWD=/home/opam/.opam/4.13/.opam-switch/build/csexp.1.5.1)
-> compiled  csexp.1.5.1
Processing 97/213: [ocaml-compiler-libs: dune build] [octavius: dune build] [re: dune build] [result: dune build] [sexplib0: dune build] [spawn: dune build] [stdlib-shims: dune build]
-> installed csexp.1.5.1
Processing 98/213: [ocaml-compiler-libs: dune build] [octavius: dune build] [re: dune build] [result: dune build] [sexplib0: dune build] [spawn: dune build] [stdlib-shims: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "result" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/result.1.5)
-> compiled  result.1.5
Processing 98/213: [ocaml-compiler-libs: dune build] [octavius: dune build] [re: dune build] [sexplib0: dune build] [spawn: dune build] [stdlib-shims: dune build]
-> installed result.1.5
Processing 99/213: [ocaml-compiler-libs: dune build] [octavius: dune build] [re: dune build] [sexplib0: dune build] [spawn: dune build] [stdlib-shims: dune build]
Processing 100/213: [dune-configurator: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [re: dune build] [sexplib0: dune build] [spawn: dune build] [stdlib-shims: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "sexplib0" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/sexplib0.v0.14.0)
-> compiled  sexplib0.v0.14.0
Processing 100/213: [dune-configurator: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [re: dune build] [spawn: dune build] [stdlib-shims: dune build]
-> installed sexplib0.v0.14.0
Processing 101/213: [dune-configurator: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [re: dune build] [spawn: dune build] [stdlib-shims: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "spawn" "-j" "127" "@install" (CWD=/home/opam/.opam/4.13/.opam-switch/build/spawn.v0.14.0)
-> compiled  spawn.v0.14.0
Processing 101/213: [dune-configurator: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [re: dune build] [stdlib-shims: dune build]
-> installed spawn.v0.14.0
Processing 102/213: [dune-configurator: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [re: dune build] [stdlib-shims: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "stdlib-shims" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/stdlib-shims.0.3.0)
-        ocaml (internal)
- File "/home/opam/.opam/4.13/.opam-switch/build/stdlib-shims.0.3.0/_build/.dune/default/src/dune.ml", line 28, characters 14-37:
- 28 |   Hashtbl.add Toploop.directive_table "require"
-                    ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "/home/opam/.opam/4.13/.opam-switch/build/stdlib-shims.0.3.0/_build/.dune/default/src/dune.ml", line 30, characters 14-37:
- 30 |   Hashtbl.add Toploop.directive_table "use"
-                    ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "/home/opam/.opam/4.13/.opam-switch/build/stdlib-shims.0.3.0/_build/.dune/default/src/dune.ml", line 34, characters 14-37:
- 34 |   Hashtbl.add Toploop.directive_table "use_mod"
-                    ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
-        ocaml (internal)
- File "/home/opam/.opam/4.13/.opam-switch/build/stdlib-shims.0.3.0/_build/.dune/default/src/dune.ml", line 28, characters 14-37:
- 28 |   Hashtbl.add Toploop.directive_table "require"
-                    ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "/home/opam/.opam/4.13/.opam-switch/build/stdlib-shims.0.3.0/_build/.dune/default/src/dune.ml", line 30, characters 14-37:
- 30 |   Hashtbl.add Toploop.directive_table "use"
-                    ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
- File "/home/opam/.opam/4.13/.opam-switch/build/stdlib-shims.0.3.0/_build/.dune/default/src/dune.ml", line 34, characters 14-37:
- 34 |   Hashtbl.add Toploop.directive_table "use_mod"
-                    ^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Toploop.directive_table
-> compiled  stdlib-shims.0.3.0
Processing 102/213: [dune-configurator: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [re: dune build]
-> installed stdlib-shims.0.3.0
Processing 103/213: [dune-configurator: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build] [re: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "re" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/re.1.10.3)
-> compiled  re.1.10.3
Processing 103/213: [dune-configurator: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build]
-> installed re.1.10.3
Processing 104/213: [dune-configurator: dune build] [ocaml-compiler-libs: dune build] [octavius: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "octavius" "-j" "127" "@install" (CWD=/home/opam/.opam/4.13/.opam-switch/build/octavius.1.2.2)
-> compiled  octavius.1.2.2
Processing 104/213: [dune-configurator: dune build] [ocaml-compiler-libs: dune build]
-> installed octavius.1.2.2
Processing 105/213: [dune-configurator: dune build] [ocaml-compiler-libs: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ocaml-compiler-libs" "-j" "127" "@install" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ocaml-compiler-libs.v0.12.4)
-> compiled  ocaml-compiler-libs.v0.12.4
Processing 105/213: [dune-configurator: dune build]
-> installed ocaml-compiler-libs.v0.12.4
Processing 106/213: [dune-configurator: dune build]
Processing 107/213: [dune-configurator: dune build] [ppxlib: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "dune-configurator" "-j" "127" "@install" (CWD=/home/opam/.opam/4.13/.opam-switch/build/dune-configurator.2.9.1)
-> compiled  dune-configurator.2.9.1
Processing 107/213: [ppxlib: dune build]
-> installed dune-configurator.2.9.1
Processing 108/213: [ppxlib: dune build]
Processing 109/213: [base: dune build] [ppxlib: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "base" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/base.v0.14.1)
-> compiled  base.v0.14.1
Processing 109/213: [ppxlib: dune build]
-> installed base.v0.14.1
Processing 110/213: [ppxlib: dune build]
Processing 111/213: [fieldslib: dune build] [ppxlib: dune build]
Processing 112/213: [fieldslib: dune build] [parsexp: dune build] [ppxlib: dune build]
Processing 113/213: [fieldslib: dune build] [parsexp: dune build] [ppxlib: dune build] [stdio: dune build]
Processing 114/213: [fieldslib: dune build] [parsexp: dune build] [ppxlib: dune build] [stdio: dune build] [typerep: dune build]
Processing 115/213: [fieldslib: dune build] [parsexp: dune build] [ppxlib: dune build] [stdio: dune build] [typerep: dune build] [variantslib: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "fieldslib" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/fieldslib.v0.14.0)
-> compiled  fieldslib.v0.14.0
Processing 115/213: [parsexp: dune build] [ppxlib: dune build] [stdio: dune build] [typerep: dune build] [variantslib: dune build]
-> installed fieldslib.v0.14.0
Processing 116/213: [parsexp: dune build] [ppxlib: dune build] [stdio: dune build] [typerep: dune build] [variantslib: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "variantslib" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/variantslib.v0.14.0)
-> compiled  variantslib.v0.14.0
Processing 116/213: [parsexp: dune build] [ppxlib: dune build] [stdio: dune build] [typerep: dune build]
-> installed variantslib.v0.14.0
Processing 117/213: [parsexp: dune build] [ppxlib: dune build] [stdio: dune build] [typerep: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "stdio" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/stdio.v0.14.0)
-> compiled  stdio.v0.14.0
Processing 117/213: [parsexp: dune build] [ppxlib: dune build] [typerep: dune build]
-> installed stdio.v0.14.0
Processing 118/213: [parsexp: dune build] [ppxlib: dune build] [typerep: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "typerep" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/typerep.v0.14.0)
-> compiled  typerep.v0.14.0
Processing 118/213: [parsexp: dune build] [ppxlib: dune build]
-> installed typerep.v0.14.0
Processing 119/213: [parsexp: dune build] [ppxlib: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "parsexp" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/parsexp.v0.14.1)
-> compiled  parsexp.v0.14.1
Processing 119/213: [ppxlib: dune build]
-> installed parsexp.v0.14.1
Processing 120/213: [ppxlib: dune build]
Processing 121/213: [ppxlib: dune build] [sexplib: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "sexplib" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/sexplib.v0.14.0)
-> compiled  sexplib.v0.14.0
Processing 121/213: [ppxlib: dune build]
-> installed sexplib.v0.14.0
Processing 122/213: [ppxlib: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppxlib" "-j" "127" "@install" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppxlib.0.23.0)
-> compiled  ppxlib.0.23.0
-> installed ppxlib.0.23.0
Processing 124/213: [ppx_cold: dune build]
Processing 125/213: [ppx_cold: dune build] [ppx_compare: dune build]
Processing 126/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build]
Processing 127/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build]
Processing 128/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build]
Processing 129/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build]
Processing 130/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build]
Processing 131/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build]
Processing 132/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build]
Processing 133/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build]
Processing 134/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build]
Processing 135/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build]
Processing 136/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build]
Processing 137/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build]
Processing 138/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optcomp: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_optcomp" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_optcomp.v0.14.3)
-> compiled  ppx_optcomp.v0.14.3
Processing 138/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_optcomp.v0.14.3
Processing 139/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_enumerate: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_enumerate" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_enumerate.v0.14.0)
-> compiled  ppx_enumerate.v0.14.0
Processing 139/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_enumerate.v0.14.0
Processing 140/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_stable: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_stable" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_stable.v0.14.1)
-> compiled  ppx_stable.v0.14.1
Processing 140/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_stable.v0.14.1
Processing 141/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_fields_conv: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_fields_conv" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_fields_conv.v0.14.2)
-> compiled  ppx_fields_conv.v0.14.2
Processing 141/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_fields_conv.v0.14.2
Processing 142/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_let: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_let" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_let.v0.14.0)
-> compiled  ppx_let.v0.14.0
Processing 142/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_let.v0.14.0
Processing 143/213: [ppx_cold: dune build] [ppx_compare: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_cold" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_cold.v0.14.0)
-> compiled  ppx_cold.v0.14.0
Processing 143/213: [ppx_compare: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_cold.v0.14.0
Processing 144/213: [ppx_compare: dune build] [ppx_fixed_literal: dune build] [ppx_here: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_here" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_here.v0.14.0)
-> compiled  ppx_here.v0.14.0
Processing 144/213: [ppx_compare: dune build] [ppx_fixed_literal: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_here.v0.14.0
Processing 145/213: [ppx_compare: dune build] [ppx_fixed_literal: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_typerep_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_typerep_conv" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_typerep_conv.v0.14.2)
-> compiled  ppx_typerep_conv.v0.14.2
Processing 145/213: [ppx_compare: dune build] [ppx_fixed_literal: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_typerep_conv.v0.14.2
Processing 146/213: [ppx_compare: dune build] [ppx_fixed_literal: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_pipebang: dune build] [ppx_sexp_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_pipebang" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_pipebang.v0.14.0)
-> compiled  ppx_pipebang.v0.14.0
Processing 146/213: [ppx_compare: dune build] [ppx_fixed_literal: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_sexp_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_pipebang.v0.14.0
Processing 147/213: [ppx_compare: dune build] [ppx_fixed_literal: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_sexp_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_fixed_literal" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_fixed_literal.v0.14.0)
-> compiled  ppx_fixed_literal.v0.14.0
Processing 147/213: [ppx_compare: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_sexp_conv: dune build] [ppx_variants_conv: dune build]
-> installed ppx_fixed_literal.v0.14.0
Processing 148/213: [ppx_compare: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_sexp_conv: dune build] [ppx_variants_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_variants_conv" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_variants_conv.v0.14.2)
-> compiled  ppx_variants_conv.v0.14.2
Processing 148/213: [ppx_compare: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_sexp_conv: dune build]
-> installed ppx_variants_conv.v0.14.2
Processing 149/213: [ppx_compare: dune build] [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_sexp_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_compare" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_compare.v0.14.0)
-> compiled  ppx_compare.v0.14.0
Processing 149/213: [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_sexp_conv: dune build]
-> installed ppx_compare.v0.14.0
Processing 150/213: [ppx_js_style: dune build] [ppx_optional: dune build] [ppx_sexp_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_optional" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_optional.v0.14.0)
-> compiled  ppx_optional.v0.14.0
Processing 150/213: [ppx_js_style: dune build] [ppx_sexp_conv: dune build]
-> installed ppx_optional.v0.14.0
Processing 151/213: [ppx_js_style: dune build] [ppx_sexp_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_js_style" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_js_style.v0.14.1)
-> compiled  ppx_js_style.v0.14.1
Processing 151/213: [ppx_sexp_conv: dune build]
-> installed ppx_js_style.v0.14.1
Processing 152/213: [ppx_sexp_conv: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_sexp_conv" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_sexp_conv.v0.14.3)
-> compiled  ppx_sexp_conv.v0.14.3
-> installed ppx_sexp_conv.v0.14.3
Processing 154/213: [ppx_assert: dune build]
Processing 155/213: [ppx_assert: dune build] [ppx_custom_printf: dune build]
Processing 156/213: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_hash: dune build]
Processing 157/213: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_hash: dune build] [ppx_sexp_message: dune build]
Processing 158/213: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_hash: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_hash" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_hash.v0.14.0)
-> compiled  ppx_hash.v0.14.0
Processing 158/213: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
-> installed ppx_hash.v0.14.0
Processing 159/213: [ppx_assert: dune build] [ppx_custom_printf: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
Processing 160/213: [ppx_assert: dune build] [ppx_base: dune build] [ppx_custom_printf: dune build] [ppx_sexp_message: dune build] [ppx_sexp_value: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_sexp_message" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_sexp_message.v0.14.1)
-> compiled  ppx_sexp_message.v0.14.1
Processing 160/213: [ppx_assert: dune build] [ppx_base: dune build] [ppx_custom_printf: dune build] [ppx_sexp_value: dune build]
-> installed ppx_sexp_message.v0.14.1
Processing 161/213: [ppx_assert: dune build] [ppx_base: dune build] [ppx_custom_printf: dune build] [ppx_sexp_value: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_assert" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_assert.v0.14.0)
-     ocamlopt runtime-lib/.ppx_assert_lib.objs/native/ppx_assert_lib__Runtime.{cmx,o}
- File "runtime-lib/runtime.ml", line 74, characters 46-51:
- 74 | let test_result_or_eq ~sexpifier ~comparator ?equal ~expect ~got =
-                                                    ^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "runtime-lib/runtime.ml", line 102, characters 60-65:
- 102 | let test_result ~pos ~sexpifier ~comparator ~here ?message ?equal ~expect ~got =
-                                                                   ^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "runtime-lib/runtime.ml", line 102, characters 51-58:
- 102 | let test_result ~pos ~sexpifier ~comparator ~here ?message ?equal ~expect ~got =
-                                                          ^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
-       ocamlc runtime-lib/.ppx_assert_lib.objs/byte/ppx_assert_lib__Runtime.{cmo,cmt}
- File "runtime-lib/runtime.ml", line 74, characters 46-51:
- 74 | let test_result_or_eq ~sexpifier ~comparator ?equal ~expect ~got =
-                                                    ^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "runtime-lib/runtime.ml", line 102, characters 60-65:
- 102 | let test_result ~pos ~sexpifier ~comparator ~here ?message ?equal ~expect ~got =
-                                                                   ^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "runtime-lib/runtime.ml", line 102, characters 51-58:
- 102 | let test_result ~pos ~sexpifier ~comparator ~here ?message ?equal ~expect ~got =
-                                                          ^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
-     ocamlopt runtime-lib/.ppx_assert_lib.objs/native/ppx_assert_lib__Runtime.{cmx,o}
- File "runtime-lib/runtime.ml", line 74, characters 46-51:
- 74 | let test_result_or_eq ~sexpifier ~comparator ?equal ~expect ~got =
-                                                    ^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "runtime-lib/runtime.ml", line 102, characters 60-65:
- 102 | let test_result ~pos ~sexpifier ~comparator ~here ?message ?equal ~expect ~got =
-                                                                   ^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "runtime-lib/runtime.ml", line 102, characters 51-58:
- 102 | let test_result ~pos ~sexpifier ~comparator ~here ?message ?equal ~expect ~got =
-                                                          ^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
-       ocamlc runtime-lib/.ppx_assert_lib.objs/byte/ppx_assert_lib__Runtime.{cmo,cmt}
- File "runtime-lib/runtime.ml", line 74, characters 46-51:
- 74 | let test_result_or_eq ~sexpifier ~comparator ?equal ~expect ~got =
-                                                    ^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "runtime-lib/runtime.ml", line 102, characters 60-65:
- 102 | let test_result ~pos ~sexpifier ~comparator ~here ?message ?equal ~expect ~got =
-                                                                   ^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "runtime-lib/runtime.ml", line 102, characters 51-58:
- 102 | let test_result ~pos ~sexpifier ~comparator ~here ?message ?equal ~expect ~got =
-                                                          ^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
-> compiled  ppx_assert.v0.14.0
Processing 161/213: [ppx_base: dune build] [ppx_custom_printf: dune build] [ppx_sexp_value: dune build]
-> installed ppx_assert.v0.14.0
Processing 162/213: [ppx_base: dune build] [ppx_custom_printf: dune build] [ppx_sexp_value: dune build]
Processing 163/213: [jst-config: dune build] [ppx_base: dune build] [ppx_custom_printf: dune build] [ppx_sexp_value: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_sexp_value" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_sexp_value.v0.14.0)
-> compiled  ppx_sexp_value.v0.14.0
Processing 163/213: [jst-config: dune build] [ppx_base: dune build] [ppx_custom_printf: dune build]
-> installed ppx_sexp_value.v0.14.0
Processing 164/213: [jst-config: dune build] [ppx_base: dune build] [ppx_custom_printf: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_custom_printf" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_custom_printf.v0.14.1)
-> compiled  ppx_custom_printf.v0.14.1
Processing 164/213: [jst-config: dune build] [ppx_base: dune build]
-> installed ppx_custom_printf.v0.14.1
Processing 165/213: [jst-config: dune build] [ppx_base: dune build]
Processing 166/213: [bin_prot: dune build] [jst-config: dune build] [ppx_base: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_base" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_base.v0.14.0)
-> compiled  ppx_base.v0.14.0
Processing 166/213: [bin_prot: dune build] [jst-config: dune build]
-> installed ppx_base.v0.14.0
Processing 167/213: [bin_prot: dune build] [jst-config: dune build]
Processing 168/213: [bin_prot: dune build] [jst-config: dune build] [ppx_string: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "jst-config" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/jst-config.v0.14.1)
-> compiled  jst-config.v0.14.1
Processing 168/213: [bin_prot: dune build] [ppx_string: dune build]
-> installed jst-config.v0.14.1
Processing 169/213: [bin_prot: dune build] [ppx_string: dune build]
Processing 170/213: [bin_prot: dune build] [ppx_string: dune build] [time_now: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "bin_prot" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/bin_prot.v0.14.0)
-> compiled  bin_prot.v0.14.0
Processing 170/213: [ppx_string: dune build] [time_now: dune build]
-> installed bin_prot.v0.14.0
Processing 171/213: [ppx_string: dune build] [time_now: dune build]
Processing 172/213: [ppx_bin_prot: dune build] [ppx_string: dune build] [time_now: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_string" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_string.v0.14.1)
-> compiled  ppx_string.v0.14.1
Processing 172/213: [ppx_bin_prot: dune build] [time_now: dune build]
-> installed ppx_string.v0.14.1
Processing 173/213: [ppx_bin_prot: dune build] [time_now: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "time_now" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/time_now.v0.14.0)
-> compiled  time_now.v0.14.0
Processing 173/213: [ppx_bin_prot: dune build]
-> installed time_now.v0.14.0
Processing 174/213: [ppx_bin_prot: dune build]
Processing 175/213: [ppx_bin_prot: dune build] [ppx_inline_test: dune build]
Processing 176/213: [ppx_bin_prot: dune build] [ppx_inline_test: dune build] [ppx_module_timer: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_bin_prot" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_bin_prot.v0.14.0)
-> compiled  ppx_bin_prot.v0.14.0
Processing 176/213: [ppx_inline_test: dune build] [ppx_module_timer: dune build]
-> installed ppx_bin_prot.v0.14.0
Processing 177/213: [ppx_inline_test: dune build] [ppx_module_timer: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_module_timer" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_module_timer.v0.14.0)
-> compiled  ppx_module_timer.v0.14.0
Processing 177/213: [ppx_inline_test: dune build]
-> installed ppx_module_timer.v0.14.0
Processing 178/213: [ppx_inline_test: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_inline_test" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_inline_test.v0.14.1)
-> compiled  ppx_inline_test.v0.14.1
-> installed ppx_inline_test.v0.14.1
Processing 180/213: [ppx_bench: dune build]
Processing 181/213: [ppx_bench: dune build] [ppx_expect: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_bench" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_bench.v0.14.1)
-> compiled  ppx_bench.v0.14.1
Processing 181/213: [ppx_expect: dune build]
-> installed ppx_bench.v0.14.1
Processing 182/213: [ppx_expect: dune build]
Processing 183/213: [ppx_expect: dune build] [splittable_random: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_expect" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_expect.v0.14.1)
-> compiled  ppx_expect.v0.14.1
Processing 183/213: [splittable_random: dune build]
-> installed ppx_expect.v0.14.1
Processing 184/213: [splittable_random: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "splittable_random" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/splittable_random.v0.14.0)
-> compiled  splittable_random.v0.14.0
-> installed splittable_random.v0.14.0
Processing 186/213: [base_quickcheck: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "base_quickcheck" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/base_quickcheck.v0.14.1)
-> compiled  base_quickcheck.v0.14.1
-> installed base_quickcheck.v0.14.1
Processing 188/213: [ppx_jane: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "ppx_jane" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/ppx_jane.v0.14.0)
-> compiled  ppx_jane.v0.14.0
-> installed ppx_jane.v0.14.0
Processing 190/213: [base_bigstring: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "base_bigstring" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/base_bigstring.v0.14.0)
-> compiled  base_bigstring.v0.14.0
-> installed base_bigstring.v0.14.0
Processing 192/213: [core_kernel: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "core_kernel" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/core_kernel.v0.14.2)
-          gcc src/md5_stubs.o
- md5_stubs.c:11:32: warning: '-pedantic' is not an option that controls warnings [-Wpragmas]
-    11 | #pragma GCC diagnostic ignored "-pedantic"
-       |                                ^~~~~~~~~~~
-> compiled  core_kernel.v0.14.2
-> installed core_kernel.v0.14.2
Processing 194/213: [async_kernel: dune build]
Processing 195/213: [async_kernel: dune build] [protocol_version_header: dune build]
Processing 196/213: [async_kernel: dune build] [protocol_version_header: dune build] [timezone: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "protocol_version_header" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/protocol_version_header.v0.14.0)
-> compiled  protocol_version_header.v0.14.0
Processing 196/213: [async_kernel: dune build] [timezone: dune build]
-> installed protocol_version_header.v0.14.0
Processing 197/213: [async_kernel: dune build] [timezone: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "timezone" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/timezone.v0.14.0)
-> compiled  timezone.v0.14.0
Processing 197/213: [async_kernel: dune build]
-> installed timezone.v0.14.0
Processing 198/213: [async_kernel: dune build]
Processing 199/213: [async_kernel: dune build] [core: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "async_kernel" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/async_kernel.v0.14.0)
-       ocamlc src/.async_kernel.objs/byte/async_kernel__Throttle.{cmo,cmt}
- File "src/throttle.ml", line 283, characters 25-42:
- 283 | let monad_sequence_how ?(how = `Sequential) ~f =
-                                ^^^^^^^^^^^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "src/throttle.ml", line 297, characters 26-43:
- 297 | let monad_sequence_how2 ?(how = `Sequential) ~f =
-                                 ^^^^^^^^^^^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
-     ocamlopt src/.async_kernel.objs/native/async_kernel__Throttle.{cmx,o}
- File "src/throttle.ml", line 283, characters 25-42:
- 283 | let monad_sequence_how ?(how = `Sequential) ~f =
-                                ^^^^^^^^^^^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "src/throttle.ml", line 297, characters 26-43:
- 297 | let monad_sequence_how2 ?(how = `Sequential) ~f =
-                                 ^^^^^^^^^^^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
-       ocamlc src/.async_kernel.objs/byte/async_kernel__Throttle.{cmo,cmt}
- File "src/throttle.ml", line 283, characters 25-42:
- 283 | let monad_sequence_how ?(how = `Sequential) ~f =
-                                ^^^^^^^^^^^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "src/throttle.ml", line 297, characters 26-43:
- 297 | let monad_sequence_how2 ?(how = `Sequential) ~f =
-                                 ^^^^^^^^^^^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
-     ocamlopt src/.async_kernel.objs/native/async_kernel__Throttle.{cmx,o}
- File "src/throttle.ml", line 283, characters 25-42:
- 283 | let monad_sequence_how ?(how = `Sequential) ~f =
-                                ^^^^^^^^^^^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "src/throttle.ml", line 297, characters 26-43:
- 297 | let monad_sequence_how2 ?(how = `Sequential) ~f =
-                                 ^^^^^^^^^^^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
-> compiled  async_kernel.v0.14.0
Processing 199/213: [core: dune build]
-> installed async_kernel.v0.14.0
Processing 200/213: [core: dune build]
Processing 201/213: [async_rpc_kernel: dune build] [core: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "async_rpc_kernel" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/async_rpc_kernel.v0.14.0)
-> compiled  async_rpc_kernel.v0.14.0
Processing 201/213: [core: dune build]
-> installed async_rpc_kernel.v0.14.0
Processing 202/213: [core: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "core" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/core.v0.14.1)
-          gcc src/ocaml_utils_stubs.o
- In file included from ocaml_utils_stubs.c:17:
- ocaml_utils_macros.h:11: warning: "Is_none" redefined
-    11 | #define Is_none(v) (Is_long(v) && Long_val(v) == 0)
-       | 
- In file included from /home/opam/.opam/4.13/lib/jane-street-headers/ocaml_utils.h:6,
-                  from ocaml_utils_stubs.c:16:
- /home/opam/.opam/4.13/lib/ocaml/caml/mlvalues.h:406: note: this is the location of the previous definition
-   406 | #define Is_none(v) ((v) == Val_none)
-       | 
- In file included from ocaml_utils_stubs.c:17:
- ocaml_utils_macros.h:12: warning: "Is_some" redefined
-    12 | #define Is_some(v) (Is_block(v) && Tag_val(v) == 0 && Wosize_val(v) == 1)
-       | 
- In file included from /home/opam/.opam/4.13/lib/jane-street-headers/ocaml_utils.h:6,
-                  from ocaml_utils_stubs.c:16:
- /home/opam/.opam/4.13/lib/ocaml/caml/mlvalues.h:407: note: this is the location of the previous definition
-   407 | #define Is_some(v) Is_block(v)
-       | 
-       ocamlc src/.core.objs/byte/core__Core_thread.{cmo,cmt}
- File "src/core_thread.pp.ml", line 1:
- Alert deprecated: wait_read
- This function no longer does anything
- File "thread.mli", lines 78-79, characters 0-62:
-   Definition
- File "src/core_thread.mli", line 61, characters 0-39:
-   Expected signature
- File "src/core_thread.pp.ml", line 1:
- Alert deprecated: wait_write
- This function no longer does anything
- File "thread.mli", lines 83-84, characters 0-62:
-   Definition
- File "src/core_thread.mli", line 64, characters 0-40:
-   Expected signature
-     ocamlopt src/.core.objs/native/core__Core_thread.{cmx,o}
- File "src/core_thread.pp.ml", line 1:
- Alert deprecated: wait_read
- This function no longer does anything
- File "thread.mli", lines 78-79, characters 0-62:
-   Definition
- File "src/core_thread.mli", line 61, characters 0-39:
-   Expected signature
- File "src/core_thread.pp.ml", line 1:
- Alert deprecated: wait_write
- This function no longer does anything
- File "thread.mli", lines 83-84, characters 0-62:
-   Definition
- File "src/core_thread.mli", line 64, characters 0-40:
-   Expected signature
-> compiled  core.v0.14.1
-> installed core.v0.14.1
Processing 204/213: [async_unix: dune build]
Processing 205/213: [async_unix: dune build] [textutils: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "textutils" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/textutils.v0.14.0)
-> compiled  textutils.v0.14.0
Processing 205/213: [async_unix: dune build]
-> installed textutils.v0.14.0
Processing 206/213: [async_unix: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "async_unix" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/async_unix.v0.14.0)
-       ocamlc src/.async_unix.objs/byte/async_unix__Reader0.{cmi,cmo,cmt}
- File "src/reader0.ml", line 1305, characters 7-16:
- 1305 |       ?exclusive
-               ^^^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "src/reader0.ml", line 1345, characters 19-28:
- 1345 | let gen_load_sexp ?exclusive ~sexp_kind ~file ~a_of_sexp =
-                           ^^^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "src/reader0.ml", line 1360, characters 7-16:
- 1360 |       ?exclusive
-               ^^^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "src/reader0.ml", line 1386, characters 20-29:
- 1386 | let gen_load_sexps ?exclusive ~sexp_kind ~file ~a_of_sexp =
-                            ^^^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
-     ocamlopt src/.async_unix.objs/native/async_unix__Reader0.{cmx,o}
- File "src/reader0.ml", line 1305, characters 7-16:
- 1305 |       ?exclusive
-               ^^^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "src/reader0.ml", line 1345, characters 19-28:
- 1345 | let gen_load_sexp ?exclusive ~sexp_kind ~file ~a_of_sexp =
-                           ^^^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "src/reader0.ml", line 1360, characters 7-16:
- 1360 |       ?exclusive
-               ^^^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
- File "src/reader0.ml", line 1386, characters 20-29:
- 1386 | let gen_load_sexps ?exclusive ~sexp_kind ~file ~a_of_sexp =
-                            ^^^^^^^^^
- Warning 16 [unerasable-optional-argument]: this optional argument cannot be erased.
-> compiled  async_unix.v0.14.0
-> installed async_unix.v0.14.0
Processing 208/213: [async: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "async" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/async.v0.14.0)
-> compiled  async.v0.14.0
-> installed async.v0.14.0
Processing 210/213: [async_find: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "async_find" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/async_find.v0.14.0)
-> compiled  async_find.v0.14.0
-> installed async_find.v0.14.0
Processing 212/213: [async_inotify: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "async_inotify" "-j" "127" (CWD=/home/opam/.opam/4.13/.opam-switch/build/async_inotify.v0.14.0)
-> compiled  async_inotify.v0.14.0
-> installed async_inotify.v0.14.0
Done.
# Run eval $(opam env) to update the current shell environment
2021-11-20 23:50.41 ---> saved as "3247a5c7b7a193ad3ed1ef8022c449608304d6c1734858b1690ab49fbd443f84"
Job succeeded