OCamllabs icon Home|Differences with the last checks|Previous runs


Building on x86-bm-11.ocamllabs.io

(from ocaml/opam:debian-unstable)
2021-09-19 02:35.56 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-2.1 /usr/bin/opam"))
2021-09-19 02:35.56 ---> using "4d29eb3e0b7cd69a97ed90837671d5ca38aa41e2fb94346298af500378eca6fa" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'git://github.com/ocaml/opam-repository.git' ~/opam-repository && git -C ~/opam-repository checkout -q 3ee0d8336d6616a07c1bd28128e70f56cce623e7"))
2021-09-19 02:35.56 ---> using "24f6cbaf649b9317fef2f5de78c697e321f7960ad2b7b2bd29d275ae489192c4" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2021-09-19 02:35.56 ---> using "94a4c48f3191995f9a9b70ed5cd1086f755fcecad41dde6d767dae081409869d" from cache

/: (run (network host)
        (shell "git clone -q 'git://github.com/ocaml/ocaml-beta-repository.git' ~/'beta' && git -C ~/'beta' checkout -q 79aeeadd813bdae424ab53f882f08bee0a4e0b89"))
2021-09-19 02:35.56 ---> using "6c1c09503e5964bb4f81d169dabcbd2c7ab1df67fc923b7ff3b1e2db0d249060" from cache

/: (run (shell "opam repository add --dont-select 'beta' ~/'beta'"))
[beta] Initialised
2021-09-19 02:35.56 ---> using "01f0c327ea2114c276b620211c79f5d5172b7ccbe08ae7a56c86388c2b42729a" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=beta,default 4.02.3"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.02.3"} | "ocaml-system" {= "4.02.3"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-base-compiler.4.02.3  (cached)
-> installed ocaml-base-compiler.4.02.3
-> installed ocaml-config.1
-> installed ocaml.4.02.3
-> installed base-ocamlbuild.base
Done.
# Run eval $(opam env --switch=4.02.3) to update the current shell environment
2021-09-19 02:35.56 ---> using "9770b656e65e990d727834a83c0ee7847d49e8502c6c24fecf618e0e372443a8" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [165 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Ign:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages [8773 kB]
- Fetched 9001 kB in 4s (2293 kB/s)
- Reading package lists...
- 
2021-09-19 02:35.56 ---> using "47ddffd4c8a21a27aa549094b42574bd476189ebe2377fcac7b82441df2e605f" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam install -y ocaml-secondary-compiler"))
The following actions will be performed:
  - install ocaml-secondary-compiler 4.08.1-1

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved ocaml-secondary-compiler.4.08.1-1  (cached)
-> installed ocaml-secondary-compiler.4.08.1-1
Done.
# Run eval $(opam env) to update the current shell environment
2021-09-19 02:35.56 ---> using "42c7cf830656625bb19e1a5fa7d570a4a226dd82efe327f936a389dff5fbeaa5" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"bap-symbol-reader.2.3.0\"\
               \nopam install -vy \"bap-symbol-reader.2.3.0\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"bap-symbol-reader.2.3.0\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] bap-symbol-reader.2.3.0 is not installed.

Nothing to do.
[ERROR] Package conflict!
  * No agreement on the version of ocaml:
    - (invariant) -> ocaml-base-compiler = 4.02.3 -> ocaml = 4.02.3
    - bap-symbol-reader >= 2.3.0 -> ocaml >= 4.08.0
    You can temporarily relax the switch invariant with `--update-invariant'

No solution found, exiting
'opam install -vy bap-symbol-reader.2.3.0' failed.
"/bin/bash" "-c"
"
opam remove -y "bap-symbol-reader.2.3.0"
opam install -vy "bap-symbol-reader.2.3.0"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "bap-symbol-reader.2.3.0" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed