OCamllabs icon Home|Differences with the last checks|Previous runs


Building on phoebe.ocamllabs.io

(from ocaml/opam:debian-unstable)
2021-09-13 21:44.52 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-2.1 /usr/bin/opam"))
2021-09-13 21:44.52 ---> using "4d29eb3e0b7cd69a97ed90837671d5ca38aa41e2fb94346298af500378eca6fa" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'git://github.com/ocaml/opam-repository.git' ~/opam-repository && git -C ~/opam-repository checkout -q a3f679d14a0cdbda37ed0d7b396a55d4f37b2399"))
2021-09-13 21:44.52 ---> using "8312fff5116fe8705c9f5800fc099eaaa003a83cb1d6f0ab4416257ca1b8bc02" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2021-09-13 21:44.52 ---> using "96784e44d680143038979ab3e407e26103abfeace832da2fae875c5b40b9f7b9" from cache

/: (run (network host)
        (shell "git clone -q 'git://github.com/ocaml/ocaml-beta-repository.git' ~/'beta' && git -C ~/'beta' checkout -q 79aeeadd813bdae424ab53f882f08bee0a4e0b89"))
2021-09-13 21:44.52 ---> using "91721fbd08494adf3181e62a7aebef952080b9c009e46773a8179555899edaa8" from cache

/: (run (shell "opam repository add --dont-select 'beta' ~/'beta'"))
[beta] Initialised
2021-09-13 21:44.52 ---> using "3cdad023313afd1b5d4eda3b687943c4a50e0d5fb6d53d9934e48e5bc4d56945" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=beta,default 4.11.2"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-base-compiler" {= "4.11.2"} | "ocaml-system" {= "4.11.2"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-base-compiler.4.11.2  (cached)
-> installed ocaml-base-compiler.4.11.2
-> installed ocaml-config.1
-> installed ocaml.4.11.2
Done.
# Run eval $(opam env --switch=4.11.2) to update the current shell environment
2021-09-13 21:44.52 ---> using "d18101cce2767916bc5c1e0d09a4fe35a1fd8f03cc73c915759d20a75c2489f1" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [165 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Ign:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages [8781 kB]
- Fetched 9009 kB in 2s (5926 kB/s)
- Reading package lists...
- 
2021-09-13 21:44.52 ---> using "4c0f866b2489d69a1c9e8406072eb522a3a9b06da5e9a4db1f068243750b85f5" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"bap-frames.2.1.2\"\
               \nopam install -vy \"bap-frames.2.1.2\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"bap-frames.2.1.2\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
Nothing to do.
[NOTE] bap-frames.2.1.2 is not installed.

[ERROR] Package conflict!
  * No agreement on the version of ocaml-base-compiler:
    - (invariant) -> ocaml-base-compiler = 4.11.2
    - bap-frames >= 2.1.2 -> ocaml < 4.08.0 -> ocaml-base-compiler < 3.07+1
    You can temporarily relax the switch invariant with `--update-invariant'

No solution found, exiting
'opam install -vy bap-frames.2.1.2' failed.
"/bin/bash" "-c"
"
opam remove -y "bap-frames.2.1.2"
opam install -vy "bap-frames.2.1.2"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "bap-frames.2.1.2" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed