OCamllabs icon Home|Differences with the last checks|Previous runs


Building on laodoke.ocamllabs.io

(from ocaml/opam:debian-unstable)
2021-09-03 12:24.48 ---> using "0acd5aeaa8f7bc314514d9795d14a7f12ec72a6a5b11c5904350189734c6859b" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMUTF8 never)

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "sudo ln -f /usr/bin/opam-2.1 /usr/bin/opam"))
2021-09-03 12:24.48 ---> using "4d29eb3e0b7cd69a97ed90837671d5ca38aa41e2fb94346298af500378eca6fa" from cache

/: (run (network host)
        (shell "rm -rf ~/opam-repository && git clone -q 'git://github.com/ocaml/opam-repository.git' ~/opam-repository && git -C ~/opam-repository checkout -q 8fc7af65ccb8f3b3709bf02b749ac492e6700b59"))
2021-09-03 12:24.48 ---> using "eb095db6df41eeadc708604343f7b0ce0892db9136dac67a38046f57271c5802" from cache

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2021-09-03 12:24.48 ---> using "d245c9af6f86b2b97434d338a3fbb8270425ab7dc6ad1b5451665adc9698eabf" from cache

/: (run (network host)
        (shell "git clone -q 'git://github.com/ocaml/ocaml-beta-repository.git' ~/'beta' && git -C ~/'beta' checkout -q 79aeeadd813bdae424ab53f882f08bee0a4e0b89"))
2021-09-03 12:24.48 ---> using "20d9850dcecd0523d6eddecad814e9bbd93882334348605bfa6e15ffd8f5ced5" from cache

/: (run (shell "opam repository add --dont-select 'beta' ~/'beta'"))
[beta] Initialised
2021-09-03 12:24.48 ---> using "6f8879c5099d2146b69bdcec3874fd111cad6c5c42ac63d5f9aa72a228fd8ee8" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=beta,default 4.13.0+trunk"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-variants" {= "4.13.0+trunk"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-variants.4.13.0+trunk  (https://github.com/ocaml/ocaml/archive/4.13.tar.gz)
-> installed ocaml-variants.4.13.0+trunk
-> installed ocaml-config.2
-> installed ocaml.4.13.0
Done.
# Run eval $(opam env --switch=4.13.0+trunk) to update the current shell environment
2021-09-03 12:24.48 ---> using "6712a74d1c1dd02a3a6016afba137eef5268a19bc9ee3f1c1955ef2ed1510eb1" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [165 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Ign:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages [8766 kB]
- Fetched 8994 kB in 2s (5184 kB/s)
- Reading package lists...
- 
2021-09-03 12:24.48 ---> using "efb2002aa60b7139ac6bcdcb20564781fe8c1766de01de081e2c168839e6bf82" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"bolt.1.4\"\
               \nopam install -vy \"bolt.1.4\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"bolt.1.4\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] bolt.1.4 is not installed.

Nothing to do.
[ERROR] Package conflict!
No solution found, exiting
  * No agreement on the version of ocaml:
    - (invariant) -> ocaml-variants = 4.13.0+trunk -> ocaml = 4.13.0
    - bolt >= 1.4 -> ocaml < 4.06.0
    You can temporarily relax the switch invariant with `--update-invariant'

'opam install -vy bolt.1.4' failed.
"/bin/bash" "-c"
"
opam remove -y "bolt.1.4"
opam install -vy "bolt.1.4"
res=$?
if [ $res = 31 ]; then
    if opam show -f x-ci-accept-failures: "bolt.1.4" | grep -q '"debian-unstable"'; then
        echo "This package failed and has been disabled for CI using the 'x-ci-accept-failures' field."
        exit 69
    fi
fi


exit $res
" failed with exit status 20
Failed: Build failed