OCamllabs icon Home|Differences with the last checks|Previous runs


Building on laodoke.ocamllabs.io

(from ocurrent/opam:debian-unstable)
WARNING: Error loading config file: .dockercfg: $HOME is not defined
Unable to find image 'ocurrent/opam:debian-unstable' locally
debian-unstable: Pulling from ocurrent/opam
b2048aa58c5f: Pulling fs layer
412783517da1: Pulling fs layer
2143755e883d: Pulling fs layer
b2048aa58c5f: Verifying Checksum
b2048aa58c5f: Download complete
b2048aa58c5f: Pull complete
2143755e883d: Verifying Checksum
2143755e883d: Download complete
412783517da1: Verifying Checksum
412783517da1: Download complete
412783517da1: Pull complete
2143755e883d: Pull complete
Digest: sha256:d5761fd43bfa1a0782288e3fc959c461a5b030a735a1e16290ff499c79950c05
Status: Downloaded newer image for ocurrent/opam:debian-unstable
2021-07-11 14:09.15 ---> using "ec5d5faa8619574bfe663422158251f52f4b465bd9d157e348e692194b4f4a2a" from cache

/: (user (uid 1000) (gid 1000))

/: (env OPAMPRECISETRACKING 1)

/: (env OPAMDEPEXTYES 1)

/: (env OPAMUTF8 never)

/: (run (network host)
        (shell  "\
               \n        set -e\
               \n        git clone -q git://github.com/kit-ty-kate/opam.git /tmp/opam\
               \n        git -C /tmp/opam checkout -q '72695bfac80dbcd1d2f10287b2626d18d4acc9f2'\
               \n        opam remote set-url default git://github.com/ocaml/opam-repository.git\
               \n        opam pin add -yn /tmp/opam > /dev/null\
               \n        opam install -y opam-devel opam-0install-cudf 'ocamlfind>=1.9'\
               \n        sudo mv \"$(opam var opam-devel:lib)/opam\" /usr/bin/opam\
               \n        rm -rf /tmp/opam /tmp/depext.txt ~/.opam\
               \n        if ! test -d ~/opam-repository; then\
               \n          git clone -q git://github.com/ocaml/opam-repository.git ~/opam-repository\
               \n        else\
               \n          git -C ~/opam-repository pull -q origin master\
               \n        fi\
               \n        git -C ~/opam-repository checkout -q 'fde0c1b501157043509b4a5fc9775c7b4a5b81bd'\
               \n      "))
[default] Initialised

<><> Synchronising pinned packages ><><><><><><><><><><><><><><><><><><><><><><>
[opam-devel.2.1.0~beta4] no changes from git+file:///tmp/opam#HEAD

The following actions will be performed:
  - install ocamlfind          1.9.1
  - install seq                base         [required by re]
  - install cmdliner           1.0.4        [required by opam-devel]
  - install dune               2.9.0        [required by opam-0install-cudf, opam-devel]
  - install ocamlbuild         0.14.0       [required by cudf]
  - install base-bytes         base         [required by extlib]
  - install stdlib-shims       0.3.0        [required by ocamlgraph]
  - install re                 1.9.0        [required by opam-client]
  - install opam-file-format   2.1.3        [required by opam-format]
  - install cppo               1.6.7        [required by extlib]
  - install 0install-solver    2.17         [required by opam-0install-cudf]
  - install ocamlgraph         2.0.0        [required by dose3]
  - install extlib             1.7.7-1      [required by cudf, opam-client]
  - install opam-core          2.1.0~beta4* [required by opam-format]
  - install cudf               0.9-1        [required by opam-0install-cudf]
  - install opam-format        2.1.0~beta4* [required by opam-repository, opam-solver]
  - install opam-0install-cudf 0.4.2
  - install mccs               1.1+13       [required by opam-solver]
  - install dose3              5.0.1-1      [required by opam-solver]
  - install opam-repository    2.1.0~beta4* [required by opam-client]
  - install opam-solver        2.1.0~beta4* [required by opam-client]
  - install opam-state         2.1.0~beta4* [required by opam-client]
  - install opam-client        2.1.0~beta4* [required by opam-devel]
  - install opam-devel         2.1.0~beta4*
===== 24 to install =====

<><> Gathering sources ><><><><><><><><><><><><><><><><><><><><><><><><><><><><>
[cppo.1.6.7] downloaded from https://github.com/ocaml-community/cppo/releases/download/v1.6.7/cppo-v1.6.7.tbz
[0install-solver.2.17] downloaded from https://github.com/0install/0install/releases/download/v2.17/0install-v2.17.tbz
[cmdliner.1.0.4] downloaded from http://erratique.ch/software/cmdliner/releases/cmdliner-1.0.4.tbz
[cudf.0.9-1] downloaded from https://gforge.inria.fr/frs/download.php/36602/cudf-0.9.tar.gz
[dose3.5.0.1-1] downloaded from https://gforge.inria.fr/frs/download.php/file/36063/dose3-5.0.1.tar.gz
[dune.2.9.0] downloaded from https://github.com/ocaml/dune/releases/download/2.9.0/dune-2.9.0.tbz
[extlib.1.7.7-1] downloaded from https://ygrek.org/p/release/ocaml-extlib/extlib-1.7.7.tar.gz
[mccs.1.1+13] downloaded from https://github.com/AltGr/ocaml-mccs/archive/1.1+13.tar.gz
[ocamlbuild.0.14.0] downloaded from https://github.com/ocaml/ocamlbuild/archive/0.14.0.tar.gz
[ocamlgraph.2.0.0] downloaded from https://github.com/backtracking/ocamlgraph/releases/download/2.0.0/ocamlgraph-2.0.0.tbz
[ocamlfind.1.9.1] downloaded from http://download.camlcity.org/download/findlib-1.9.1.tar.gz
[opam-0install-cudf.0.4.2] downloaded from https://github.com/ocaml-opam/opam-0install-solver/releases/download/v0.4.2/opam-0install-cudf-v0.4.2.tbz
[re.1.9.0] downloaded from https://github.com/ocaml/ocaml-re/releases/download/1.9.0/re-1.9.0.tbz
[opam-file-format.2.1.3] downloaded from https://github.com/ocaml/opam-file-format/archive/2.1.3.tar.gz
[stdlib-shims.0.3.0] downloaded from https://github.com/ocaml/stdlib-shims/releases/download/0.3.0/stdlib-shims-0.3.0.tbz

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed seq.base
-> installed cmdliner.1.0.4
-> installed ocamlfind.1.9.1
-> installed base-bytes.base
-> installed ocamlbuild.0.14.0
-> installed dune.2.9.0
-> installed stdlib-shims.0.3.0
-> installed opam-file-format.2.1.3
-> installed 0install-solver.2.17
-> installed cppo.1.6.7
-> installed re.1.9.0
-> installed ocamlgraph.2.0.0
-> installed extlib.1.7.7-1
-> installed opam-core.2.1.0~beta4
-> installed cudf.0.9-1
-> installed opam-0install-cudf.0.4.2
-> installed mccs.1.1+13
-> installed opam-format.2.1.0~beta4
-> installed opam-repository.2.1.0~beta4
-> installed dose3.5.0.1-1
-> installed opam-state.2.1.0~beta4
-> installed opam-solver.2.1.0~beta4
-> installed opam-client.2.1.0~beta4
-> installed opam-devel.2.1.0~beta4
Done.

<><> opam-devel.2.1.0~beta4 installed successfully ><><><><><><><><><><><><><><>
=> The development version of opam has been successfully compiled into /home/opam/.opam/4.11/lib/opam-devel. You should not run it from there, please install the binaries to your PATH, e.g. with
       sudo cp /home/opam/.opam/4.11/lib/opam-devel/opam /usr/local/bin

   If you just want to give it a try without altering your current installation, you could use instead:
       alias opam2="OPAMROOT=~/.opam2 /home/opam/.opam/4.11/lib/opam-devel/opam"
# Run eval $(opam env) to update the current shell environment
2021-07-11 14:09.15 ---> using "fc64ba1332625bff57276b40dd35c036c9d05446d8c148f5e3c18307c7031aa3" from cache

/: (env OPAMEXTERNALSOLVER builtin-0install)

/: (env OPAMCRITERIA +removed)

/: (run (shell "rm -rf ~/.opam && opam init -ya --bare --config ~/.opamrc-sandbox ~/opam-repository"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.


<><> Fetching repository information ><><><><><><><><><><><><><><><><><><><><><>
[default] Initialised

User configuration:
  ~/.profile is already up-to-date.
[NOTE] Make sure that ~/.profile is well sourced in your ~/.bashrc.

2021-07-11 14:09.15 ---> using "00c01ca02e802d5fa7754a4697a8779aaea0a810c62c2e43a8a953539d24c588" from cache

/: (run (network host)
        (shell "git clone -q 'git://github.com/ocaml/ocaml-beta-repository.git' ~/'beta' && git -C ~/'beta' checkout -q 79aeeadd813bdae424ab53f882f08bee0a4e0b89"))
2021-07-11 14:09.15 ---> using "70b043bb9d5c2aea159030596ee4ecd912fa733e5969f78b2d24102111d1ff2e" from cache

/: (run (shell "opam repository add --dont-select 'beta' ~/'beta'"))
[beta] Initialised
2021-07-11 14:09.15 ---> using "52f6336bfa9315ab675de86d2658b0b7077f52d91b1304e791b19cae4bd5c5df" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell "opam switch create --repositories=beta,default 4.13.0+trunk"))

<><> Installing new switch packages <><><><><><><><><><><><><><><><><><><><><><>
Switch invariant: ["ocaml-variants" {= "4.13.0+trunk"}]

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> installed base-bigarray.base
-> installed base-threads.base
-> installed base-unix.base
-> retrieved ocaml-variants.4.13.0+trunk  (https://github.com/ocaml/ocaml/archive/4.13.tar.gz)
-> installed ocaml-variants.4.13.0+trunk
-> installed ocaml-config.2
-> installed ocaml.4.13.0
Done.
# Run eval $(opam env --switch=4.13.0+trunk) to update the current shell environment
2021-07-11 14:09.15 ---> using "c6e74ad66180e07de9785a260c37e40db02292263d5542646f0eebaaae8fbf55" from cache

/: (run (network host)
        (shell "opam update --depexts"))
+ /usr/bin/sudo "apt-get" "update"
- Get:1 http://deb.debian.org/debian unstable InRelease [161 kB]
- Get:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index [63.6 kB]
- Ign:2 http://deb.debian.org/debian unstable/main amd64 Packages.diff/Index
- Get:3 http://deb.debian.org/debian unstable/main amd64 Packages [8638 kB]
- Fetched 8863 kB in 1s (6339 kB/s)
- Reading package lists...
- 
2021-07-11 14:09.15 ---> using "45c732e146af9010190aa2934a3febdcf9672b43e66fcd2035a6c298ae4e9a0d" from cache

/: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
        (network host)
        (shell  "\
               \nopam remove -y \"atdgen.2.2.1\"\
               \nopam install -vy \"atdgen.2.2.1\"\
               \nres=$?\
               \nif [ $res = 31 ]; then\
               \n    if opam show -f x-ci-accept-failures: \"atdgen.2.2.1\" | grep -q '\"debian-unstable\"'; then\
               \n        echo \"This package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\"\
               \n        exit 69\
               \n    fi\
               \nfi\
               \n\
               \n\
               \nexit $res\
               \n"))
[NOTE] atdgen.2.2.1 is not installed.

Nothing to do.
The following actions will be performed:
  - install dune           2.9.0    [required by atdgen]
  - install seq            base     [required by re]
  - install menhirSdk      20210419 [required by menhir]
  - install menhirLib      20210419 [required by menhir]
  - install easy-format    1.3.2    [required by atd]
  - install cppo           1.6.7    [required by yojson]
  - install re             1.9.0    [required by atd, atdgen-runtime]
  - install menhir         20210419 [required by atd]
  - install biniou         1.2.1    [required by atdgen]
  - install atd            2.2.1    [required by atdgen]
  - install yojson         1.7.0    [required by atdgen]
  - install atdgen-runtime 2.2.1    [required by atdgen]
  - install atdgen         2.2.1
===== 13 to install =====

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
Processing  1/39:
Processing  2/39:
Processing  3/39:
-> retrieved atd.2.2.1  (cached)
Processing  4/39:
-> retrieved atdgen.2.2.1  (cached)
Processing  5/39:
-> retrieved atdgen-runtime.2.2.1  (cached)
Processing  6/39:
-> retrieved biniou.1.2.1  (cached)
Processing  7/39:
-> retrieved cppo.1.6.7  (cached)
Processing  8/39:
-> retrieved easy-format.1.3.2  (cached)
Processing  9/39:
-> retrieved menhir.20210419  (cached)
Processing 10/39:
-> retrieved menhirLib.20210419  (cached)
Processing 11/39:
-> retrieved dune.2.9.0  (cached)
Processing 12/39:
Processing 13/39:
Processing 14/39: [dune: ocaml bootstrap.ml]
Processing 15/39: [dune: ocaml bootstrap.ml]
-> installed seq.base
Processing 16/39: [dune: ocaml bootstrap.ml]
-> retrieved menhirSdk.20210419  (cached)
-> retrieved re.1.9.0  (cached)
-> retrieved yojson.1.7.0  (cached)
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "ocaml" "bootstrap.ml" "-j" "71" (CWD=/home/opam/.opam/4.13.0+trunk/.opam-switch/build/dune.2.9.0)
- File "./bootstrap.ml", line 46, characters 17-27:
- 46 |               && String.sub fn 0 (String.length duneboot) = duneboot
-                       ^^^^^^^^^^
- Warning 6 [labels-omitted]: labels pos, len were omitted in the application of this function.
- File "./bootstrap.ml", line 103, characters 28-37:
- 103 |   let args = Array.to_list (Array.sub Sys.argv 1 (Array.length Sys.argv - 1)) in
-                                   ^^^^^^^^^
- Warning 6 [labels-omitted]: labels pos, len were omitted in the application of this function.
- ocamlc -output-complete-exe -w -24 -g -o .duneboot.exe -I boot unix.cma boot/libs.ml boot/duneboot.ml
- ./.duneboot.exe -j 71
- cd _boot && /home/opam/.opam/4.13.0+trunk/bin/ocamlopt.opt -c -g -no-alias-deps -w -49 -I +threads cmdliner_base.ml
- File "vendor/cmdliner/src/cmdliner_base.ml", line 158, characters 14-27:
- Warning 6 [labels-omitted]: labels kind, ambs were omitted in the application of this function.
- cd _boot && /home/opam/.opam/4.13.0+trunk/bin/ocamlopt.opt -c -g -no-alias-deps -w -49 -I +threads cmdliner_docgen.ml
- File "vendor/cmdliner/src/cmdliner_docgen.ml", line 278, characters 23-39:
- Warning 6 [labels-omitted]: label sec was omitted in the application of this function.
- File "vendor/cmdliner/src/cmdliner_docgen.ml", line 293, characters 22-56:
- Warning 6 [labels-omitted]: label sec was omitted in the application of this function.
- File "vendor/cmdliner/src/cmdliner_docgen.ml", line 294, characters 35-51:
- Warning 6 [labels-omitted]: label sec was omitted in the application of this function.
- File "vendor/cmdliner/src/cmdliner_docgen.ml", line 295, characters 36-52:
- Warning 6 [labels-omitted]: label sec was omitted in the application of this function.
- cd _boot && /home/opam/.opam/4.13.0+trunk/bin/ocamlopt.opt -c -g -no-alias-deps -w -49 -I +threads cmdliner_cline.ml
- File "vendor/cmdliner/src/cmdliner_cline.ml", line 128, characters 20-47:
- Warning 6 [labels-omitted]: labels kind, ambs were omitted in the application of this function.
- cd _boot && /home/opam/.opam/4.13.0+trunk/bin/ocamlopt.opt -c -g -no-alias-deps -w -49 -I +threads cmdliner_arg.ml
- File "vendor/cmdliner/src/cmdliner_arg.ml", line 193, characters 24-50:
- Warning 6 [labels-omitted]: label err was omitted in the application of this function.
- File "vendor/cmdliner/src/cmdliner_arg.ml", line 243, characters 24-50:
- Warning 6 [labels-omitted]: label err was omitted in the application of this function.
- File "vendor/cmdliner/src/cmdliner_arg.ml", line 260, characters 10-36:
- Warning 6 [labels-omitted]: label pos was omitted in the application of this function.
- cd _boot && /home/opam/.opam/4.13.0+trunk/bin/ocamlopt.opt -c -g -no-alias-deps -w -49 -I +threads cmdliner.ml
- File "vendor/cmdliner/src/cmdliner.ml", line 195, characters 25-47:
- Warning 6 [labels-omitted]: label errs was omitted in the application of this function.
- 

Processing 16/39: [dune: ./dune.exe build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "./dune.exe" "build" "-p" "dune" "--profile" "dune-bootstrap" "-j" "71" (CWD=/home/opam/.opam/4.13.0+trunk/.opam-switch/build/dune.2.9.0)
-> compiled  dune.2.9.0
-> installed dune.2.9.0
Processing 18/39: [cppo: dune build]
Processing 19/39: [cppo: dune build] [easy-format: dune build]
Processing 20/39: [cppo: dune build] [easy-format: dune build] [menhirLib: dune build]
Processing 21/39: [cppo: dune build] [easy-format: dune build] [menhirLib: dune build] [menhirSdk: dune build]
Processing 22/39: [cppo: dune build] [easy-format: dune build] [menhirLib: dune build] [menhirSdk: dune build] [re: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "easy-format" "-j" "71" (CWD=/home/opam/.opam/4.13.0+trunk/.opam-switch/build/easy-format.1.3.2)
-       ocamlc src/.easy_format.objs/byte/easy_format.{cmo,cmt}
- File "src/easy_format.ml", line 203, characters 16-46:
- 203 |     let tagf0 = pp_get_formatter_tag_functions fmt () in
-                       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_get_formatter_tag_functions
- Use Format.pp_get_formatter_stag_functions.
- File "src/easy_format.ml", line 232, characters 4-34:
- 232 |     pp_set_formatter_tag_functions fmt tagf
-           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_set_formatter_tag_functions
- This function will erase non-string tag formatting functions. Use Format.pp_set_formatter_stag_functions.
- File "src/easy_format.ml", line 264, characters 9-39:
- 264 |         (pp_get_formatter_tag_functions fmt ()) with
-                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_get_formatter_tag_functions
- Use Format.pp_get_formatter_stag_functions.
- File "src/easy_format.ml", line 269, characters 6-36:
- 269 |       pp_set_formatter_tag_functions fmt tagf
-             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_set_formatter_tag_functions
- This function will erase non-string tag formatting functions. Use Format.pp_set_formatter_stag_functions.
- File "src/easy_format.ml", line 322, characters 16-27:
- 322 |     | Some s -> pp_open_tag fmt s
-                       ^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_open_tag
- Use Format.pp_open_stag.
- File "src/easy_format.ml", line 326, characters 16-28:
- 326 |     | Some _ -> pp_close_tag fmt ()
-                       ^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_close_tag
- Use Format.pp_close_stag.
- File "src/easy_format.ml", line 332, characters 10-21:
- 332 |           pp_open_tag fmt tag;
-                 ^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_open_tag
- Use Format.pp_open_stag.
- File "src/easy_format.ml", line 334, characters 10-22:
- 334 |           pp_close_tag fmt ()
-                 ^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_close_tag
- Use Format.pp_close_stag.
-     ocamlopt src/.easy_format.objs/native/easy_format.{cmx,o}
- File "src/easy_format.ml", line 203, characters 16-46:
- 203 |     let tagf0 = pp_get_formatter_tag_functions fmt () in
-                       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_get_formatter_tag_functions
- Use Format.pp_get_formatter_stag_functions.
- File "src/easy_format.ml", line 232, characters 4-34:
- 232 |     pp_set_formatter_tag_functions fmt tagf
-           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_set_formatter_tag_functions
- This function will erase non-string tag formatting functions. Use Format.pp_set_formatter_stag_functions.
- File "src/easy_format.ml", line 264, characters 9-39:
- 264 |         (pp_get_formatter_tag_functions fmt ()) with
-                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_get_formatter_tag_functions
- Use Format.pp_get_formatter_stag_functions.
- File "src/easy_format.ml", line 269, characters 6-36:
- 269 |       pp_set_formatter_tag_functions fmt tagf
-             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_set_formatter_tag_functions
- This function will erase non-string tag formatting functions. Use Format.pp_set_formatter_stag_functions.
- File "src/easy_format.ml", line 322, characters 16-27:
- 322 |     | Some s -> pp_open_tag fmt s
-                       ^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_open_tag
- Use Format.pp_open_stag.
- File "src/easy_format.ml", line 326, characters 16-28:
- 326 |     | Some _ -> pp_close_tag fmt ()
-                       ^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_close_tag
- Use Format.pp_close_stag.
- File "src/easy_format.ml", line 332, characters 10-21:
- 332 |           pp_open_tag fmt tag;
-                 ^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_open_tag
- Use Format.pp_open_stag.
- File "src/easy_format.ml", line 334, characters 10-22:
- 334 |           pp_close_tag fmt ()
-                 ^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_close_tag
- Use Format.pp_close_stag.
-       ocamlc src/.easy_format.objs/byte/easy_format.{cmo,cmt}
- File "src/easy_format.ml", line 203, characters 16-46:
- 203 |     let tagf0 = pp_get_formatter_tag_functions fmt () in
-                       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_get_formatter_tag_functions
- Use Format.pp_get_formatter_stag_functions.
- File "src/easy_format.ml", line 232, characters 4-34:
- 232 |     pp_set_formatter_tag_functions fmt tagf
-           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_set_formatter_tag_functions
- This function will erase non-string tag formatting functions. Use Format.pp_set_formatter_stag_functions.
- File "src/easy_format.ml", line 264, characters 9-39:
- 264 |         (pp_get_formatter_tag_functions fmt ()) with
-                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_get_formatter_tag_functions
- Use Format.pp_get_formatter_stag_functions.
- File "src/easy_format.ml", line 269, characters 6-36:
- 269 |       pp_set_formatter_tag_functions fmt tagf
-             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_set_formatter_tag_functions
- This function will erase non-string tag formatting functions. Use Format.pp_set_formatter_stag_functions.
- File "src/easy_format.ml", line 322, characters 16-27:
- 322 |     | Some s -> pp_open_tag fmt s
-                       ^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_open_tag
- Use Format.pp_open_stag.
- File "src/easy_format.ml", line 326, characters 16-28:
- 326 |     | Some _ -> pp_close_tag fmt ()
-                       ^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_close_tag
- Use Format.pp_close_stag.
- File "src/easy_format.ml", line 332, characters 10-21:
- 332 |           pp_open_tag fmt tag;
-                 ^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_open_tag
- Use Format.pp_open_stag.
- File "src/easy_format.ml", line 334, characters 10-22:
- 334 |           pp_close_tag fmt ()
-                 ^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_close_tag
- Use Format.pp_close_stag.
-     ocamlopt src/.easy_format.objs/native/easy_format.{cmx,o}
- File "src/easy_format.ml", line 203, characters 16-46:
- 203 |     let tagf0 = pp_get_formatter_tag_functions fmt () in
-                       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_get_formatter_tag_functions
- Use Format.pp_get_formatter_stag_functions.
- File "src/easy_format.ml", line 232, characters 4-34:
- 232 |     pp_set_formatter_tag_functions fmt tagf
-           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_set_formatter_tag_functions
- This function will erase non-string tag formatting functions. Use Format.pp_set_formatter_stag_functions.
- File "src/easy_format.ml", line 264, characters 9-39:
- 264 |         (pp_get_formatter_tag_functions fmt ()) with
-                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_get_formatter_tag_functions
- Use Format.pp_get_formatter_stag_functions.
- File "src/easy_format.ml", line 269, characters 6-36:
- 269 |       pp_set_formatter_tag_functions fmt tagf
-             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_set_formatter_tag_functions
- This function will erase non-string tag formatting functions. Use Format.pp_set_formatter_stag_functions.
- File "src/easy_format.ml", line 322, characters 16-27:
- 322 |     | Some s -> pp_open_tag fmt s
-                       ^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_open_tag
- Use Format.pp_open_stag.
- File "src/easy_format.ml", line 326, characters 16-28:
- 326 |     | Some _ -> pp_close_tag fmt ()
-                       ^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_close_tag
- Use Format.pp_close_stag.
- File "src/easy_format.ml", line 332, characters 10-21:
- 332 |           pp_open_tag fmt tag;
-                 ^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_open_tag
- Use Format.pp_open_stag.
- File "src/easy_format.ml", line 334, characters 10-22:
- 334 |           pp_close_tag fmt ()
-                 ^^^^^^^^^^^^
- Alert deprecated: Stdlib.Format.pp_close_tag
- Use Format.pp_close_stag.
-> compiled  easy-format.1.3.2
Processing 22/39: [cppo: dune build] [menhirLib: dune build] [menhirSdk: dune build] [re: dune build]
-> installed easy-format.1.3.2
Processing 23/39: [cppo: dune build] [menhirLib: dune build] [menhirSdk: dune build] [re: dune build]
Processing 24/39: [biniou: dune build] [cppo: dune build] [menhirLib: dune build] [menhirSdk: dune build] [re: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "menhirSdk" "-j" "71" (CWD=/home/opam/.opam/4.13.0+trunk/.opam-switch/build/menhirSdk.20210419)
-> compiled  menhirSdk.20210419
Processing 24/39: [biniou: dune build] [cppo: dune build] [menhirLib: dune build] [re: dune build]
-> installed menhirSdk.20210419
Processing 25/39: [biniou: dune build] [cppo: dune build] [menhirLib: dune build] [re: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "menhirLib" "-j" "71" (CWD=/home/opam/.opam/4.13.0+trunk/.opam-switch/build/menhirLib.20210419)
-         pack lib/pack/menhirLib.{ml,mli}
- Creating menhirLib.ml...
- Creating menhirLib.mli...
-         pack lib/pack/menhirLib.{ml,mli}
- Creating menhirLib.ml...
- Creating menhirLib.mli...
-> compiled  menhirLib.20210419
Processing 25/39: [biniou: dune build] [cppo: dune build] [re: dune build]
-> installed menhirLib.20210419
Processing 26/39: [biniou: dune build] [cppo: dune build] [re: dune build]
Processing 27/39: [biniou: dune build] [cppo: dune build] [menhir: dune build] [re: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "biniou" "-j" "71" (CWD=/home/opam/.opam/4.13.0+trunk/.opam-switch/build/biniou.1.2.1)
-> compiled  biniou.1.2.1
Processing 27/39: [cppo: dune build] [menhir: dune build] [re: dune build]
-> installed biniou.1.2.1
Processing 28/39: [cppo: dune build] [menhir: dune build] [re: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "cppo" "-j" "71" (CWD=/home/opam/.opam/4.13.0+trunk/.opam-switch/build/cppo.1.6.7)
-> compiled  cppo.1.6.7
Processing 28/39: [menhir: dune build] [re: dune build]
-> installed cppo.1.6.7
Processing 29/39: [menhir: dune build] [re: dune build]
Processing 30/39: [menhir: dune build] [re: dune build] [yojson: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "re" "-j" "71" (CWD=/home/opam/.opam/4.13.0+trunk/.opam-switch/build/re.1.9.0)
-> compiled  re.1.9.0
Processing 30/39: [menhir: dune build] [yojson: dune build]
-> installed re.1.9.0
Processing 31/39: [menhir: dune build] [yojson: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "yojson" "-j" "71" (CWD=/home/opam/.opam/4.13.0+trunk/.opam-switch/build/yojson.1.7.0)
-> compiled  yojson.1.7.0
Processing 31/39: [menhir: dune build]
-> installed yojson.1.7.0
Processing 32/39: [menhir: dune build]
Processing 33/39: [atdgen-runtime: dune build] [menhir: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "atdgen-runtime" "-j" "71" "@install" (CWD=/home/opam/.opam/4.13.0+trunk/.opam-switch/build/atdgen-runtime.2.2.1)
-> compiled  atdgen-runtime.2.2.1
Processing 33/39: [menhir: dune build]
-> installed atdgen-runtime.2.2.1
Processing 34/39: [menhir: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "menhir" "-j" "71" (CWD=/home/opam/.opam/4.13.0+trunk/.opam-switch/build/menhir.20210419)
-       menhir src/stage2/parserMessages.check
- Read 101 sample input sentences and 101 error messages.
- Read 101 sample input sentences and 48 error messages.
-       menhir src/stage2/parserMessages.ml
- Read 101 sample input sentences and 48 error messages.
-       menhir src/stage2/parser.{ml,mli}
- Grammar has 56 nonterminal symbols, among which 1 start symbols.
- Grammar has 37 terminal symbols.
- Grammar has 129 productions.
- Built an LR(0) automaton with 194 states.
- The grammar is not SLR(1) -- 5 states have a conflict.
- The construction mode is no-pager.
- Built an LR(1) automaton with 298 states.
- One shift/reduce conflict was silently solved.
- Extra reductions on error were added in 40 states.
- Priority played a role in 0 of these states.
- 152 out of 298 states have a default reduction.
- 102 out of 298 states are represented.
- 44 out of 96 symbols keep track of their start position.
- 48 out of 96 symbols keep track of their end position.
- The action table is 11324 entries; 1610 non-zero; 1359 compressed.
- The action table occupies roughly 2816 bytes.
- The goto table is 16986 entries; 329 non-zero; 636 compressed.
- The goto table occupies roughly 1368 bytes.
- The error table occupies roughly 1448 bytes.
- The default_reduction table occupies roughly 336 bytes.
- The lhs table occupies roughly 168 bytes.
- The trace table occupies roughly 8 bytes.
-> compiled  menhir.20210419
-> installed menhir.20210419
Processing 36/39: [atd: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "atd" "-j" "71" "@install" (CWD=/home/opam/.opam/4.13.0+trunk/.opam-switch/build/atd.2.2.1)
-> compiled  atd.2.2.1
-> installed atd.2.2.1
Processing 38/39: [atdgen: dune build]
+ /home/opam/.opam/opam-init/hooks/sandbox.sh "build" "dune" "build" "-p" "atdgen" "-j" "71" "@install" (CWD=/home/opam/.opam/4.13.0+trunk/.opam-switch/build/atdgen.2.2.1)
-> compiled  atdgen.2.2.1
-> installed atdgen.2.2.1
Done.
# Run eval $(opam env) to update the current shell environment
2021-07-11 14:10.03 ---> saved as "f6354038838eec16576b323a03dda6398a08aad97cdcde83349c26550ba7d9c4"
Job succeeded